# Errors with Marvel indexes when starting second node

**URL:** https://discuss.elastic.co/t/errors-with-marvel-indexes-when-starting-second-node/35182
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [November 20, 2015, 7:12pm UTC](https://discuss.elastic.co/t/errors-with-marvel-indexes-when-starting-second-node/35182 "2015-11-20T19:12:57Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sibyl](https://avatars.discourse-cdn.com/v4/letter/s/b9e5f3/32.png) [@sibyl](https://discuss.elastic.co/u/sibyl)
#### Post date: [November 20, 2015, 7:12pm UTC](https://discuss.elastic.co/t/errors-with-marvel-indexes-when-starting-second-node/35182/1 "2015-11-20T19:12:57Z")

</div>

Hello,

I have a master node and a data node. When I add indexes to my master node and start my data node, I get the errors (BroadcastShardOperationFailedException, IllegalIndexShardStateException). It still sync the indexes and everything seems to be working properly but I would like to fix the errors if possible.

I am new to Elasticsearch so any guidance would be gladly appreciated.

Here are the logs of what's happening exactly :

Error when starting the second node : [http://pastebin.com/trD5hiNv](http://pastebin.com/trD5hiNv)  
Error when disconnecting the second node : [http://pastebin.com/Nb8vvEbg](http://pastebin.com/Nb8vvEbg)

Note : I have been doing tests on my master node with the data node offline adding multiple indexes using a large file in bulk (50mbs file). The problem seems to happen only when I have indexes other than the ones marvel create. If I delete all indexes but the ones from marvel, I don't get any errors. If I add indexes and restart nodes, the errors come back.

Thank you!

---

<div class="post-metadata">

### Author: ![tanguy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tanguy/32/6030_2.png) [@tanguy](https://discuss.elastic.co/u/tanguy)
#### Post date: [November 24, 2015, 1:26pm UTC](https://discuss.elastic.co/t/errors-with-marvel-indexes-when-starting-second-node/35182/2 "2015-11-24T13:26:25Z")

</div>

Hi,

The exceptions occurs because the marvel agent requires the data node to be up. Marvel queries the data node to get stats about indices and shards and if you did not configure HTTP exporters marvel will also try to index data locally.

There's a pull request ([https://github.com/elastic/elasticsearch/pull/14950](https://github.com/elastic/elasticsearch/pull/14950)) on elasticsearch to log at TRACE (and not DEBUG) level some of the exceptions you have.

In case of local exporter, marvel requires data node because it index data. One thing you can do it start with a higher sampling interval (configuration: ̀marvel.agent.interval: 30s`) and once your cluster & nodes are up you update it using the Cluster Update API.

-- Tanguy

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:46pm UTC](https://discuss.elastic.co/t/errors-with-marvel-indexes-when-starting-second-node/35182/3 "2017-07-06T13:46:55Z")

</div>


