# ES 2.4.1 fail on startup

**URL:** https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102
**Category:** Elasticsearch
**Created:** [July 31, 2019, 11:10am UTC](https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102 "2019-07-31T11:10:57Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mhssm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mhssm/32/51305_2.png) [@mhssm](https://discuss.elastic.co/u/mhssm)
#### Post date: [July 31, 2019, 11:10am UTC](https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102/1 "2019-07-31T11:10:57Z")

</div>

I have trouble starting ES 2.4.1 on an Ubuntu 14.04 box. ES has been installed using apt-get and is invoked by init (running as default "elasticsearch" user):

```
admin@LOG:/tmp$ sudo -i service elasticsearch start
 * Starting Elasticsearch Server [fail] 

```

I see no addtional output on the screen other than the shown. Log files are updated but show no content:

```
admin@LOG:/tmp$ ls /var/log/elasticsearch/ -al
total 8
drwxr-xr-x 2 elasticsearch elasticsearch 4096 Jul 31 11:27 .
drwxrwxr-x 14 root syslog 4096 Jul 31 11:26 ..
-rw-r--r-- 1 elasticsearch elasticsearch 0 Jul 31 11:27 elasticsearch_deprecation.log
-rw-r--r-- 1 elasticsearch elasticsearch 0 Jul 31 11:27 elasticsearch_index_indexing_slowlog.log
-rw-r--r-- 1 elasticsearch elasticsearch 0 Jul 31 11:27 elasticsearch_index_search_slowlog.log
-rw-r--r-- 1 elasticsearch elasticsearch 0 Jul 31 13:05 elasticsearch.log

```

The syslog shows no entries - the box has 4Gb memory and jvm.option limits has been set to "1g".

Any ideas?

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [August 1, 2019, 12:32pm UTC](https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102/2 "2019-08-01T12:32:00Z")

</div>

Hey Morten,

if this is using the init script (I am not sure on top of my head, if 14.04 is using sysvinit, upstart or systemd), you can probably shed some more light by calling the init script manually and add `set -x` in there, or by checking `journalctl` if there is any more information in the systemd logs, if that one is being used.

--Alex

---

<div class="post-metadata">

### Author: ![mhssm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mhssm/32/51305_2.png) [@mhssm](https://discuss.elastic.co/u/mhssm)
#### Post date: [August 1, 2019, 1:08pm UTC](https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102/3 "2019-08-01T13:08:35Z")

</div>

Hello Alexander, thanks for getting back.

Actually, I ditched the old 2.4.1 version (had to manually circumvent a crazy requirement on ES as running in the dpkg prerm script to be able to remove the package and deleted several dangling folders as well) . Then moved to the latest 7.3 version which worked almost out of the box. Sadly more errors had to be debugged, for instance that the box I've inherited was low on disk space, so ES went into READ-ONLY mode and threw errors in Kibana.

But, yes, Ubuntu 14.04 is using sysvinit and I could probably have behaved more patiently and done some more debugging.

Thanks again - ES seem to have a responsive community, which is a key to success.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 29, 2019, 1:08pm UTC](https://discuss.elastic.co/t/es-2-4-1-fail-on-startup/193102/4 "2019-08-29T13:08:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
