# ES 5.2 fails to start with setting "index.number\_of\_shards: 2" in elasticsearch.yml

**URL:** <https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654>\
**Category:** Elasticsearch\
**Created:** [April 26, 2017, 6:36am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654 "2017-04-26T06:36:07Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [April 26, 2017, 6:36am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/1 "2017-04-26T06:36:07Z")

</div>

HI,  
I would like to set number of shards into 2 but when i define that in elasticsearch.yml facing error. Can anyone help me to set it on exact file.

I want to set number of shards: 2 and number of replica:1 which file i have to change it.

Anyone clarify me default value for shard and replica.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 26, 2017, 6:38am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/2 "2017-04-26T06:38:20Z")

</div>

What is the error?

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [April 26, 2017, 6:46am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/3 "2017-04-26T06:46:13Z")

</div>

Please find the below error,

```
    *************************************************************************************
Found index level settings on node level configuration.

Since elasticsearch 5.x index level settings can NOT be set on the nodes 
configuration like the elasticsearch.yaml, in system properties or command line 
arguments.In order to upgrade all indices the settings must be updated via the 
/${index}/_settings API. Unless all settings are dynamic all indices must be closed 
in order to apply the upgradeIndices created in the future should use index templates 
to set default values. 

Please ensure all required values are updated on all indices by executing: 

curl -XPUT 'http://localhost:9200/_all/_settings?preserve_existing=true' -d '{
  "index.number_of_shards" : "2"
}'
*************************************************************************************

[2017-04-26T01:44:51,685][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalArgumentException: node settings must not contain any index level settings
	at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:131) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.node.Node.<init>(Node.java:328) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.node.Node.<init>(Node.java:232) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap$6.<init>(Bootstrap.java:241) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:241) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) [elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) [elasticsearch-5.2.1.jar:5.2.1]
[2017-04-26T01:44:51,689][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [qa.elm.node-1] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: node settings must not contain any index level settings
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.2.1.jar:5.2.1]
Caused by: java.lang.IllegalArgumentException: node settings must not contain any index level settings
	at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:131) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.node.Node.<init>(Node.java:328) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.node.Node.<init>(Node.java:232) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap$6.<init>(Bootstrap.java:241) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:241) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-5.2.1.jar:5.2.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.2.1.jar:5.2.1]
	... 6 more
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 26, 2017, 7:16am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/4 "2017-04-26T07:16:01Z")

</div>

Is there anything we can help clarify, as that seems to explain it pretty well?

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [April 26, 2017, 7:19am UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/5 "2017-04-26T07:19:06Z")

</div>

Yes, I need to know how to set shard and replica for new index creation and where i have update those shards value

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [April 26, 2017, 2:59pm UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/6 "2017-04-26T14:59:33Z")

</div>

Use an [index template](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-templates.html).

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [May 2, 2017, 1:11pm UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/7 "2017-05-02T13:11:29Z")

</div>

Thank you @nik9000 issue resolved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 30, 2017, 1:23pm UTC](https://discuss.elastic.co/t/es-5-2-fails-to-start-with-setting-index-number-of-shards-2-in-elasticsearch-yml/83654/8 "2017-05-30T13:23:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
