# ES 5.3.1 - content\_type cannot be user-specified

**URL:** <https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692>\
**Category:** Elasticsearch\
**Created:** [April 26, 2017, 12:07pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692 "2017-04-26T12:07:03Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![christer.n](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christer.n/32/15539_2.png) [@christer.n](https://discuss.elastic.co/u/christer.n)\
**Post date:** [April 26, 2017, 12:07pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692/1 "2017-04-26T12:07:03Z")

</div>

Hi, when spinning up an empty ES instance v5.3.1 everything works fine, after indexing some stuff, and letting it run - adding some templates, mapping templates e.e - when i shut down the instance (CTRL+C) and try to start it again i get the following exception:

Any idea why ?

```
4) Error injecting constructor, ElasticsearchException[java.io.IOException: failed to read [id:20, legacy:false, file:D:\ElasticSearch\elasticsearch-5.3.1\data\nodes\0\_state\global-20.st]]; nested: IOException[failed to read [id:20, legacy:false, file:D:\ElasticSearch\elasticsearch-5.3.1\data\nodes\0\_state\global-20.st]]; nested: ParsingException[[stored script source] failed to parse field [options]]; nested: IllegalArgumentException[content_type cannot be user-specified];
  at org.elasticsearch.gateway.GatewayMetaState.<init>(Unknown Source)
  while locating org.elasticsearch.gateway.GatewayMetaState
for parameter 4 at org.elasticsearch.gateway.GatewayService.<init>(Unknown Source)
  while locating org.elasticsearch.gateway.GatewayService
Caused by: ElasticsearchException[java.io.IOException: failed to read [id:20, legacy:false, file:D:\ElasticSearch\elasticsearch-5.3.1\data\nodes\0\_state\global-20.st]]; nested: IOException[failed to read [id:20, legacy:false, file:D:\ElasticSearch\elasticsearch-5.3.1\data\nodes\0\_state\global-20.st]]; nested: ParsingException[[stored script source] failed to parse field [options]]; nested: IllegalArgumentException[content_type cannot be user-specified];
    at org.elasticsearch.ExceptionsHelper.maybeThrowRuntimeAndSuppress(ExceptionsHelper.java:150)
    at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestState(MetaDataStateFormat.java:334)
    at org.elasticsearch.gateway.MetaStateService.loadGlobalState(MetaStateService.java:113)
    at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:57)
    at org.elasticsearch.gateway.GatewayMetaState.<init>(GatewayMetaState.java:88)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
    at ...
```

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [April 26, 2017, 12:17pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692/2 "2017-04-26T12:17:34Z")

</div>

Unfortunately you have hit this bug: [https://github.com/elastic/elasticsearch/pull/24251](https://github.com/elastic/elasticsearch/pull/24251)

The bug has been fixed and the fix will be available in the forthcoming 5.3.2 release

---

<div class="post-metadata">

**Author:** ![christer.n](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christer.n/32/15539_2.png) [@christer.n](https://discuss.elastic.co/u/christer.n)\
**Post date:** [April 26, 2017, 12:31pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692/3 "2017-04-26T12:31:53Z")

</div>

Any releaseplan for 5.3.2 ? Its a new system, and we are soon to go into production! So either i need to downgrade, or i can hold on if the update comes within next week.  
Which version is not affected by this bug ?

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [April 26, 2017, 12:49pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692/4 "2017-04-26T12:49:23Z")

</div>

sorry but it's our policy not to publish release dates ahead of time, but 5.3.2 will be out very soon

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2017, 1:02pm UTC](https://discuss.elastic.co/t/es-5-3-1-content-type-cannot-be-user-specified/83692/5 "2017-05-24T13:02:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
