# ES 5.3 (CentOs7) Adding another path.data giving permission error

**URL:** <https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980>\
**Category:** Elasticsearch\
**Created:** [April 3, 2017, 10:08am UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980 "2017-04-03T10:08:57Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![umir1](https://avatars.discourse-cdn.com/v4/letter/u/4bbf92/32.png) [@umir1](https://discuss.elastic.co/u/umir1)\
**Post date:** [April 3, 2017, 10:08am UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980/1 "2017-04-03T10:08:57Z")

</div>

After updating on ES 5.3, i added another data path but it is giving error. `Unable to access 'path.data'` .  
To resolve permission issue i already used this command `chown -R elasticsearch:elasticsearch /home/elk/data` but getting same error

OS: CentOs7

While Checking ES Status

> ● elasticsearch.service - Elasticsearch  
> Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
> Active: failed (Result: exit-code) since Mon 2017-04-03 06:02:48 EDT; 8min ago  
> Docs: [http://www.elastic.co](http://www.elastic.co)  
> Process: 20805 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
> Process: 20803 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
> Main PID: 20805 (code=exited, status=1/FAILURE)

> Apr 03 06:02:21 ELK-VM01 systemd[1]: Starting Elasticsearch...  
> Apr 03 06:02:21 ELK-VM01 systemd[1]: Started Elasticsearch.  
> Apr 03 06:02:48 ELK-VM01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
> Apr 03 06:02:48 ELK-VM01 systemd[1]: Unit elasticsearch.service entered failed state.  
> Apr 03 06:02:48 ELK-VM01 systemd[1]: elasticsearch.service failed.

From Logs

> [2017-04-03T06:02:48,498][ERROR][o.e.b.Bootstrap] Exception  
> java.lang.IllegalStateException: Unable to access 'path.data' (/home/elk/data)  
> at org.elasticsearch.bootstrap.Security.addPath(Security.java:373) ~[elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:253) ~[elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:209) ~[elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Security.configure(Security.java:115) ~[elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:237) ~[elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:58) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.3.0.jar:5.3.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.3.0.jar:5.3.0]  
> Caused by: java.nio.file.AccessDeniedException: /home/elk/data  
> at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) ~[?:1.8.0\_73]  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:1.8.0\_73]  
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:1.8.0\_73]  
> at sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:384) ~[?:1.8.0\_73]  
> at java.nio.file.Files.createDirectory(Files.java:674) ~[?:1.8.0\_73]  
> at java.nio.file.Files.createAndCheckIsDirectory(Files.java:781) ~[?:1.8.0\_73]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 4, 2017, 12:34am UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980/2 "2017-04-04T00:34:16Z")

</div>

Is the user you are starting Elasticsearch with called `elasticsearch`?

---

<div class="post-metadata">

**Author:** ![umir1](https://avatars.discourse-cdn.com/v4/letter/u/4bbf92/32.png) [@umir1](https://discuss.elastic.co/u/umir1)\
**Post date:** [April 5, 2017, 12:07pm UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980/3 "2017-04-05T12:07:10Z")

</div>

elasticsearch is just default user of elasticsearch group

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [April 5, 2017, 1:25pm UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980/4 "2017-04-05T13:25:22Z")

</div>

I'd double check that I can touch a file in that directory as the Elasticsearch user. And that Elasticsearch as running as that user. If both of those look good and Elasticsearch can't write to it then I'd open an issue about it. Bonus points if your reproduction runs agains the a clean VM like the one you get by running `vagrant up ubuntu 1604` in the Elasticsearch repo.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 3, 2017, 1:25pm UTC](https://discuss.elastic.co/t/es-5-3-centos7-adding-another-path-data-giving-permission-error/80980/5 "2017-05-03T13:25:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
