# ES 6.3 - bound or publishing to a non-loopback address, enforcing bootstrap checks

**URL:** <https://discuss.elastic.co/t/es-6-3-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks/136614>\
**Category:** Elasticsearch\
**Created:** [June 20, 2018, 6:29am UTC](https://discuss.elastic.co/t/es-6-3-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks/136614 "2018-06-20T06:29:22Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Phillip\_Tribble](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phillip_tribble/32/32474_2.png) [@Phillip\_Tribble](https://discuss.elastic.co/u/Phillip_Tribble)\
**Post date:** [June 20, 2018, 6:29am UTC](https://discuss.elastic.co/t/es-6-3-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks/136614/1 "2018-06-20T06:29:22Z")

</div>

Hello, I am struggling for hours trying to get a new ES 6.3 cluster setup in Docker. The error is as below:

```auto
] [rpi-1] bound or publishing to a non-loopback address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: JVM is using the client VM [Java HotSpot(TM) Client VM] but should be using a server VM for the best performance

```

If I remove network.publish\_host: 192.168.0.101 from the config below, it will start up and try to connect to another node but will fail because it is trying to join a cluster using 127.0.0.1

My Config:

```auto
#action.destructive_requires_name: true
xpack.ml.enabled: false
node.name: c054915212b1
discovery.zen.ping.unicast.hosts: [192.168.0.108, 192.168.0.103, 192.168.0.104]
http.cors.enabled: true
http.cors.allow-origin: "*"
node.master: true
network.publish_host: 192.168.0.101
http.bind_host: 192.168.0.101
http.publish_host: 192.168.0.101
http.host: 192.168.0.101

```

I have never had an issue setting up a cluster prior to this release. Your help is greatly appreciated.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 18, 2018, 6:29am UTC](https://discuss.elastic.co/t/es-6-3-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks/136614/2 "2018-07-18T06:29:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
