# ES 6.4.2 - error when trying to snapshot cluster to S3 bucket

**URL:** <https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910>\
**Category:** Elasticsearch\
**Created:** [March 12, 2019, 9:39am UTC](https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910 "2019-03-12T09:39:17Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![NadavKal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nadavkal/32/70971_2.png) [@NadavKal](https://discuss.elastic.co/u/NadavKal)\
**Post date:** [March 12, 2019, 9:39am UTC](https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910/1 "2019-03-12T09:39:17Z")

</div>

i have open a new bucket on S3 and added full S3 permissions to the cluster instance Role.  
but when attempting to snapshot like this:

/\_snapshot/s3\_repository  
{  
"type": "s3",  
"settings": {  
"bucket": "my-bucket",  
"region": "us-east-1"  
}  
}

i'm getting:  
{  
"error": {  
"root\_cause": [  
{  
"type": "remote\_transport\_exception",  
"reason": "[ip-10-1-0-50][10.1.0.50:9300][indices:admin/create]"  
}  
],  
"type": "string\_index\_out\_of\_bounds\_exception",  
"reason": "String index out of range: 0"  
},  
"status": 500  
}

10.1.0.50 has repository-s3 plugin installed and the elasticsearch service has been restarted.

could any one tell me what's causing the error and how to fix it?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [March 12, 2019, 3:36pm UTC](https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910/2 "2019-03-12T15:36:07Z")

</div>

This shouldn't be happening. Can you provide the stack trace that goes with this exception? It should be in the Elasticsearch log file.

---

<div class="post-metadata">

**Author:** ![NadavKal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nadavkal/32/70971_2.png) [@NadavKal](https://discuss.elastic.co/u/NadavKal)\
**Post date:** [March 12, 2019, 4:19pm UTC](https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910/3 "2019-03-12T16:19:47Z")

</div>

thanks @DavidTurner, but i've already solved it.  
i don't know why but it didn't work from the kibana dev tool.  
it did work though with a curl and from cerebro.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 9, 2019, 4:19pm UTC](https://discuss.elastic.co/t/es-6-4-2-error-when-trying-to-snapshot-cluster-to-s3-bucket/171910/4 "2019-04-09T16:19:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
