# ES 6.7.2 - "failed to read local state, exiting" on minor k8s pod updates (not ES upgrade)

**URL:** <https://discuss.elastic.co/t/es-6-7-2-failed-to-read-local-state-exiting-on-minor-k8s-pod-updates-not-es-upgrade/190795>\
**Category:** Elasticsearch\
**Created:** [July 16, 2019, 4:50pm UTC](https://discuss.elastic.co/t/es-6-7-2-failed-to-read-local-state-exiting-on-minor-k8s-pod-updates-not-es-upgrade/190795 "2019-07-16T16:50:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![LucasSh](https://avatars.discourse-cdn.com/v4/letter/l/c68b51/32.png) [@LucasSh](https://discuss.elastic.co/u/LucasSh)\
**Post date:** [July 16, 2019, 4:50pm UTC](https://discuss.elastic.co/t/es-6-7-2-failed-to-read-local-state-exiting-on-minor-k8s-pod-updates-not-es-upgrade/190795/1 "2019-07-16T16:50:22Z")

</div>

Our CI/CD is hung on a failed data pod (data-1) that cannot startup due to the following error/exception:

```auto
[2019-07-16T16:39:30,650][ERROR][o.e.g.GatewayMetaState] [stgsiemv2-elasticsearch-data-1] failed to read local state, exiting...
java.lang.IllegalStateException: index and alias names need to be unique, but the following duplicates were found [.kibana (alias of [.kibana_1/FJprNkLuQi2B6pRnZpbP6w])]
	at org.elasticsearch.cluster.metadata.MetaData$Builder.build(MetaData.java:1118) ~[elasticsearch-6.7.2.jar:6.7.2]

```

I'd like to know how it got in this state, but right now my biggest concern is how to safely get out of it without wiping stored data in the .kibana\* indices (I feel like I could probably resolve this by deleting the indices, but would like to avoid that). I did try reindexing .kibana\_1 to .kibana\_3 in hopes that it would eliminate the conflict. At this point I have the alias ".kibana" pointing to .kibana\_1, but I also have 3 other .kibana indices (.kibana1, .kibana2, .kibana3 - all reindexes in attempt to free up the conflict). None of the above works. The data node still exists with this error.

---

<div class="post-metadata">

**Author:** ![ywelsch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ywelsch/32/7751_2.png) [@ywelsch](https://discuss.elastic.co/u/ywelsch)\
**Post date:** [July 17, 2019, 10:19am UTC](https://discuss.elastic.co/t/es-6-7-2-failed-to-read-local-state-exiting-on-minor-k8s-pod-updates-not-es-upgrade/190795/2 "2019-07-17T10:19:50Z")

</div>

Is the cluster health green or yellow without that data node? If so, you can just wipe the data folder on the node and bring it back online.

Also, can you check past logs of `elasticsearch-data-1` and see if there are warnings about dangling indices?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 14, 2019, 10:19am UTC](https://discuss.elastic.co/t/es-6-7-2-failed-to-read-local-state-exiting-on-minor-k8s-pod-updates-not-es-upgrade/190795/3 "2019-08-14T10:19:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
