# ES 7.13.2 - Not starting up - elasticsearch.bat error Invalid initial heap size

**URL:** <https://discuss.elastic.co/t/es-7-13-2-not-starting-up-elasticsearch-bat-error-invalid-initial-heap-size/296945>\
**Category:** Elasticsearch\
**Created:** [February 11, 2022, 8:01am UTC](https://discuss.elastic.co/t/es-7-13-2-not-starting-up-elasticsearch-bat-error-invalid-initial-heap-size/296945 "2022-02-11T08:01:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jothi\_Kiruthika](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jothi_kiruthika/32/101700_2.png) [@Jothi\_Kiruthika](https://discuss.elastic.co/u/Jothi_Kiruthika)\
**Post date:** [February 11, 2022, 8:01am UTC](https://discuss.elastic.co/t/es-7-13-2-not-starting-up-elasticsearch-bat-error-invalid-initial-heap-size/296945/1 "2022-02-11T08:01:56Z")

</div>

HI I am trying to start up ES by running Elasticsearch.bat.

I have created an options file under JVM.options.d folder setting the heap size to 2 gb as below -

-Xms2g  
-Xmx2g

But When running the batch file, i get the below error.

7.13.2\Elasticsearch-7.13.2\bin\>Elasticsearch.bat  
Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]  
output:

error:  
Invalid initial heap size: -Xms2g  
Error: Could not create the Java Virtual Machine.  
Error: A fatal exception has occurred. Program will exit.

---

<div class="post-metadata">

**Author:** ![iconm](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@iconm](https://discuss.elastic.co/u/iconm)\
**Post date:** [February 11, 2022, 8:08am UTC](https://discuss.elastic.co/t/es-7-13-2-not-starting-up-elasticsearch-bat-error-invalid-initial-heap-size/296945/2 "2022-02-11T08:08:16Z")

</div>

Don't you prefer to put it in a virtual machine?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 11, 2022, 8:08am UTC](https://discuss.elastic.co/t/es-7-13-2-not-starting-up-elasticsearch-bat-error-invalid-initial-heap-size/296945/3 "2022-03-11T08:08:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
