# \[ES 8.6.1 & 8.6.2\] Fleet's "Custom Logs" integration stops sending logs with "failed to publish events: temporary bulk send failure" message

**URL:** https://discuss.elastic.co/t/es-8-6-1-8-6-2-fleets-custom-logs-integration-stops-sending-logs-with-failed-to-publish-events-temporary-bulk-send-failure-message/327293
**Category:** Elastic Agent
**Created:** [March 8, 2023, 5:08pm UTC](https://discuss.elastic.co/t/es-8-6-1-8-6-2-fleets-custom-logs-integration-stops-sending-logs-with-failed-to-publish-events-temporary-bulk-send-failure-message/327293 "2023-03-08T17:08:35Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![BorisNaguet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/borisnaguet/32/118203_2.png) [@BorisNaguet](https://discuss.elastic.co/u/BorisNaguet)
#### Post date: [March 8, 2023, 5:08pm UTC](https://discuss.elastic.co/t/es-8-6-1-8-6-2-fleets-custom-logs-integration-stops-sending-logs-with-failed-to-publish-events-temporary-bulk-send-failure-message/327293/1 "2023-03-08T17:08:35Z")

</div>

Hello,

I'm new to Elastic, so it's possible that I configured something wrong...  
Also, please be precise on where/how to find things if you ask for more info.

> **Base installation**
>
> I installed a fresh Elastic recently:
> 
> - 8.6.1
> - one node Elastic/kibana, on the same server than my dev Tomcat
> - AWS EC2 (not k8s), Ubuntu
> - bound on eth0 IP (not using localhost)
> - Using only Fleet and Elastic-agent
> - 1 agent policy: Fleet server, APM, System, System Audit and 3 "Custom Logs" integrations
> 
> The custom logs have:
> 
> - **namespace** = myproject
> - **dataset name** = myservice (I have tomcat, access-logs, and a script)
> - so I created 3 **index template** = logs-myservice-myproject\* / datastream (overriding default pipeline and index lifecycle)

=\> All this has worked, so the basics of installation should be OK.

Today I realized it had stopped sending logs (maybe after I changed something in Kibana, but not sure), while metrics and APM are still ok.

In the logs I found a lot of:

```auto
{"log.level":"error",
"message":"failed to publish events: temporary bulk send failure",
"component":{"binary":"filebeat","dataset":"elastic_agent.filebeat","id":"log-default","type":"log"},
"log":{"source":"log-default"},"log.logger":"publisher_pipeline_output","log.origin":{"file.line":176,"file.name":"pipeline/client_worker.go"},
"service.name":"filebeat",
"ecs.version":"1.6.0","ecs.version":"1.6.0"}

```

followed with these 2 "info" logs:

```auto
Connecting to backoff(elasticsearch(https://10.64.68.80:9200))
Attempting to connect to Elasticsearch version 8.6.1

```

After looking at any configuration issues (especially in pipelines regex, etc...), I saw some related github issues, so I decided to upgrade everything to 8.6.2  
=\> problem was solved when the agent was effectively updated/restarted (through kibana), but after some time it's there again...

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 5, 2023, 5:10pm UTC](https://discuss.elastic.co/t/es-8-6-1-8-6-2-fleets-custom-logs-integration-stops-sending-logs-with-failed-to-publish-events-temporary-bulk-send-failure-message/327293/3 "2023-04-05T17:10:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
