# ES cluster is red after restart

**URL:** <https://discuss.elastic.co/t/es-cluster-is-red-after-restart/10836>\
**Category:** Elasticsearch\
**Created:** [February 21, 2013, 9:22am UTC](https://discuss.elastic.co/t/es-cluster-is-red-after-restart/10836 "2013-02-21T09:22:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dong\_Aihua](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dong_aihua/32/2413_2.png) [@Dong\_Aihua](https://discuss.elastic.co/u/Dong_Aihua)\
**Post date:** [February 21, 2013, 9:22am UTC](https://discuss.elastic.co/t/es-cluster-is-red-after-restart/10836/1 "2013-02-21T09:22:08Z")

</div>

Hi, guys:  
After I restart the cluster, it became to red, and the cluster cluster  
stayed at the below status for long time, unassiged shards and initializing  
shards stayed at 26 and 24 for long time, no change.  
{  
"cluster\_name" : "es-test-cluster-1",  
"status" : "red",  
"timed\_out" : false,  
"number\_of\_nodes" : 20,  
"number\_of\_data\_nodes" : 15,  
"active\_primary\_shards" : 196,  
"active\_shards" : 350,  
"relocating\_shards" : 0,  
"initializing\_shards" : 24,  
"unassigned\_shards" : 26  
}

And I captured some logs from master node:  
[2013-02-21 17:30:19,072][DEBUG][cluster.action.shard] [xseed023.kdev]  
Applying failed shard [nelo2-log-2013-02-26][11],  
node[BRrHHP-iSDCDkdcNrQrgOA], [R], s[INITIALIZING], reason [Failed to start  
shard, message [RecoveryFailedException[[nelo2-log-2013-02-26][11]:  
Recovery failed from  
[xseed040.kdev][FLPZtxFSQA-1uaYQDyiKMg][inet[/10.96.250.230:9300]]{master=false}  
into  
[xseed033.kdev][BRrHHP-iSDCDkdcNrQrgOA][inet[/10.96.250.223:9300]]{master=false}];  
nested: RemoteTransportException[Failed to deserialize exception response  
from stream]; nested: TransportSerializationException[Failed to deserialize  
exception response from stream]; nested:  
StreamCorruptedException[unexpected end of block data]; ]]  
[2013-02-21 17:30:19,073][TRACE][cluster.service] [xseed023.kdev]  
cluster state updated:  
version [123], source [shard-failed ([nelo2-log-2013-02-26][11],  
node[BRrHHP-iSDCDkdcNrQrgOA], [R], s[INITIALIZING]), reason [Failed to  
start shard, message [RecoveryFailedException[[nelo2-log-2013-02-26][11]:  
Recovery failed from  
[xseed040.kdev][FLPZtxFSQA-1uaYQDyiKMg][inet[/10.96.250.230:9300]]{master=false}  
into  
[xseed033.kdev][BRrHHP-iSDCDkdcNrQrgOA][inet[/10.96.250.223:9300]]{master=false}];  
nested: RemoteTransportException[Failed to deserialize exception response  
from stream]; nested: TransportSerializationException[Failed to deserialize  
exception response from stream]; nested:  
StreamCorruptedException[unexpected end of block data]; ]]]  
[2013-02-21 17:30:19,157][DEBUG][gateway.local] [xseed023.kdev]  
[nelo2-log-2013-02-19][18]: throttling allocation  
[[nelo2-log-2013-02-19][18], node[null], [R], s[UNASSIGNED]] to  
[[xseed030.kdev][JlHMNsATS52ifplzd-lRJw][inet[/10.96.250.220:9300]]{master=false}]  
in order to reuse its unallocated persistent store with total\_size [3.6gb]  
By the way, before restart, the master is node A, but after restart,  
the master become to another node B. I'm not sure if it will cause the  
problem or not.  
Does anyone know how to bring the cluster to green?  
Thank you very much!

-Regards-  
-Jackie-

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Clinton\_Gormley](https://avatars.discourse-cdn.com/v4/letter/c/50afbb/32.png) [@Clinton\_Gormley](https://discuss.elastic.co/u/Clinton_Gormley)\
**Post date:** [February 21, 2013, 2:58pm UTC](https://discuss.elastic.co/t/es-cluster-is-red-after-restart/10836/2 "2013-02-21T14:58:12Z")

</div>

> [RecoveryFailedException[[nelo2-log-2013-02-26][11]: Recovery failed  
> from  
> [xseed040.kdev][FLPZtxFSQA-1uaYQDyiKMg][inet[/10.96.250.230:9300]]{master=false} into [xseed033.kdev][BRrHHP-iSDCDkdcNrQrgOA][inet[/10.96.250.223:9300]]{master=false}]; nested: RemoteTransportException[Failed to deserialize exception response from stream]; nested: TransportSerializationException[Failed to deserialize exception response from stream]; nested: StreamCorruptedException[unexpected end of block data]; ]]

It sounds like you are using different versions of ES in the same  
cluster (nodes or clients)

clint

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:50am UTC](https://discuss.elastic.co/t/es-cluster-is-red-after-restart/10836/3 "2017-07-06T02:50:20Z")

</div>


