# ES Error - No commit point data is available in gateway

**URL:** <https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493>\
**Category:** Elasticsearch\
**Created:** [May 28, 2011, 4:54am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493 "2011-05-28T04:54:28Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![senthil\_prabhu](https://avatars.discourse-cdn.com/v4/letter/s/9e8a1a/32.png) [@senthil\_prabhu](https://discuss.elastic.co/u/senthil_prabhu)\
**Post date:** [May 28, 2011, 4:54am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/1 "2011-05-28T04:54:28Z")

</div>

1. Restart Elastic Search, any one index get following error and ES  
Indices were not opened, after the error indices deletion, cluster  
will come green and it’s working fine. So every ES restart we loss any  
one indices.

We are using Elastic search version 16.0

“[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
Solomon] sending f

ailed shard for [db288\_audit][2], node[SoJVrnNpSsy7uDEA3qRnBw], [P],  
s[INITIALIZ

ING], reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException

[[db288\_audit][2] No commit point data is available in gateway]]]

[01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
[db288\_au

dit][2] failed to read commit point [commit-1]

java.lang.ArrayIndexOutOfBoundsException

[01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
[db288\_au

dit][2] listed commit\_point [commit-0]/[0], but not all files exists,  
ignoring

[01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
[db288\_au

dit][2] failed to start shard

org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[db288\_audit

][2] No commit point data is available in gateway

```
    at

```

org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.

recover(BlobStoreIndexShardGateway.java:423)

```
    at org.elasticsearch.index.gateway.IndexShardGatewayService

```

$1.run(IndexS

hardGatewayService.java:144)

```
    at java.util.concurrent.ThreadPoolExecutor

```

$Worker.runTask(ThreadPoolExec

utor.java:886)

```
    at java.util.concurrent.ThreadPoolExecutor

```

$Worker.run(ThreadPoolExecutor

.java:908)

```
    at java.lang.Thread.run(Thread.java:619)”

```

What's going wrong here....?

Can any one help me...

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 28, 2011, 9:18am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/2 "2011-05-28T09:18:41Z")

</div>

Can you please gist the exception. Which shared gateway are you using?

On Saturday, May 28, 2011 at 7:54 AM, senthil prabhu wrote:

> 1. Restart Elastic Search, any one index get following error and ES  
> Indices were not opened, after the error indices deletion, cluster  
> will come green and it’s working fine. So every ES restart we loss any  
> one indices.
> 
> We are using Elastic search version 16.0
> 
> “[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
> Solomon] sending f
> 
> ailed shard for [db288\_audit][2], node[SoJVrnNpSsy7uDEA3qRnBw], [P],  
> s[INITIALIZ
> 
> ING], reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException
> 
> [[db288\_audit][2] No commit point data is available in gateway]]]
> 
> [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> [db288\_au
> 
> dit][2] failed to read commit point [commit-1]
> 
> java.lang.ArrayIndexOutOfBoundsException
> 
> [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> [db288\_au
> 
> dit][2] listed commit\_point [commit-0]/[0], but not all files exists,  
> ignoring
> 
> [01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
> [db288\_au
> 
> dit][2] failed to start shard
> 
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> [db288\_audit
> 
> ][2] No commit point data is available in gateway
> 
> at  
> org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.
> 
> recover(BlobStoreIndexShardGateway.java:423)
> 
> at org.elasticsearch.index.gateway.IndexShardGatewayService  
> $1.run(IndexS
> 
> hardGatewayService.java:144)
> 
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.runTask(ThreadPoolExec
> 
> utor.java:886)
> 
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor
> 
> .java:908)
> 
> at java.lang.Thread.run(Thread.java:619)”
> 
> What's going wrong here....?
> 
> Can any one help me...

---

<div class="post-metadata">

**Author:** ![senthil\_prabhu](https://avatars.discourse-cdn.com/v4/letter/s/9e8a1a/32.png) [@senthil\_prabhu](https://discuss.elastic.co/u/senthil_prabhu)\
**Post date:** [May 28, 2011, 11:30am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/3 "2011-05-28T11:30:35Z")

</div>

We are using FS shared gateway and the Exception i am getting is

“[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
Solomon] sending failed shard for [db288\_audit][2],  
node[SoJVrnNpSsy7uDEA3qRnBw], [P], s[INITIALIZ  
ING], reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException[[db288\_audit][2] No commit point  
data is available in gateway]]]  
[01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
[db288\_audit][2] failed to read commit point  
[commit-1]java.lang.ArrayIndexOutOfBoundsException  
[01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
[db288\_audit][2] listed commit\_point [commit-0]/[0], but not all files  
exists, ignoring  
[01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
[db288\_audit][2] failed to start  
shardorg.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[db288\_audit][2] No commit point data is available in gateway at  
org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.recover(BlobStoreIndexShardGateway.java:  
423) at org.elasticsearch.index.gateway.IndexShardGatewayService  
$1.run(IndexShardGatewayService.java:144) at  
java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886) at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor  
.java:908) at java.lang.Thread.run(Thread.java:619)”

On May 28, 2:18 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:

> Can you please gist the exception. Which shared gateway are you using?
> 
> On Saturday, May 28, 2011 at 7:54 AM, senthil prabhu wrote:
> 
> > 1. Restart Elastic Search, any one index get following error and ES  
> > Indices were not opened, after the error indices deletion, cluster  
> > will come green and it’s working fine. So every ES restart we loss any  
> > one indices.
> 
> > We are using Elastic search version 16.0
> 
> > “[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
> > Solomon] sending f
> 
> > ailed shard for [db288\_audit][2], node[SoJVrnNpSsy7uDEA3qRnBw], [P],  
> > s[INITIALIZ
> 
> > ING], reason [Failed to start shard, message  
> > [IndexShardGatewayRecoveryException
> 
> > [[db288\_audit][2] No commit point data is available in gateway]]]
> 
> > [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> > [db288\_au
> 
> > dit][2] failed to read commit point [commit-1]
> 
> > java.lang.ArrayIndexOutOfBoundsException
> 
> > [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> > [db288\_au
> 
> > dit][2] listed commit\_point [commit-0]/[0], but not all files exists,  
> > ignoring
> 
> > [01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
> > [db288\_au
> 
> > dit][2] failed to start shard
> 
> > org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> > [db288\_audit
> 
> > ][2] No commit point data is available in gateway
> 
> > at  
> > org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.
> 
> > recover(BlobStoreIndexShardGateway.java:423)
> 
> > at org.elasticsearch.index.gateway.IndexShardGatewayService  
> > $1.run(IndexS
> 
> > hardGatewayService.java:144)
> 
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.runTask(ThreadPoolExec
> 
> > utor.java:886)
> 
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.run(ThreadPoolExecutor
> 
> > .java:908)
> 
> > at java.lang.Thread.run(Thread.java:619)”
> 
> > What's going wrong here....?
> 
> > Can any one help me...

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 28, 2011, 1:47pm UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/4 "2011-05-28T13:47:23Z")

</div>

Can you _GIST_ ([http://gist.github.com](http://gist.github.com)) the full log of the node where you see this exception?

On Saturday, May 28, 2011 at 2:30 PM, senthil prabhu wrote:

> We are using FS shared gateway and the Exception i am getting is
> 
> “[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
> Solomon] sending failed shard for [db288\_audit][2],  
> node[SoJVrnNpSsy7uDEA3qRnBw], [P], s[INITIALIZ  
> ING], reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException[[db288\_audit][2] No commit point  
> data is available in gateway]]]  
> [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> [db288\_audit][2] failed to read commit point  
> [commit-1]java.lang.ArrayIndexOutOfBoundsException  
> [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> [db288\_audit][2] listed commit\_point [commit-0]/[0], but not all files  
> exists, ignoring  
> [01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
> [db288\_audit][2] failed to start  
> shardorg.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> [db288\_audit][2] No commit point data is available in gateway at  
> org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.recover(BlobStoreIndexShardGateway.java:  
> 423) at org.elasticsearch.index.gateway.IndexShardGatewayService  
> $1.run(IndexShardGatewayService.java:144) at  
> java.util.concurrent.ThreadPoolExecutor  
> $Worker.runTask(ThreadPoolExecutor.java:886) at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor  
> .java:908) at java.lang.Thread.run(Thread.java:619)”
> 
> On May 28, 2:18 pm, Shay Banon \<[shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) ([http://elasticsearch.com](http://elasticsearch.com))\> wrote:
> 
> > Can you please gist the exception. Which shared gateway are you using?
> > 
> > On Saturday, May 28, 2011 at 7:54 AM, senthil prabhu wrote:
> > 
> > > 1. Restart Elastic Search, any one index get following error and ES  
> > > Indices were not opened, after the error indices deletion, cluster  
> > > will come green and it’s working fine. So every ES restart we loss any  
> > > one indices.
> > 
> > > We are using Elastic search version 16.0
> > 
> > > “[01:48:56,425][WARN][cluster.action.shard] [O'Sullivan,  
> > > Solomon] sending f
> > 
> > > ailed shard for [db288\_audit][2], node[SoJVrnNpSsy7uDEA3qRnBw], [P],  
> > > s[INITIALIZ
> > 
> > > ING], reason [Failed to start shard, message  
> > > [IndexShardGatewayRecoveryException
> > 
> > > [[db288\_audit][2] No commit point data is available in gateway]]]
> > 
> > > [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> > > [db288\_au
> > 
> > > dit][2] failed to read commit point [commit-1]
> > 
> > > java.lang.ArrayIndexOutOfBoundsException
> > 
> > > [01:48:56,582][WARN][index.gateway.fs] [O'Sullivan, Solomon]  
> > > [db288\_au
> > 
> > > dit][2] listed commit\_point [commit-0]/[0], but not all files exists,  
> > > ignoring
> > 
> > > [01:48:56,582][WARN][indices.cluster] [O'Sullivan, Solomon]  
> > > [db288\_au
> > 
> > > dit][2] failed to start shard
> > 
> > > org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> > > [db288\_audit
> > 
> > > ][2] No commit point data is available in gateway
> > 
> > > at  
> > > org.elasticsearch.index.gateway.blobstore.BlobStoreIndexShardGateway.
> > 
> > > recover(BlobStoreIndexShardGateway.java:423)
> > 
> > > at org.elasticsearch.index.gateway.IndexShardGatewayService  
> > > $1.run(IndexS
> > 
> > > hardGatewayService.java:144)
> > 
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.runTask(ThreadPoolExec
> > 
> > > utor.java:886)
> > 
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.run(ThreadPoolExecutor
> > 
> > > .java:908)
> > 
> > > at java.lang.Thread.run(Thread.java:619)”
> > 
> > > What's going wrong here....?
> > 
> > > Can any one help me...

---

<div class="post-metadata">

**Author:** ![fashionalwallet](https://avatars.discourse-cdn.com/v4/letter/f/839c29/32.png) [@fashionalwallet](https://discuss.elastic.co/u/fashionalwallet)\
**Post date:** [June 10, 2011, 3:43am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/5 "2011-06-10T03:43:17Z")

</div>

- deleted -

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:03am UTC](https://discuss.elastic.co/t/es-error-no-commit-point-data-is-available-in-gateway/4493/6 "2017-07-06T04:03:58Z")

</div>


