# ES error while creating index on Solaris

**URL:** https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321
**Category:** Elasticsearch
**Created:** [October 19, 2014, 10:25am UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321 "2014-10-19T10:25:47Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![xsreality](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xsreality/32/1173_2.png) [@xsreality](https://discuss.elastic.co/u/xsreality)
#### Post date: [October 19, 2014, 10:25am UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/1 "2014-10-19T10:25:47Z")

</div>

Hello,

I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday when  
Logstash tries to create a new index ES stops responding (process is  
active) with below error:

[2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
Morpheus] [logstash-2014.10.19] failed to create  
org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
character ('\_' (code 95)): was expecting a colon to separate field name and  
value  
at [Source:  
{"_default_":{"\_defa:{"\_defled":true},"dynamic\_templates":[{"string\_fields":[{"stch":"_",""stch":"ping\_fiel":"","ng",""stch"ga:{"\_def":"_","ng","index":"_","yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":"\*","",""stcerties":[{"sertionc:{"\_def":"geoipc:nt",,,,}};  
line: 1, column: 25]  
at  
org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
at  
org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
at  
org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
at  
org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
at  
org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:50)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.map(AbstractXContentParser.java:208)  
at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
at  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.java:473)  
at  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.java:89)  
at  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:260)  
at  
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:328)  
at  
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)

I tried with fresh install of ES and Logstash but the error starts coming  
as soon as Logstash tries to create an index. It seems to be related to  
mappings but I am not sure. In Unix it works fine, problem is only coming  
in Solaris.

Please help.

Regards,  
Abhinav

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)
#### Post date: [October 19, 2014, 2:30pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/2 "2014-10-19T14:30:18Z")

</div>

Is this Solaris SPARC?

Looks like a compression / Jackson issue, SPARC is 64bit big-endian, so  
this is interesting.

Jörg

On Sun, Oct 19, 2014 at 12:25 PM, Abhinav Sonkar [xsabhinav@gmail.com](mailto:xsabhinav@gmail.com)  
wrote:

> Hello,
> 
> I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday when  
> Logstash tries to create a new index ES stops responding (process is  
> active) with below error:
> 
> [2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
> Morpheus] [logstash-2014.10.19] failed to create  
> org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> character ('\_' (code 95)): was expecting a colon to separate field name and  
> value  
> at [Source:  
> {"_default_":{"\_defa:{"\_defled":true},"dynamic\_templates":[{"string\_fields":[{"stch":"_",""stch":"ping\_fiel":"","ng",""stch"ga:{"\_def":"_","ng","index":"_","yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":"\*","",""stcerties":[{"sertionc:{"\_def":"geoipc:nt",,,,}};  
> line: 1, column: 25]  
> at  
> org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> at  
> org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
> at  
> org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
> at  
> org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
> at  
> org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:50)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.map(AbstractXContentParser.java:208)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
> at  
> org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.java:473)  
> at  
> org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.java:89)  
> at  
> org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:260)  
> at  
> org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:328)  
> at  
> org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:745)
> 
> I tried with fresh install of ES and Logstash but the error starts coming  
> as soon as Logstash tries to create an index. It seems to be related to  
> mappings but I am not sure. In Unix it works fine, problem is only coming  
> in Solaris.
> 
> Please help.
> 
> Regards,  
> Abhinav
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEc3Ya5C7HfBiVUeBa2sfEjZMjxYZ4He-OHoocgOTVc4w%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEc3Ya5C7HfBiVUeBa2sfEjZMjxYZ4He-OHoocgOTVc4w%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)
#### Post date: [October 19, 2014, 2:31pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/3 "2014-10-19T14:31:01Z")

</div>

Sorry, I overlooked this - yes it is SPARC. I will investigate.

Jörg

On Sun, Oct 19, 2014 at 4:30 PM, [joergprante@gmail.com](mailto:joergprante@gmail.com) \<  
[joergprante@gmail.com](mailto:joergprante@gmail.com)\> wrote:

> Is this Solaris SPARC?
> 
> Looks like a compression / Jackson issue, SPARC is 64bit big-endian, so  
> this is interesting.
> 
> Jörg
> 
> On Sun, Oct 19, 2014 at 12:25 PM, Abhinav Sonkar [xsabhinav@gmail.com](mailto:xsabhinav@gmail.com)  
> wrote:
> 
> > Hello,
> > 
> > I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday when  
> > Logstash tries to create a new index ES stops responding (process is  
> > active) with below error:
> > 
> > [2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
> > Morpheus] [logstash-2014.10.19] failed to create  
> > org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> > character ('\_' (code 95)): was expecting a colon to separate field name and  
> > value  
> > at [Source:  
> > {"_default_":{"\_defa:{"\_defled":true},"dynamic\_templates":[{"string\_fields":[{"stch":"_",""stch":"ping\_fiel":"","ng",""stch"ga:{"\_def":"_","ng","index":"_","yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":"\*","",""stcerties":[{"sertionc:{"\_def":"geoipc:nt",,,,}};  
> > line: 1, column: 25]  
> > at  
> > org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
> > at  
> > org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> > at  
> > org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> > at  
> > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
> > at  
> > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
> > at  
> > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
> > at  
> > org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:50)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.map(AbstractXContentParser.java:208)  
> > at  
> > org.elasticsearch.common.xcontent.support.AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
> > at  
> > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.java:473)  
> > at  
> > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.java:89)  
> > at  
> > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:260)  
> > at  
> > org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:328)  
> > at  
> > org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)  
> > at  
> > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> > at  
> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> > at java.lang.Thread.run(Thread.java:745)
> > 
> > I tried with fresh install of ES and Logstash but the error starts coming  
> > as soon as Logstash tries to create an index. It seems to be related to  
> > mappings but I am not sure. In Unix it works fine, problem is only coming  
> > in Solaris.
> > 
> > Please help.
> > 
> > Regards,  
> > Abhinav
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGvBnL5tf1oCWV4bXqjp%3De2zPZZgG6gOmmbWcEDPWtzcg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGvBnL5tf1oCWV4bXqjp%3De2zPZZgG6gOmmbWcEDPWtzcg%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![xsreality](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xsreality/32/1173_2.png) [@xsreality](https://discuss.elastic.co/u/xsreality)
#### Post date: [October 19, 2014, 2:38pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/4 "2014-10-19T14:38:21Z")

</div>

Thanks Jorg.

Some more information:

The error message keeps repeating until ES is restarted. After restarting  
ES, index gets created with some bulk shards message (I am not in VPN right  
now so can't show the exact message). When the time comes to create new  
logstash index, error starts coming again.

Abhinav

On Sunday, 19 October 2014 16:31:07 UTC+2, Jörg Prante wrote:

> Sorry, I overlooked this - yes it is SPARC. I will investigate.
> 
> Jörg
> 
> On Sun, Oct 19, 2014 at 4:30 PM, [joerg...@gmail.com](mailto:joerg...@gmail.com) \<javascript:\> \<  
> [joerg...@gmail.com](mailto:joerg...@gmail.com) \<javascript:\>\> wrote:
> 
> > Is this Solaris SPARC?
> > 
> > Looks like a compression / Jackson issue, SPARC is 64bit big-endian, so  
> > this is interesting.
> > 
> > Jörg
> > 
> > On Sun, Oct 19, 2014 at 12:25 PM, Abhinav Sonkar \<[xsab...@gmail.com](mailto:xsab...@gmail.com)  
> > \<javascript:\>\> wrote:
> > 
> > > Hello,
> > > 
> > > I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday when  
> > > Logstash tries to create a new index ES stops responding (process is  
> > > active) with below error:
> > > 
> > > [2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
> > > Morpheus] [logstash-2014.10.19] failed to create  
> > > org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> > > character ('\_' (code 95)): was expecting a colon to separate field name and  
> > > value  
> > > at [Source:  
> > > {"_default_":{"\_defa:{"\_defled":true},"dynamic\_templates":[{"string\_fields":[{"stch":"_",""stch":"ping\_fiel":"","ng",""stch"ga:{"\_def":"_","ng","index":"_","yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":"\*","",""stcerties":[{"sertionc:{"\_def":"geoipc:nt",,,,}};  
> > > line: 1, column: 25]  
> > > at  
> > > org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
> > > at  
> > > org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> > > at  
> > > org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> > > at  
> > > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
> > > at  
> > > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
> > > at  
> > > org.elasticsearch.common.jackson.core.json.ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
> > > at  
> > > org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:50)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.map(AbstractXContentParser.java:208)  
> > > at  
> > > org.elasticsearch.common.xcontent.support.AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
> > > at  
> > > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.java:473)  
> > > at  
> > > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.java:89)  
> > > at  
> > > org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:260)  
> > > at  
> > > org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:328)  
> > > at  
> > > org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)  
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> > > at java.lang.Thread.run(Thread.java:745)
> > > 
> > > I tried with fresh install of ES and Logstash but the error starts  
> > > coming as soon as Logstash tries to create an index. It seems to be related  
> > > to mappings but I am not sure. In Unix it works fine, problem is only  
> > > coming in Solaris.
> > > 
> > > Please help.
> > > 
> > > Regards,  
> > > Abhinav
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google  
> > > Groups "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send  
> > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Clinton\_Gormley](https://avatars.discourse-cdn.com/v4/letter/c/50afbb/32.png) [@Clinton\_Gormley](https://discuss.elastic.co/u/Clinton_Gormley)
#### Post date: [October 20, 2014, 12:00pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/5 "2014-10-20T12:00:42Z")

</div>

Hi Abhinav

It would be good to know exactly where this problem is coming from. Is it  
the way that Logstash adds the template, or is it in the Elasticsearch  
layer. Please could you try something:

- Delete the existing template and index in Elasticsearch
- Take the Logstash template and create it yourself, not using Logstash
- Then index a document into an index that matches the template pattern

If this works, then we know the problem is in the Logstash layer, rather  
than in the Elasticsearch layer

thanks

On 19 October 2014 16:38, Abhinav Sonkar [xsabhinav@gmail.com](mailto:xsabhinav@gmail.com) wrote:

> Thanks Jorg.
> 
> Some more information:
> 
> The error message keeps repeating until ES is restarted. After restarting  
> ES, index gets created with some bulk shards message (I am not in VPN right  
> now so can't show the exact message). When the time comes to create new  
> logstash index, error starts coming again.
> 
> Abhinav
> 
> On Sunday, 19 October 2014 16:31:07 UTC+2, Jörg Prante wrote:
> 
> > Sorry, I overlooked this - yes it is SPARC. I will investigate.
> > 
> > Jörg
> > 
> > On Sun, Oct 19, 2014 at 4:30 PM, [joerg...@gmail.com](mailto:joerg...@gmail.com) [joerg...@gmail.com](mailto:joerg...@gmail.com)  
> > wrote:
> > 
> > > Is this Solaris SPARC?
> > > 
> > > Looks like a compression / Jackson issue, SPARC is 64bit big-endian, so  
> > > this is interesting.
> > > 
> > > Jörg
> > > 
> > > On Sun, Oct 19, 2014 at 12:25 PM, Abhinav Sonkar [xsab...@gmail.com](mailto:xsab...@gmail.com)  
> > > wrote:
> > > 
> > > > Hello,
> > > > 
> > > > I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday when  
> > > > Logstash tries to create a new index ES stops responding (process is  
> > > > active) with below error:
> > > > 
> > > > [2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
> > > > Morpheus] [logstash-2014.10.19] failed to create  
> > > > org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> > > > character ('\_' (code 95)): was expecting a colon to separate field name and  
> > > > value  
> > > > at [Source: {"_default_":{"_defa:{"defled":true},"dynamic  
> > > > templates":[{"string\_fields":[{"stch":"\*",""stch":"\*ping_  
> > > > fiel":"_","ng",""stch"ga:{"\_def":"_","ng","index":"_","  
> > > > yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""  
> > > > ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,  
> > > > roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"  
> > > > yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":  
> > > > "\*","",""stcerties":[{"sertionc:{"_def":"geoipc:nt",,,,}}; line: 1,  
> > > > column: 25]  
> > > > at org.elasticsearch.common.jackson.core.JsonParser._  
> > > > constructError(JsonParser.java:1419)  
> > > > at org.elasticsearch.common.jackson.core.base.  
> > > > ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> > > > at org.elasticsearch.common.jackson.core.base.  
> > > > ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> > > > at org.elasticsearch.common.jackson.core.json.  
> > > > ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
> > > > at org.elasticsearch.common.jackson.core.json.  
> > > > ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
> > > > at org.elasticsearch.common.jackson.core.json.  
> > > > ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
> > > > at org.elasticsearch.common.xcontent.json.  
> > > > JsonXContentParser.nextToken(JsonXContentParser.java:50)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.map(AbstractXContentParser.java:208)  
> > > > at org.elasticsearch.common.xcontent.support.  
> > > > AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
> > > > at org.elasticsearch.cluster.metadata.  
> > > > MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.  
> > > > java:473)  
> > > > at org.elasticsearch.cluster.metadata.  
> > > > MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.  
> > > > java:89)  
> > > > at org.elasticsearch.cluster.metadata.  
> > > > MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.  
> > > > java:260)  
> > > > at org.elasticsearch.cluster.service.InternalClusterService$  
> > > > UpdateTask.run(InternalClusterService.java:328)  
> > > > at org.elasticsearch.common.util.concurrent.  
> > > > PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(  
> > > > PrioritizedEsThreadPoolExecutor.java:153)  
> > > > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > > > ThreadPoolExecutor.java:1145)  
> > > > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > > > ThreadPoolExecutor.java:615)  
> > > > at java.lang.Thread.run(Thread.java:745)
> > > > 
> > > > I tried with fresh install of ES and Logstash but the error starts  
> > > > coming as soon as Logstash tries to create an index. It seems to be related  
> > > > to mappings but I am not sure. In Unix it works fine, problem is only  
> > > > coming in Solaris.
> > > > 
> > > > Please help.
> > > > 
> > > > Regards,  
> > > > Abhinav
> > > > 
> > > > --  
> > > > You received this message because you are subscribed to the Google  
> > > > Groups "elasticsearch" group.  
> > > > To unsubscribe from this group and stop receiving emails from it, send  
> > > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > To view this discussion on the web visit [https://groups.google.com/d/](https://groups.google.com/d/)  
> > > > msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%  
> > > > [40googlegroups.com](http://40googlegroups.com)  
> > > > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > > .  
> > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .
> 
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w\_\_PRNn5R7UMzUZoXeGqQ%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w__PRNn5R7UMzUZoXeGqQ%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)
#### Post date: [October 20, 2014, 3:03pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/6 "2014-10-20T15:03:30Z")

</div>

When trying to reproduce, I have no luck running ES 1.3.4 on Solaris Sparc.  
Just like ES 1.2.2, it crashes with SIGBUS, but this time in lzf  
compression codec.

So I will open an issue.

Jörg

# 

# A fatal error has been detected by the Java Runtime Environment:

# 

# SIGBUS (0xa) at pc=0xffffffff7e51d838, pid=26623, tid=42

# 

# JRE version: Java(TM) SE Runtime Environment (8.0\_11-b12) (build

1.8.0\_11-b12)

JavaThread "elasticsearch[Taj Nital][clusterService#updateTask][T#1]"  
daemon [\_thread\_in\_vm, id=42, stack(0xfffffffedfd00000,0xfffffffedfd40000)]

Stack: [0xfffffffedfd00000,0xfffffffedfd40000], sp=0xfffffffedfd3e4f0,  
free space=249k  
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native  
code)  
V [libjvm.so+0xd1d838] Unsafe\_GetInt+0x174  
J 2115 sun.misc.Unsafe.getInt(Ljava/lang/Object;J)I (0 bytes) @  
0xffffffff6c51c0e8 [0xffffffff6c51bfa0+0x148]  
j  
org.elasticsearch.common.compress.lzf.impl.UnsafeChunkEncoderBE.\_getInt([BI)I+10  
j  
org.elasticsearch.common.compress.lzf.impl.UnsafeChunkEncoderBE.tryCompress([BII[BI)I+104  
j  
org.elasticsearch.common.compress.lzf.ChunkEncoder.encodeChunk([BII)Lorg/elasticsearch/common/compress/lzf/LZFChunk;+17  
j  
org.elasticsearch.common.compress.lzf.LZFEncoder.encode(Lorg/elasticsearch/common/compress/lzf/ChunkEncoder;[BII)[B+17  
j org.elasticsearch.common.compress.lzf.LZFEncoder.encode([BII)[B+9  
j org.elasticsearch.common.compress.lzf.LZFCompressor.compress([BII)[B+3  
j  
org.elasticsearch.common.compress.CompressedString.(Ljava/lang/String;)V+29  
j  
org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(Lorg/elasticsearch/cluster/ClusterState;)Lorg/elasticsearch/cluster/ClusterState;+1536  
j  
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run()V+77  
j  
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run()V+4  
j  
java.util.concurrent.ThreadPoolExecutor.runWorker(Ljava/util/concurrent/ThreadPoolExecutor$Worker;)V+95  
j java.util.concurrent.ThreadPoolExecutor$Worker.run()V+5  
j java.lang.Thread.run()V+11  
v ~StubRoutines::call\_stub  
V [libjvm.so+0x6fd670] void  
JavaCalls::call\_helper(JavaValue\*,methodHandle\*,JavaCallArguments\*,Thread\*)+0xa58  
V [libjvm.so+0x6fba9c] void  
JavaCalls::call\_virtual(JavaValue\*,KlassHandle,Symbol\*,Symbol\*,JavaCallArguments\*,Thread\*)+0x370  
V [libjvm.so+0x6fbd60] void  
JavaCalls::call\_virtual(JavaValue\*,Handle,KlassHandle,Symbol\*,Symbol\*,Thread\*)+0x50  
V [libjvm.so+0x825924] void thread\_entry(JavaThread\*,Thread\*)+0xdc  
V [libjvm.so+0xce4894] void JavaThread::thread\_main\_inner()+0x94  
V [libjvm.so+0xce47e0] void JavaThread::run()+0x408  
V [libjvm.so+0xb3abc4] java\_start+0x364

On Mon, Oct 20, 2014 at 2:00 PM, Clinton Gormley [clint@traveljury.com](mailto:clint@traveljury.com)  
wrote:

> Hi Abhinav
> 
> It would be good to know exactly where this problem is coming from. Is it  
> the way that Logstash adds the template, or is it in the Elasticsearch  
> layer. Please could you try something:
> 
> - Delete the existing template and index in Elasticsearch
> - Take the Logstash template and create it yourself, not using Logstash
> - Then index a document into an index that matches the template pattern
> 
> If this works, then we know the problem is in the Logstash layer, rather  
> than in the Elasticsearch layer
> 
> thanks
> 
> On 19 October 2014 16:38, Abhinav Sonkar [xsabhinav@gmail.com](mailto:xsabhinav@gmail.com) wrote:
> 
> > Thanks Jorg.
> > 
> > Some more information:
> > 
> > The error message keeps repeating until ES is restarted. After restarting  
> > ES, index gets created with some bulk shards message (I am not in VPN right  
> > now so can't show the exact message). When the time comes to create new  
> > logstash index, error starts coming again.
> > 
> > Abhinav
> > 
> > On Sunday, 19 October 2014 16:31:07 UTC+2, Jörg Prante wrote:
> > 
> > > Sorry, I overlooked this - yes it is SPARC. I will investigate.
> > > 
> > > Jörg
> > > 
> > > On Sun, Oct 19, 2014 at 4:30 PM, [joerg...@gmail.com](mailto:joerg...@gmail.com) [joerg...@gmail.com](mailto:joerg...@gmail.com)  
> > > wrote:
> > > 
> > > > Is this Solaris SPARC?
> > > > 
> > > > Looks like a compression / Jackson issue, SPARC is 64bit big-endian, so  
> > > > this is interesting.
> > > > 
> > > > Jörg
> > > > 
> > > > On Sun, Oct 19, 2014 at 12:25 PM, Abhinav Sonkar [xsab...@gmail.com](mailto:xsab...@gmail.com)  
> > > > wrote:
> > > > 
> > > > > Hello,
> > > > > 
> > > > > I am using ES 1.3.4 with Logstash 1.4.2 on Solaris sparc. Everyday  
> > > > > when Logstash tries to create a new index ES stops responding (process is  
> > > > > active) with below error:
> > > > > 
> > > > > [2014-10-19 12:23:02,264][DEBUG][action.admin.indices.create] [SZ1248  
> > > > > Morpheus] [logstash-2014.10.19] failed to create  
> > > > > org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> > > > > character ('\_' (code 95)): was expecting a colon to separate field name and  
> > > > > value  
> > > > > at [Source: {"_default_":{"_defa:{"defled":true},"dynamic  
> > > > > templates":[{"string\_fields":[{"stch":"\*",""stch":"\*ping_  
> > > > > fiel":"_","ng",""stch"ga:{"\_def":"_","ng","index":"_","  
> > > > > yzed":truit\_norms":[{"s,"fields":[{"stc:{"\_def":"_",""  
> > > > > ga:{"\_dex":"_","an,"yzed":truitre\_abovf":"_",,,,,,,,,  
> > > > > roperties":[{"sersionc:{"\_def":"_",""ga:{"\_dex":"_","an,"  
> > > > > yzed"},"geoipc:{"\_def":"object",""stcmic":true},"dth":  
> > > > > "\*","",""stcerties":[{"sertionc:{"_def":"geoipc:nt",,,,}}; line: 1,  
> > > > > column: 25]  
> > > > > at org.elasticsearch.common.jackson.core.JsonParser._  
> > > > > constructError(JsonParser.java:1419)  
> > > > > at org.elasticsearch.common.jackson.core.base.  
> > > > > ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> > > > > at org.elasticsearch.common.jackson.core.base.  
> > > > > ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> > > > > at org.elasticsearch.common.jackson.core.json.  
> > > > > ReaderBasedJsonParser.\_skipColon2(ReaderBasedJsonParser.java:1773)  
> > > > > at org.elasticsearch.common.jackson.core.json.  
> > > > > ReaderBasedJsonParser.\_skipColon(ReaderBasedJsonParser.java:1746)  
> > > > > at org.elasticsearch.common.jackson.core.json.  
> > > > > ReaderBasedJsonParser.nextToken(ReaderBasedJsonParser.java:621)  
> > > > > at org.elasticsearch.common.xcontent.json.  
> > > > > JsonXContentParser.nextToken(JsonXContentParser.java:50)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.readMap(AbstractXContentParser.java:268)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.readValue(AbstractXContentParser.java:308)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.readMap(AbstractXContentParser.java:275)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.readMap(AbstractXContentParser.java:254)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.map(AbstractXContentParser.java:208)  
> > > > > at org.elasticsearch.common.xcontent.support.  
> > > > > AbstractXContentParser.mapAndClose(AbstractXContentParser.java:219)  
> > > > > at org.elasticsearch.cluster.metadata.  
> > > > > MetaDataCreateIndexService.parseMapping(MetaDataCreateIndexService.  
> > > > > java:473)  
> > > > > at org.elasticsearch.cluster.metadata.  
> > > > > MetaDataCreateIndexService.access$400(MetaDataCreateIndexService.  
> > > > > java:89)  
> > > > > at org.elasticsearch.cluster.metadata.  
> > > > > MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.  
> > > > > java:260)  
> > > > > at org.elasticsearch.cluster.service.InternalClusterService$  
> > > > > UpdateTask.run(InternalClusterService.java:328)  
> > > > > at org.elasticsearch.common.util.concurrent.  
> > > > > PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(  
> > > > > PrioritizedEsThreadPoolExecutor.java:153)  
> > > > > at java.util.concurrent.ThreadPoolExecutor.runWorker(  
> > > > > ThreadPoolExecutor.java:1145)  
> > > > > at java.util.concurrent.ThreadPoolExecutor$Worker.run(  
> > > > > ThreadPoolExecutor.java:615)  
> > > > > at java.lang.Thread.run(Thread.java:745)
> > > > > 
> > > > > I tried with fresh install of ES and Logstash but the error starts  
> > > > > coming as soon as Logstash tries to create an index. It seems to be related  
> > > > > to mappings but I am not sure. In Unix it works fine, problem is only  
> > > > > coming in Solaris.
> > > > > 
> > > > > Please help.
> > > > > 
> > > > > Regards,  
> > > > > Abhinav
> > > > > 
> > > > > --  
> > > > > You received this message because you are subscribed to the Google  
> > > > > Groups "elasticsearch" group.  
> > > > > To unsubscribe from this group and stop receiving emails from it, send  
> > > > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > > To view this discussion on the web visit [https://groups.google.com/d/](https://groups.google.com/d/)  
> > > > > msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%  
> > > > > [40googlegroups.com](http://40googlegroups.com)  
> > > > > [https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c07d4f45-25ec-4c3c-b201-9cd354e7470d%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > > > .  
> > > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google Groups  
> > > "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send an  
> > > email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c82c923a-dbf9-456f-9c37-423d18f1a575%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .
> > 
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w\_\_PRNn5R7UMzUZoXeGqQ%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w__PRNn5R7UMzUZoXeGqQ%40mail.gmail.com)  
> [https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w\_\_PRNn5R7UMzUZoXeGqQ%40mail.gmail.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/CAPt3XKQ8s3YH6mkZOChOLgmPG-HE0w__PRNn5R7UMzUZoXeGqQ%40mail.gmail.com?utm_medium=email&utm_source=footer)  
> .
> 
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHH-JdW-paF18GFDxR8cdc91Yz7U8BzGYjS98vj2EaCNw%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHH-JdW-paF18GFDxR8cdc91Yz7U8BzGYjS98vj2EaCNw%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)
#### Post date: [October 20, 2014, 3:08pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/7 "2014-10-20T15:08:46Z")

</div>

I have added a comment to

> <https://github.com/elastic/elasticsearch/issues/6962>

Jörg

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF3%3D8TU2QJtVWp\_RqUdHxQkScQY1MDRYfQwbPrGhDFx7Q%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF3%3D8TU2QJtVWp_RqUdHxQkScQY1MDRYfQwbPrGhDFx7Q%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Clinton\_Gormley](https://avatars.discourse-cdn.com/v4/letter/c/50afbb/32.png) [@Clinton\_Gormley](https://discuss.elastic.co/u/Clinton_Gormley)
#### Post date: [October 20, 2014, 3:49pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/8 "2014-10-20T15:49:31Z")

</div>

I think this is fixed in v1.3.5  
with [Add all unsafe variants of LZF compress library functions to forbidden APIs. by rjernst · Pull Request #7468 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/pull/7468)

On Monday, 20 October 2014 17:08:55 UTC+2, Jörg Prante wrote:

> I have added a comment to  
> [Internal: Remove unsafe unaligned memory access - illegal on SPARC · Issue #6962 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/6962)
> 
> Jörg

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0b05890d-cfa4-4fe9-8e28-568d5369f52c%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0b05890d-cfa4-4fe9-8e28-568d5369f52c%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![xsreality](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xsreality/32/1173_2.png) [@xsreality](https://discuss.elastic.co/u/xsreality)
#### Post date: [October 20, 2014, 8:13pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/9 "2014-10-20T20:13:37Z")

</div>

Hi Clinton,

Thanks for your reply. Can you please help in performing the below steps? I  
don't completely understand the concepts of ES yet.

Abhinav

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/4768b3f2-946e-4e99-88ba-15b1dc54213d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4768b3f2-946e-4e99-88ba-15b1dc54213d%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![xsreality](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xsreality/32/1173_2.png) [@xsreality](https://discuss.elastic.co/u/xsreality)
#### Post date: [October 20, 2014, 8:14pm UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/10 "2014-10-20T20:14:39Z")

</div>

Hi Jorg,

Is the LZF compression issue related to the original Jackson issue?

Abhinav

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b2408f4c-cd74-4dcf-b303-d6987408d7fb%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b2408f4c-cd74-4dcf-b303-d6987408d7fb%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:54am UTC](https://discuss.elastic.co/t/es-error-while-creating-index-on-solaris/20321/11 "2017-07-06T00:54:55Z")

</div>


