# ES fails to start when using 64 bit java

**URL:** https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507
**Category:** Elasticsearch
**Created:** [April 9, 2013, 2:22pm UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507 "2013-04-09T14:22:55Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![ryan\_melissari](https://avatars.discourse-cdn.com/v4/letter/r/cc9497/32.png) [@ryan\_melissari](https://discuss.elastic.co/u/ryan_melissari)
#### Post date: [April 9, 2013, 2:22pm UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507/1 "2013-04-09T14:22:55Z")

</div>

I have been using ES for a few months now without many problems. I have  
started running curl search commands that could be considered heavy which  
causes the cpu and memory usage to spike. ES consumes the 3gigs of memory  
it has been given then produces out of memory heap errors and hangs. This  
system has 32gigs of memory so I tried setting min/max to 8 gigs of memory  
and restart ES passing JAVA\_OPTS="$JAVA\_OPTS -d64" in the start-up script.  
You can tell it is using the 64 bit version of java as it produces  
an Invalid initial heap size: -Xms8g error if it tries the 32 bit version.  
I have tried multiple versions of java, all with the same error. Thank  
you in advance for any help.

Gist of error log: [https://gist.github.com/rmelissari/5346017](https://gist.github.com/rmelissari/5346017)  
ES Version: .20.5  
JVM: 1.6.0.25, 1.6.0.43, 1.7.0.17  
Configuration: Default configuration  
Operating System: Sparc Solaris 10 update 11  
Nodes: 1  
Indices: 68  
Shards: 5  
ES\_Min\_Mem = 3g  
ES\_Max\_Mem = 3g

[root]@logtest /export/logs/root/elasticsearch/bin\> (09:11:03 04/08/13)  
:: ./elasticsearch -f &  
[1] 28309

[root]@logtest /export/logs/root/elasticsearch/bin\> (09:11:05 04/08/13)  
:: [2013-04-09 09:11:12,606][INFO][node] [Xorr the  
God-Jewel] {0.20.5}[28309]: initializing ...  
[2013-04-09 09:11:12,678][INFO][plugins] [Xorr the  
God-Jewel] loaded [], sites [paramedic]

# 

# A fatal error has been detected by the Java Runtime Environment:

# 

# SIGBUS (0xa) at pc=0xffffffff7e176c08, pid=28309, tid=2

# 

# JRE version: 6.0\_43-b01

# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.14-b01 mixed mode

solaris-sparc compressed oops)

# Problematic frame:

# V [libjvm.so+0x976c08] Unsafe\_GetLong+0x120

# 

# An error report file with more information is saved as:

# /export/logs/root/elasticsearch/bin/hs\_err\_pid28309.log

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![Ivan](https://avatars.discourse-cdn.com/v4/letter/i/df788c/32.png) [@Ivan](https://discuss.elastic.co/u/Ivan)
#### Post date: [April 9, 2013, 2:31pm UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507/2 "2013-04-09T14:31:57Z")

</div>

Are you using mlockall by any chance? Nothing else comes to mind.

--  
Ivan

On Tue, Apr 9, 2013 at 7:22 AM, [ryan.melissari@gmail.com](mailto:ryan.melissari@gmail.com) wrote:

> I have been using ES for a few months now without many problems. I have  
> started running curl search commands that could be considered heavy which  
> causes the cpu and memory usage to spike. ES consumes the 3gigs of memory  
> it has been given then produces out of memory heap errors and hangs. This  
> system has 32gigs of memory so I tried setting min/max to 8 gigs of memory  
> and restart ES passing JAVA\_OPTS="$JAVA\_OPTS -d64" in the start-up script.  
> You can tell it is using the 64 bit version of java as it produces  
> an Invalid initial heap size: -Xms8g error if it tries the 32 bit version.  
> I have tried multiple versions of java, all with the same error. Thank  
> you in advance for any help.
> 
> Gist of error log: [Elasticsearch java 64bit startup error · GitHub](https://gist.github.com/rmelissari/5346017)  
> ES Version: .20.5  
> JVM: 1.6.0.25, 1.6.0.43, 1.7.0.17  
> Configuration: Default configuration  
> Operating System: Sparc Solaris 10 update 11  
> Nodes: 1  
> Indices: 68  
> Shards: 5  
> ES\_Min\_Mem = 3g  
> ES\_Max\_Mem = 3g
> 
> [root]@logtest /export/logs/root/elasticsearch/bin\> (09:11:03 04/08/13)  
> :: ./elasticsearch -f &  
> [1] 28309
> 
> [root]@logtest /export/logs/root/elasticsearch/bin\> (09:11:05 04/08/13)  
> :: [2013-04-09 09:11:12,606][INFO][node] [Xorr the  
> God-Jewel] {0.20.5}[28309]: initializing ...  
> [2013-04-09 09:11:12,678][INFO][plugins] [Xorr the  
> God-Jewel] loaded , sites [paramedic]
> 
> # 
> 
> # A fatal error has been detected by the Java Runtime Environment:
> 
> # 
> 
> # SIGBUS (0xa) at pc=0xffffffff7e176c08, pid=28309, tid=2
> 
> # 
> 
> # JRE version: 6.0\_43-b01
> 
> # Java VM: Java HotSpot(TM) 64-Bit Server VM (20.14-b01 mixed mode
> 
> solaris-sparc compressed oops)
> 
> # Problematic frame:
> 
> # V [libjvm.so+0x976c08] Unsafe\_GetLong+0x120
> 
> # 
> 
> # An error report file with more information is saved as:
> 
> # /export/logs/root/elasticsearch/bin/hs\_err\_pid28309.log
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![ryan\_melissari](https://avatars.discourse-cdn.com/v4/letter/r/cc9497/32.png) [@ryan\_melissari](https://discuss.elastic.co/u/ryan_melissari)
#### Post date: [April 9, 2013, 2:39pm UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507/3 "2013-04-09T14:39:41Z")

</div>

On Tuesday, April 9, 2013 9:31:57 AM UTC-5, Ivan Brusic wrote:

> Are you using mlockall by any chance? Nothing else comes to mind.
> 
> --  
> Ivan

I am not, unless it is a default setting, but that is a good idea looking  
at itsdescription. The instructions are not very clear on where to set  
bootstrap.mlockall to true. Where would this be done at?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)
#### Post date: [April 9, 2013, 2:45pm UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507/4 "2013-04-09T14:45:07Z")

</div>

You mention three JVMs, and you quote a JVM SIGBUS coredump with Java  
1.6.0\_43. Does SIGBUS also happen on 1.7.0\_17? Note, this is an issue  
with your JVM, not with Elasticsearch.

Jörg

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 2:42am UTC](https://discuss.elastic.co/t/es-fails-to-start-when-using-64-bit-java/11507/5 "2017-07-06T02:42:00Z")

</div>


