# ES fails to start with error index has more than one write index

**URL:** <https://discuss.elastic.co/t/es-fails-to-start-with-error-index-has-more-than-one-write-index/245828>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [August 20, 2020, 10:34pm UTC](https://discuss.elastic.co/t/es-fails-to-start-with-error-index-has-more-than-one-write-index/245828 "2020-08-20T22:34:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Prashant\_Agrawal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prashant_agrawal/32/74982_2.png) [@Prashant\_Agrawal](https://discuss.elastic.co/u/Prashant_Agrawal)\
**Post date:** [August 20, 2020, 10:34pm UTC](https://discuss.elastic.co/t/es-fails-to-start-with-error-index-has-more-than-one-write-index/245828/1 "2020-08-20T22:34:57Z")

</div>

There was an ES cluster which was running for a while but suddenly docker got restarted and all nodes started to fail with below error:

> "stacktrace": ["org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: alias [my-extension-2019.09-write] has more than one write index [my-extension-2019.09-000011,my-extension-2019.09-000017]",

Anyway I can clean up the same or start the cluster.. Also as this does not have an ID otherwise I could have deleted that particular folder from data/nodes/0/indices..

Would be great of someone can help on same.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 17, 2020, 10:34pm UTC](https://discuss.elastic.co/t/es-fails-to-start-with-error-index-has-more-than-one-write-index/245828/2 "2020-09-17T22:34:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

---

<div class="post-metadata">

**Author:** ![Stef\_Nestor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stef_nestor/32/85483_2.png) [@Stef\_Nestor](https://discuss.elastic.co/u/Stef_Nestor)\
**Post date:** [August 3, 2021, 11:07pm UTC](https://discuss.elastic.co/t/es-fails-to-start-with-error-index-has-more-than-one-write-index/245828/3 "2021-08-03T23:07:20Z")

</div>

(Apologies for the original lack of response.)

For future note when searched, this is now answered in the blog [Troubleshooting ILM blog](https://www.elastic.co/blog/troubleshooting-elasticsearch-ilm-common-issues-and-fixes) with the direct summary quote:

> When you run [Get Aliases](https://www.elastic.co/guide/en/elasticsearch/reference/current/cat-alias.html), you’ll notice that two indices are marked as `is_write_index:true` when only one should be per alias. You’ll want to toggle `is_write_index:false` on one of the indices via the [Aliases API](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-aliases.html).
