# ES-Hadoop on YARN Installation Error

**URL:** <https://discuss.elastic.co/t/es-hadoop-on-yarn-installation-error/53780>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [June 23, 2016, 1:28pm UTC](https://discuss.elastic.co/t/es-hadoop-on-yarn-installation-error/53780 "2016-06-23T13:28:11Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![tushar.hadoop](https://avatars.discourse-cdn.com/v4/letter/t/958977/32.png) [@tushar.hadoop](https://discuss.elastic.co/u/tushar.hadoop)\
**Post date:** [June 23, 2016, 1:28pm UTC](https://discuss.elastic.co/t/es-hadoop-on-yarn-installation-error/53780/1 "2016-06-23T13:28:11Z")

</div>

Hello,

We have a kerberized HDP 2.3.4 Cluster, we are trying to install ES-Hadoop on YARN package but we are facing some errors related to YARN and Elasticsearch.

We are not sure if this is a YARN Bug or ES-Hadoop YARN issue, any advice would be helpful!

Exception to [https://issues.apache.org/jira/browse/YARN-2425](https://issues.apache.org/jira/browse/YARN-2425)

Sample Exception Log Messages -

> ```
> 2016-04-25 23:07:28,032 ERROR logaggregation.LogAggregationService (LogAggregationService.java:run(300)) - Failed to setup application log directory for application_1461625022531_0002
> 
> ```
> 
> ...  
> .. [I have delete this lines]  
> ..  
> java.io.IOException: Failed on local exception: java.io.IOException: org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]; Host Details : local host is: "datanode2.dev.ida/192.168.40.104"; destination host is: "datanode1.dev.ida":8020;  
> ..  
> .. [I have delete this lines]  
> .. org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolTranslatorPB.getFileInfo(ClientNamenodeProtocolTranslatorPB.java:771)  
> Caused by: java.io.IOException: org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]  
> ...  
> ... [I have delete this lines]  
> ...  
> at org.apache.hadoop.ipc.Client.call(Client.java:1397)  
> ... 29 more  
> Caused by: org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]  
> at org.apache.hadoop.security.SaslRpcClient.selectSaslClient(SaslRpcClient.java:172)  
> at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1657)  
> at org.apache.hadoop.ipc.Client$Connection.setupIOstreams(Client.java:722)  
> ... 32 more

Regards,  
Tushar

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:24pm UTC](https://discuss.elastic.co/t/es-hadoop-on-yarn-installation-error/53780/2 "2017-07-06T13:24:13Z")

</div>


