# ES-hive integration error- Cannot detect ES version - typically this happens if the network/Elasticsearch cluster is not accessible or when targeting a WAN/Cloud instance without the proper setting 'es.nodes.wan.only'

**URL:** <https://discuss.elastic.co/t/es-hive-integration-error-cannot-detect-es-version-typically-this-happens-if-the-network-elasticsearch-cluster-is-not-accessible-or-when-targeting-a-wan-cloud-instance-without-the-proper-setting-es-nodes-wan-only/181416>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [May 16, 2019, 1:56pm UTC](https://discuss.elastic.co/t/es-hive-integration-error-cannot-detect-es-version-typically-this-happens-if-the-network-elasticsearch-cluster-is-not-accessible-or-when-targeting-a-wan-cloud-instance-without-the-proper-setting-es-nodes-wan-only/181416 "2019-05-16T13:56:12Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bhanu\_Pratap\_Singh](https://avatars.discourse-cdn.com/v4/letter/b/0ea827/32.png) [@Bhanu\_Pratap\_Singh](https://discuss.elastic.co/u/Bhanu_Pratap_Singh)\
**Post date:** [May 16, 2019, 1:56pm UTC](https://discuss.elastic.co/t/es-hive-integration-error-cannot-detect-es-version-typically-this-happens-if-the-network-elasticsearch-cluster-is-not-accessible-or-when-targeting-a-wan-cloud-instance-without-the-proper-setting-es-nodes-wan-only/181416/1 "2019-05-16T13:56:12Z")

</div>

Hi,

I am trying to push data from a Hive(1.2.1000.2.6.3.0-235) table over to ElasticSearch ("version":  
: "6.6.1") in the secured environment. I have tried numerous combinations of properties for the TBL\_PROPERTIES of the "CREATE EXTERNAL TABLE" but nothing works.

1. Created codac\_booktest via kibana with normal mapping

2. Added jar:  
add jar /usr/hdp/current/hive-webhcat/share/elasticsearch-hadoop-6.6.1.jar;(local file system)  
add jar /tmp/es\_truststore\_ut/commons-httpclient-3.0.jar;(local file system)

CREATE EXTERNAL TABLE bookstest ( bookId STRING, author STRING, publisher STRING, name STRING) STORED BY 'org.elasticsearch.hadoop.hive.EsStorageHandler' TBLPROPERTIES('es.nodes' = 'infnt010112', 'es.port' = '9200','es.net.ssl'='true','es.net.ssl.protocol'='SSL', 'es.nodes.wan.only'= 'TRUE', 'es.net.ssl.keystore.location'='file:///tmp/es\_truststore\_ut/infyn010143\_keystore.jks','es.net.ssl.keystore.pass'='_ **','es.net.ssl.truststore.location'='file:///tmp/es\_truststore\_ut/codac\_ut\_truststore','es.net.ssl.truststore.pass'='** __','es.nodes.discovery' = 'false', 'es.net.ssl.keystore.type'='JKS','es.net.http.auth.user'='username', 'es.net.http.auth.pass'='_\*\*\*\*\*\*\*\*', 'es.resource' = 'codac\_booktest/books');

FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Cannot detect ES version - typically this happens if the network/Elasticsearch cluster is not accessible or when targeting a WAN/Cloud instance without the proper setting 'es.nodes.wan.only'

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 13, 2019, 1:56pm UTC](https://discuss.elastic.co/t/es-hive-integration-error-cannot-detect-es-version-typically-this-happens-if-the-network-elasticsearch-cluster-is-not-accessible-or-when-targeting-a-wan-cloud-instance-without-the-proper-setting-es-nodes-wan-only/181416/2 "2019-06-13T13:56:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
