# ES in Docker fails to start

**URL:** <https://discuss.elastic.co/t/es-in-docker-fails-to-start/183904>\
**Category:** Elasticsearch\
**Created:** [June 3, 2019, 7:38am UTC](https://discuss.elastic.co/t/es-in-docker-fails-to-start/183904 "2019-06-03T07:38:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![msat-kx](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@msat-kx](https://discuss.elastic.co/u/msat-kx)\
**Post date:** [June 3, 2019, 7:38am UTC](https://discuss.elastic.co/t/es-in-docker-fails-to-start/183904/1 "2019-06-03T07:38:05Z")

</div>

I tried to run ES in docker under Ubuntu 18.04 64b host with command:

```auto
docker run -p 9200:9200 -p 9300:9300 -e "discovery.type=single-node" docker.elastic.co/elasticsearch/elasticsearch:7.1.1

```

It failed to start, see the messages at:

> <https://gist.github.com/msat-cont/37d761119dbe5b8b3b492c2e8781af28>

It seems to be alike the issue at:

> <https://github.com/elastic/elasticsearch/issues/41867>

  
though here it is inside a docker image.

Notice that I took the command from  
[https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html)

---

<div class="post-metadata">

**Author:** ![msat-kx](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@msat-kx](https://discuss.elastic.co/u/msat-kx)\
**Post date:** [June 14, 2019, 3:38pm UTC](https://discuss.elastic.co/t/es-in-docker-fails-to-start/183904/2 "2019-06-14T15:38:30Z")

</div>

Hi, it was caused by the computer only having AMD's SSE 4a, not Intel's SSE4.2. On a different computer (that has SSE 4.2) it runs well.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 12, 2019, 3:38pm UTC](https://discuss.elastic.co/t/es-in-docker-fails-to-start/183904/3 "2019-07-12T15:38:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
