# ES is not starting after upgrading it to 7.9.2

**URL:** <https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081>\
**Category:** Elasticsearch\
**Created:** [September 27, 2020, 11:48am UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081 "2020-09-27T11:48:24Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 11:48am UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/1 "2020-09-27T11:48:24Z")

</div>

Elasticsearch is not starting after updating it to 7.9.2. It throws below error.  
OS-CentOS7

Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]  
output:

error:  
Unrecognized VM option 'UseConcMarkSweepGC'  
Error: Could not create the Java Virtual Machine.  
Error: A fatal exception has occurred. Program will exit.  
at org.elasticsearch.tools.launchers.JvmErgonomics.flagsFinal(JvmErgonomics.java:126)  
at org.elasticsearch.tools.launchers.JvmErgonomics.finalJvmOptions(JvmErgonomics.java:88)  
at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:59)  
at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:137)  
at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:95)

I tried the reinstallation but it didn't work. Please help.

---

<div class="post-metadata">

**Author:** ![fadjar340](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fadjar340/32/43610_2.png) [@fadjar340](https://discuss.elastic.co/u/fadjar340)\
**Post date:** [September 27, 2020, 12:38pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/2 "2020-09-27T12:38:35Z")

</div>

What is the /etc/logstash/jvm.options ?

---

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 12:59pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/3 "2020-09-27T12:59:37Z")

</div>

Lostash is running the problem is with Elasticsearch

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 27, 2020, 1:01pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/4 "2020-09-27T13:01:59Z")

</div>

It seems like you are running with an old jvm.options file rather than the one that comes with the new version.

---

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 1:03pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/5 "2020-09-27T13:03:56Z")

</div>

Can you please suggest the method for me to update the jvm.options file?

---

<div class="post-metadata">

**Author:** ![fadjar340](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fadjar340/32/43610_2.png) [@fadjar340](https://discuss.elastic.co/u/fadjar340)\
**Post date:** [September 27, 2020, 1:07pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/6 "2020-09-27T13:07:40Z")

</div>

Sorry for typo:  
/etc/elasticsearch/jvm.options

Please use the newest jvm.options if you have jvm.options.rpmnew

---

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 1:09pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/7 "2020-09-27T13:09:59Z")

</div>

Contents from my configs related to the error.

# Xms represents the initial size of total heap space

# Xmx represents the maximum size of total heap space

-Xms8g  
-Xmx8g

################################################################

## Expert settings

################################################################

## 

## All settings below this section are considered

## expert settings. Don't tamper with them unless

## you understand what you are doing

## 

################################################################

## GC configuration

-XX:+UseConcMarkSweepGC  
-XX:CMSInitiatingOccupancyFraction=75  
-XX:+UseCMSInitiatingOccupancyOnly

## G1GC Configuration

# NOTE: G1GC is only supported on JDK version 10 or later.

# To use G1GC uncomment the lines below.

#10-:-XX:-UseConcMarkSweepGC  
#10-:-XX:-UseCMSInitiatingOccupancyOnly  
#10-:-XX:+UseG1GC  
#10-:-XX:InitiatingHeapOccupancyPercent=75

## DNS cache policy

# cache ttl in seconds for positive DNS lookups noting that this overrides the

# JDK security property networkaddress.cache.ttl; set to -1 to cache forever

-Des.networkaddress.cache.ttl=60

# cache ttl in seconds for negative DNS lookups noting that this overrides the

# JDK security property networkaddress.cache.negative ttl; set to -1 to cache

# forever

-Des.networkaddress.cache.negative.ttl=10

---

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 1:10pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/8 "2020-09-27T13:10:38Z")

</div>

Oh Let me try ...

---

<div class="post-metadata">

**Author:** ![NiranjanMurali](https://avatars.discourse-cdn.com/v4/letter/n/2acd7d/32.png) [@NiranjanMurali](https://discuss.elastic.co/u/NiranjanMurali)\
**Post date:** [September 27, 2020, 2:37pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/9 "2020-09-27T14:37:14Z")

</div>

It worked. Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 25, 2020, 2:37pm UTC](https://discuss.elastic.co/t/es-is-not-starting-after-upgrading-it-to-7-9-2/250081/10 "2020-10-25T14:37:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
