# Es node failed to send join request to each other，how to solve it？

**URL:** <https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242>\
**Category:** Elasticsearch\
**Created:** [May 2, 2018, 11:33am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242 "2018-05-02T11:33:32Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![forestfantacy](https://avatars.discourse-cdn.com/v4/letter/f/9fc29f/32.png) [@forestfantacy](https://discuss.elastic.co/u/forestfantacy)\
**Post date:** [May 2, 2018, 11:33am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242/1 "2018-05-02T11:33:32Z")

</div>

this problem happened in es5.x & netty4,  
it can solving by downgrading to netty3,  
but es6.x is no longer support netty3, and netty4 don't work still, so how can i do

---

<div class="post-metadata">

**Author:** ![Julien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien/32/19688_2.png) [@Julien](https://discuss.elastic.co/u/Julien)\
**Post date:** [May 4, 2018, 10:43am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242/2 "2018-05-04T10:43:24Z")

</div>

No data from this post describe any netty4 known bug - do you have more details? What issue do you see in the logs when a node starts and try to contact the master nodes?

How have you added at least the list of master-eligible nodes (refer to [zen discovery documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-discovery-zen.html))

---

<div class="post-metadata">

**Author:** ![forestfantacy](https://avatars.discourse-cdn.com/v4/letter/f/9fc29f/32.png) [@forestfantacy](https://discuss.elastic.co/u/forestfantacy)\
**Post date:** [May 7, 2018, 7:31am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242/3 "2018-05-07T07:31:28Z")

</div>

thanks for ur reply,this problem is common because almost same iusse reported by a few guys

> <https://github.com/elastic/elasticsearch/issues/22189>

  

> <https://github.com/elastic/elasticsearch/issues/25860>

  

> <https://github.com/elastic/elasticsearch/issues/22189>

  
i regretly found no valid solution in those article，it don't work like the following  
-Dio.netty.noUnsafe=true  
-Dio.netty.noKeySetOptimization=true  
-Dio.netty.recycler.maxCapacityPerThread=0  
-Dio.netty.allocator.type=unpooled

expect ur help

---

<div class="post-metadata">

**Author:** ![Julien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien/32/19688_2.png) [@Julien](https://discuss.elastic.co/u/Julien)\
**Post date:** [May 9, 2018, 9:31am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242/4 "2018-05-09T09:31:22Z")

</div>

The GH issues you refer are all closed and relate to old ES versions, not v6 so most likely the error you are seeing is unrelated...  
The most likely reason a node does not join a cluster is misconfiguration and the node should be able to join if [discovery](https://www.elastic.co/guide/en/elasticsearch/reference/6.2/modules-discovery-zen.html) is set correctly (ie you should add at least all the master-eligible nodes to the list of hosts) and assuming the transport port is opened between that node and the master-eligible nodes it tries to connect to

Can you send the log and elasticsearch.yml of the node which is not able to join the cluster and one of the node which it should be joining - what error are you seeing?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 6, 2018, 9:31am UTC](https://discuss.elastic.co/t/es-node-failed-to-send-join-request-to-each-other-how-to-solve-it/130242/5 "2018-06-06T09:31:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
