# Es-stack 8.1.0 - \[security\_exception\] action \[indices:data/read/search\]

**URL:** https://discuss.elastic.co/t/es-stack-8-1-0-security-exception-action-indices-data-read-search/300097
**Category:** Kibana
**Tags:** elastic-stack-monitoring, docker
**Created:** [March 19, 2022, 5:42am UTC](https://discuss.elastic.co/t/es-stack-8-1-0-security-exception-action-indices-data-read-search/300097 "2022-03-19T05:42:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![skahdi12](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skahdi12/32/103235_2.png) [@skahdi12](https://discuss.elastic.co/u/skahdi12)
#### Post date: [March 19, 2022, 5:42am UTC](https://discuss.elastic.co/t/es-stack-8-1-0-security-exception-action-indices-data-read-search/300097/1 "2022-03-19T05:42:09Z")

</div>

Hello, I'm using Elasticsearch 8.1.0.  
I configured a es cluster and logged in to kibana as a superuser elastic.  
However, there is an error that never been seen in the previous version.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/8/58b1ffb70568398b4641fcf8639561eb246960f1.png)

kibana error message :  
ResponseError: security\_exception: [security\_exception] Reason: action [indices:data/read/search] is unauthorized for user [elastic] with roles [superuser], this action is granted by the index privileges [read,all]

I logged in with the superuser elastic account, but i don't know why it says that I don't have permission ...  
Help me please ..

---

<div class="post-metadata">

### Author: ![Gabriel\_Chagas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_chagas/32/103559_2.png) [@Gabriel\_Chagas](https://discuss.elastic.co/u/Gabriel_Chagas)
#### Post date: [March 26, 2022, 8:54pm UTC](https://discuss.elastic.co/t/es-stack-8-1-0-security-exception-action-indices-data-read-search/300097/2 "2022-03-26T20:54:24Z")

</div>

The issue is solved by adding `monitoring.ui.ccs.enabled: false` in kibana.yml as mentioned in [Stack Monitoring "access denied" after 8.0.0 upgrade · Issue #125756 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/125756)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 23, 2022, 8:54pm UTC](https://discuss.elastic.co/t/es-stack-8-1-0-security-exception-action-indices-data-read-search/300097/3 "2022-04-23T20:54:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
