# Esaggs \> field is a required parameter

**URL:** <https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016>\
**Category:** Kibana\
**Created:** [December 17, 2020, 4:49pm UTC](https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016 "2020-12-17T16:49:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![firstpostcommenter](https://avatars.discourse-cdn.com/v4/letter/f/ad7895/32.png) [@firstpostcommenter](https://discuss.elastic.co/u/firstpostcommenter)\
**Post date:** [December 17, 2020, 4:49pm UTC](https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016/1 "2020-12-17T16:49:44Z")

</div>

Hi,  
In my Kibana dashboard I get the below error:  
[esaggs] \> "field" is a required parameter

In my Dashboard there are around 11 panels/visualizations (panel0 to panel10) and I narrowed it down to panel7 which is causing the error... Because when I delete the panel7 from the dashboard then I don't see this error anymore

I checked the thread [Logstash Output wrong - Error in visualization [esaggs] \> "field" is a required parameter](https://discuss.elastic.co/t/logstash-output-wrong-error-in-visualization-esaggs-field-is-a-required-parameter/215412) and it looks like this error occurs when there is an issue with the Timestamp field

I have the below code in the panel7 for timestamp field in the "aggs" array but I am not clear what is the error with this date format

```auto
    {
         "id": "1",
          "enabled": true,
          "type": "avg",
          "schema": "metric",
           "params": {
               "field": "value"
            }
    },
   {
       "id": "4",
       "enabled": true,
       "type": "date_histogram",
       "schema": "segment",
       "params": {
           "field": "@timestamp",
           "timeRange": {
               "from": "2019-05-07T21:10:55.491Z",
               "to": "2019-05-07T21:18:55.491Z",
               "mode": "absolute"
           },
           "useNormalizedEsInterval": true,
           "interval": "auto",
           "drop_partials": false,
           "min_doc_count": 1,
           "extended_bounds": {}
       }
   }

```

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [December 17, 2020, 5:16pm UTC](https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016/2 "2020-12-17T17:16:51Z")

</div>

Can you export this visualization and post it here?

---

<div class="post-metadata">

**Author:** ![firstpostcommenter](https://avatars.discourse-cdn.com/v4/letter/f/ad7895/32.png) [@firstpostcommenter](https://discuss.elastic.co/u/firstpostcommenter)\
**Post date:** [December 17, 2020, 5:44pm UTC](https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016/3 "2020-12-17T17:44:16Z")

</div>

Found that the id 1 related field has the issue. I need to specify some valid field there

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2021, 5:44pm UTC](https://discuss.elastic.co/t/esaggs-field-is-a-required-parameter/259016/4 "2021-01-14T17:44:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
