# Esrally failed to show result (Cannot race. Load generator \[14\] has exited prematurely.)

**URL:** <https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415>\
**Category:** Elasticsearch\
**Tags:** rally\
**Created:** [November 19, 2019, 3:01am UTC](https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415 "2019-11-19T03:01:02Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jinlian\_Chen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jinlian_chen/32/44738_2.png) [@Jinlian\_Chen](https://discuss.elastic.co/u/Jinlian_Chen)\
**Post date:** [November 19, 2019, 3:01am UTC](https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415/1 "2019-11-19T03:01:02Z")

</div>

All tasks shows done 100%, but failed to show the result. Is it the memory problem? It happens when run large number of iterations to build index.  
Parameters: bulk\_indexing\_clients:32,iterations:250000

The rally log show force-merge failed, will it caused the issue?

Running log:

```
[INFO] Racing on track [email_track], challenge [route-part-body-append-only] and car ['external'] with version [7.4.2].

[WARNING] merges_total_time is 346974 ms indicating that the cluster is not in a defined clean state. Recorded index time metrics may be misleading.
[WARNING] merges_total_throttled_time is 77 ms indicating that the cluster is not in a defined clean state. Recorded index time metrics may be misleading.
[WARNING] indexing_total_time is 153967 ms indicating that the cluster is not in a defined clean state. Recorded index time metrics may be misleading.
[WARNING] refresh_total_time is 356965 ms indicating that the cluster is not in a defined clean state. Recorded index time metrics may be misleading.
[WARNING] flush_total_time is 5098 ms indicating that the cluster is not in a defined clean state. Recorded index time metrics may be misleading.
Running delete-index-route-part-body-template [100% done]
Running create-index-route-part-body-template [100% done]
Running check-cluster-health [100% done]
Running route-part-body-email-append [100% done]
Running force-merge [100% done]
[ERROR] Cannot race. Load generator [14] has exited prematurely.

Getting further help:
*********************
* Check the log files in /home/jinlian/.rally/logs for errors.
* Read the documentation at https://esrally.readthedocs.io/en/1.3.0/
* Ask a question on the forum at https://discuss.elastic.co/c/elasticsearch/rally
* Raise an issue at https://github.com/elastic/rally/issues and include the log files in /home/jinlian/.rally/logs.

-----------------------------------
[INFO] FAILURE (took 26049 seconds)
-----------------------------------

```

Rally log: [rally.log](https://gist.github.com/jinlianch/7d3a8d740ada664218b926286bfd25ce#file-rally-log)

---

<div class="post-metadata">

**Author:** ![dliappis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dliappis/32/56174_2.png) [@dliappis](https://discuss.elastic.co/u/dliappis)\
**Post date:** [November 21, 2019, 12:04pm UTC](https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415/2 "2019-11-21T12:04:02Z")

</div>

Hi,

Checking the log file attached, we see that after issuing:

`POST http://xxxxxx:80/_all/_forcemerge`

the elasticsearch client that Rally uses received:

`http.client.RemoteDisconnected: Remote end closed connection without response`

indicating that something very bad happened to Elasticsearch after this operation; was Elasticsearch still operational after force-merge? You could also check the Elasticsearch logs.

---

<div class="post-metadata">

**Author:** ![Jinlian\_Chen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jinlian_chen/32/44738_2.png) [@Jinlian\_Chen](https://discuss.elastic.co/u/Jinlian_Chen)\
**Post date:** [November 22, 2019, 1:24am UTC](https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415/3 "2019-11-22T01:24:40Z")

</div>

After the races, the elasticsearch works fine, I can access it through the kibana, and other races work fine.And if I set iterations to 100000 it work fine too.  
I can't check the log now because the docker have closed.  
I saw the doc said the report do not include force\_merge operation. I'll try do race without force\_merge.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 20, 2019, 1:24am UTC](https://discuss.elastic.co/t/esrally-failed-to-show-result-cannot-race-load-generator-14-has-exited-prematurely/208415/4 "2019-12-20T01:24:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
