# /etc/init.d/elasticsearch start doesn't work on Ubuntu 13.10

**URL:** <https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847>\
**Category:** Elasticsearch\
**Created:** [February 17, 2014, 1:40pm UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847 "2014-02-17T13:40:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mads\_Martin\_Jorgense](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@Mads\_Martin\_Jorgense](https://discuss.elastic.co/u/Mads_Martin_Jorgense)\
**Post date:** [February 17, 2014, 1:40pm UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847/1 "2014-02-17T13:40:08Z")

</div>

Hello all,

I've been enjoying the .deb packages on Ubuntu 13.10 for a while now, and  
they always worked. When I wanted to test the 1.0.0, I got the following  
error in the logs:

[2014-02-17 14:13:32,978][INFO][node] [Power  
Princess] version[1.0.0], pid[1587], build[a46900e/2014-02-12T16:18:34Z]  
[2014-02-17 14:13:32,978][INFO][node] [Power  
Princess] initializing ...  
[2014-02-17 14:13:33,010][INFO][plugins] [Power  
Princess] loaded [cloud-aws], sites [bigdesk]  
[2014-02-17 14:13:34,852][ERROR][bootstrap] {1.0.0}:  
Initialization Failed ...

- ExecutionError[java.lang.NoClassDefFoundError:  
org/elasticsearch/ElasticSearchIllegalArgumentException]

NoClassDefFoundError[org/elasticsearch/ElasticSearchIllegalArgumentException]

ClassNotFoundException[org.elasticsearch.ElasticSearchIllegalArgumentException]

I was looking through the documentation here:

[http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html)

But couldn't find anything indicating that startup shouldn't work with the  
init script from the distribution.

Any pointers to what I might be doing wrong?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 17, 2014, 1:41pm UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847/2 "2014-02-17T13:41:34Z")

</div>

You have an old version of a cloud-aws plugin.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 17 février 2014 à 14:40:12, [madsmartin@colourbox.com](mailto:madsmartin@colourbox.com) ([madsmartin@colourbox.com](mailto:madsmartin@colourbox.com)) a écrit:

Hello all,

I've been enjoying the .deb packages on Ubuntu 13.10 for a while now, and they always worked. When I wanted to test the 1.0.0, I got the following error in the logs:

[2014-02-17 14:13:32,978][INFO][node] [Power Princess] version[1.0.0], pid[1587], build[a46900e/2014-02-12T16:18:34Z]  
[2014-02-17 14:13:32,978][INFO][node] [Power Princess] initializing ...  
[2014-02-17 14:13:33,010][INFO][plugins] [Power Princess] loaded [cloud-aws], sites [bigdesk]  
[2014-02-17 14:13:34,852][ERROR][bootstrap] {1.0.0}: Initialization Failed ...

- ExecutionError[java.lang.NoClassDefFoundError: org/elasticsearch/ElasticSearchIllegalArgumentException]  
NoClassDefFoundError[org/elasticsearch/ElasticSearchIllegalArgumentException]  
ClassNotFoundException[org.elasticsearch.ElasticSearchIllegalArgumentException]

I was looking through the documentation here:

[http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html)

But couldn't find anything indicating that startup shouldn't work with the init script from the distribution.

## Any pointers to what I might be doing wrong?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.5302118e.3dc240fb.f2%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.5302118e.3dc240fb.f2%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Mads\_Martin\_Jorgense](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@Mads\_Martin\_Jorgense](https://discuss.elastic.co/u/Mads_Martin_Jorgense)\
**Post date:** [February 17, 2014, 1:46pm UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847/3 "2014-02-17T13:46:55Z")

</div>

I tried disabling bigdesk. Still fails.

On Monday, February 17, 2014 2:40:08 PM UTC+1, [madsm...@colourbox.com](mailto:madsm...@colourbox.com) wrote:

> Hello all,
> 
> I've been enjoying the .deb packages on Ubuntu 13.10 for a while now, and  
> they always worked. When I wanted to test the 1.0.0, I got the following  
> error in the logs:
> 
> [2014-02-17 14:13:32,978][INFO][node] [Power  
> Princess] version[1.0.0], pid[1587], build[a46900e/2014-02-12T16:18:34Z]  
> [2014-02-17 14:13:32,978][INFO][node] [Power  
> Princess] initializing ...  
> [2014-02-17 14:13:33,010][INFO][plugins] [Power  
> Princess] loaded [cloud-aws], sites [bigdesk]  
> [2014-02-17 14:13:34,852][ERROR][bootstrap] {1.0.0}:  
> Initialization Failed ...
> 
> - ExecutionError[java.lang.NoClassDefFoundError:  
> org/elasticsearch/ElasticSearchIllegalArgumentException]
> 
> NoClassDefFoundError[org/elasticsearch/ElasticSearchIllegalArgumentException]
> 
> ClassNotFoundException[org.elasticsearch.ElasticSearchIllegalArgumentException]
> 
> I was looking through the documentation here:
> 
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html)
> 
> But couldn't find anything indicating that startup shouldn't work with the  
> init script from the distribution.
> 
> Any pointers to what I might be doing wrong?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/b1437bf9-6db1-4ccb-801c-628eb159213f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/b1437bf9-6db1-4ccb-801c-628eb159213f%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Mads\_Martin\_Jorgense](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@Mads\_Martin\_Jorgense](https://discuss.elastic.co/u/Mads_Martin_Jorgense)\
**Post date:** [February 17, 2014, 2:08pm UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847/4 "2014-02-17T14:08:49Z")

</div>

Thanks a bunch! That solved it. Speaking of the shared gateway on s3 being  
deprecated. Is that still planned?

On Monday, February 17, 2014 2:41:34 PM UTC+1, David Pilato wrote:

> You have an old version of a cloud-aws plugin.
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 17 février 2014 à 14:40:12, [madsm...@colourbox.com](mailto:madsm...@colourbox.com) \<javascript:\> (  
> [madsm...@colourbox.com](mailto:madsm...@colourbox.com) \<javascript:\>) a écrit:
> 
> Hello all,
> 
> I've been enjoying the .deb packages on Ubuntu 13.10 for a while now, and  
> they always worked. When I wanted to test the 1.0.0, I got the following  
> error in the logs:
> 
> [2014-02-17 14:13:32,978][INFO][node] [Power  
> Princess] version[1.0.0], pid[1587], build[a46900e/2014-02-12T16:18:34Z]  
> [2014-02-17 14:13:32,978][INFO][node] [Power  
> Princess] initializing ...  
> [2014-02-17 14:13:33,010][INFO][plugins] [Power  
> Princess] loaded [cloud-aws], sites [bigdesk]  
> [2014-02-17 14:13:34,852][ERROR][bootstrap] {1.0.0}:  
> Initialization Failed ...
> 
> - ExecutionError[java.lang.NoClassDefFoundError:  
> org/elasticsearch/ElasticSearchIllegalArgumentException]
> 
> NoClassDefFoundError[org/elasticsearch/ElasticSearchIllegalArgumentException]
> 
> ClassNotFoundException[org.elasticsearch.ElasticSearchIllegalArgumentException]
> 
> I was looking through the documentation here:
> 
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/breaking-changes.html)
> 
> But couldn't find anything indicating that startup shouldn't work with the  
> init script from the distribution.
> 
> ## Any pointers to what I might be doing wrong?
> 
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0d0e7e25-ee39-4e2a-8b27-84f08bc0abb1%40googlegroups.com)  
> .  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/17c9e505-c2e6-4691-aa9d-f5f1c9a9bde2%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/17c9e505-c2e6-4691-aa9d-f5f1c9a9bde2%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:49am UTC](https://discuss.elastic.co/t/etc-init-d-elasticsearch-start-doesnt-work-on-ubuntu-13-10/15847/5 "2017-07-06T01:49:39Z")

</div>


