# Everything is broken after upgrade to 7.11

**URL:** https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973
**Category:** Kibana
**Created:** [February 11, 2021, 9:21am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973 "2021-02-11T09:21:15Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)
#### Post date: [February 11, 2021, 9:21am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/1 "2021-02-11T09:21:15Z")

</div>

After upgrade to 7.11 everything is broken:  
-Elastic-agent in Fleet stopped every agent;  
-Stack management won't open;  
-Trying to read logs in Discover gives an error:

'Wrapper@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:4249](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:4249)  
\_createSuperInternal@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:3388](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:3388)  
HttpFetchError@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:6016](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:6016)  
\_callee3$@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:59535](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:59535)  
l@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:982071](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:982071)  
s/o.\_invoke\</\<@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:981825](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:981825)  
\_/\</e[t]@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:982428](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/kbn-ui-shared-deps/kbn-ui-shared-deps.js:380:982428)  
fetch\_asyncGeneratorStep@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:52652](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:52652)  
\_next@[https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:52992](https://2e233a9cadac49f5b5e52ee324f8e04f.westeurope.azure.elastic-cloud.com:9243/36136/bundles/core/core.entry.js:6:52992)'

---

<div class="post-metadata">

### Author: ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)
#### Post date: [February 11, 2021, 11:45pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/2 "2021-02-11T23:45:32Z")

</div>

Hi Herman! Sorry to hear about that.

Can you check if [this bug](https://github.com/elastic/kibana/issues/90984) matches your issue? If so, there appears to be a [workaround.](https://github.com/elastic/kibana/issues/90984#issuecomment-777510634).

---

<div class="post-metadata">

### Author: ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)
#### Post date: [February 12, 2021, 10:33am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/3 "2021-02-12T10:33:29Z")

</div>

Hi Nick,

Thanks for your quick answer.

Do I have to remove the greyed text only, or also everything in between?

Thanks Herman

---

<div class="post-metadata">

### Author: ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)
#### Post date: [February 12, 2021, 10:47am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/4 "2021-02-12T10:47:39Z")

</div>

Hi Nick,

Thank you for your quick reaction. Disregard my previous question. I’ve updated 4 templates and error isn’t occurring anymore.

But now I am getting a new error:

Unable to initialize Fleet

Concurrent installation or upgrade of endpoint-0.17.1 detected, aborting.

Thanks,

Herman

---

<div class="post-metadata">

### Author: ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)
#### Post date: [February 12, 2021, 11:03am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/5 "2021-02-12T11:03:44Z")

</div>

Hi,  
Sorry, maybe I was too quick. After a while the first error occurred again and I had to do 6 more template updates.  
It's working again!  
Thanks,  
Herman

---

<div class="post-metadata">

### Author: ![MakoWish](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@MakoWish](https://discuss.elastic.co/u/MakoWish)
#### Post date: [February 16, 2021, 10:54pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/6 "2021-02-16T22:54:07Z")

</div>

I am also unfortunately having this issue. I have run through the workaround, and I also ran into the error:

```auto
Unable to initialize Fleet.

Concurrent installation or upgrade of endpoint-0.17.1 detected, aborting.

```

I have tried refreshing the page multiple times over the past hour or so, looking for more index templates to fix, but I either receive the above error, or I get:

```auto
Unable to initialize Fleet

An internal server error occurred.

```

The workaround does not appear to be working for us.

---

<div class="post-metadata">

### Author: ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)
#### Post date: [February 17, 2021, 1:46am UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/7 "2021-02-17T01:46:49Z")

</div>

Hi Eric,

I had the same. But trying sometime later gave me more broken index templates. In the end till 6 or 7 or so.

Fixed them all and problem solved.

Herman

---

<div class="post-metadata">

### Author: ![MakoWish](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@MakoWish](https://discuss.elastic.co/u/MakoWish)
#### Post date: [February 17, 2021, 3:43pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/8 "2021-02-17T15:43:12Z")

</div>

Next day now, and I still cannot get past the internal server error. I did modify several index templates per the workaround, but all I get is the internal server error now.

I do see these in the Kibana logs:

```auto
{"type":"log","@timestamp":"2021-02-17T07:35:38-08:00","tags":["error","plugins","fleet"],"pid":806,"message":"Request Timeout after 30000ms"}
{"type":"log","@timestamp":"2021-02-17T07:35:38-08:00","tags":["error","http"],"pid":806,"message":"Error: options.statusCode is expected to be set. given options: undefined
    at Object.customError (/usr/share/kibana/src/core/server/http/router/response.js:136:13)
    at defaultIngestErrorHandler (/usr/share/kibana/x-pack/plugins/fleet/server/errors/handlers.js:117:19)
    at FleetSetupHandler (/usr/share/kibana/x-pack/plugins/fleet/server/routes/setup/handlers.js:111:50)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:163:30)
    at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)
    at module.exports.internals.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:45:28)
    at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:312:32)
    at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:221:9)"}
{"type":"error","@timestamp":"2021-02-17T07:34:58-08:00","tags":[],"pid":806,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error
    at HapiResponseAdapter.toInternalError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:58:19)
    at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:177:34)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)
    at module.exports.internals.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:45:28)
    at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:312:32)
    at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:221:9)"},"url":"https://kb.contoso.com/api/fleet/setup","message":"Internal Server Error"}
{"type":"response","@timestamp":"2021-02-17T07:34:58-08:00","tags":["access:fleet-read"],"pid":806,"method":"post","statusCode":500,"req":{"url":"/api/fleet/setup","method":"post","headers":{"host":"kb.contoso.com","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0","accept":"*/*","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate, br","referer":"https://kb.contoso.com/s/space-name/app/fleet","content-type":"application/json","kbn-version":"7.11.0","origin":"https://kb.contoso.com","connection":"keep-alive","content-length":"0"},"remoteAddress":"192.168.1.100","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0","referer":"https://kb.contoso.com/s/space-name/app/fleet"},"res":{"statusCode":500,"responseTime":40519,"contentLength":9},"message":"POST /api/fleet/setup 500 40519ms - 9.0B"}

```

---

<div class="post-metadata">

### Author: ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)
#### Post date: [February 17, 2021, 3:58pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/9 "2021-02-17T15:58:14Z")

</div>

I think you are hitting this issue [[Fleet] Upgrade to 7.11 failed · Issue #90984 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/90984) . It will be shipped with 7.11.1

Thanks  
Rashmi

---

<div class="post-metadata">

### Author: ![MakoWish](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@MakoWish](https://discuss.elastic.co/u/MakoWish)
#### Post date: [February 17, 2021, 4:00pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/10 "2021-02-17T16:00:13Z")

</div>

It is the same issue, but the workaround that seems to be working for others did not work for me.

---

<div class="post-metadata">

### Author: ![skh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skh/32/38637_2.png) [@skh](https://discuss.elastic.co/u/skh)
#### Post date: [February 17, 2021, 4:16pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/11 "2021-02-17T16:16:47Z")

</div>

@MakoWish I think you might be seeing the same problem as described in [Unable to initialize Fleet - An internal server error occurred](https://discuss.elastic.co/t/unable-to-initialize-fleet-an-internal-server-error-occurred/264368)

We're tracking this in [[Fleet] [Security Solution] Fleet cannot upgrade: Transform stop times out · Issue #91570 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/91570)

---

<div class="post-metadata">

### Author: ![PublicName](https://avatars.discourse-cdn.com/v4/letter/p/74df32/32.png) [@PublicName](https://discuss.elastic.co/u/PublicName)
#### Post date: [February 17, 2021, 8:20pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/12 "2021-02-17T20:20:47Z")

</div>

7.11.1 did not resolve the issue.

It made matters worse not sure if @MakoWish has had any luck but I for one ran into his issue with 7.11. 7.11.1 has another error where it will not connect to Elastic at all when it is clearly running and accepting connections.

---

<div class="post-metadata">

### Author: ![MakoWish](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@MakoWish](https://discuss.elastic.co/u/MakoWish)
#### Post date: [February 17, 2021, 9:37pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/13 "2021-02-17T21:37:53Z")

</div>

7.11.1 also did not fix the issue for me. I am still receiving the same error.

```auto
Unable to initialize Fleet

An internal server error occurred.

```

---

<div class="post-metadata">

### Author: ![searchtool](https://avatars.discourse-cdn.com/v4/letter/s/85f322/32.png) [@searchtool](https://discuss.elastic.co/u/searchtool)
#### Post date: [February 17, 2021, 9:38pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/14 "2021-02-17T21:38:56Z")

</div>

> [@skh](#):
>
> @MakoWish I think you might be seeing the same problem as described in [Unable to initialize Fleet - An internal server error occurred](https://discuss.elastic.co/t/unable-to-initialize-fleet-an-internal-server-error-occurred/264368)
> 
> We're tracking this in [[Fleet] [Security Solution] Fleet cannot upgrade: Transform stop times out · Issue #91570 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/91570)

Adding the transform node solved my issue!

---

<div class="post-metadata">

### Author: ![MakoWish](https://avatars.discourse-cdn.com/v4/letter/m/e56c9b/32.png) [@MakoWish](https://discuss.elastic.co/u/MakoWish)
#### Post date: [February 18, 2021, 4:17pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/15 "2021-02-18T16:17:44Z")

</div>

I just saw that this morning and came here to link to the post, but you beat me to it! 🙂 Adding the Transform role solved the issue for me as well.

Slightly off-topic, but question on the role... I enabled it on both our Kibana servers for now (ES coordinating nodes), but what node does "best practice" say to enable it on?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 18, 2021, 4:17pm UTC](https://discuss.elastic.co/t/everything-is-broken-after-upgrade-to-7-11/263973/16 "2021-03-18T16:17:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
