# EXCEPTION\_ACCESS\_VIOLATION in Elasticsearch 8.16.1 Running on Java 17

**URL:** <https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277>\
**Category:** Elasticsearch\
**Tags:** runtime-fields\
**Created:** [December 1, 2024, 11:35am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277 "2024-12-01T11:35:05Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 1, 2024, 11:35am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/1 "2024-12-01T11:35:05Z")

</div>

**Error Summary** : I'm encountering a fatal error when running Elasticsearch 8.16.1 on Windows Server 2016. The process crashes with an access violation. Below are the details:

**System Configuration** :

-OS: Windows Server 2016 (64-bit), Build 14393.  
-JVM: Java(TM) SE Runtime Environment (17.0.12+8).  
-Memory: 32GB physical memory, 16GB heap size (`-Xms16383m`, `-Xmx16383m`).  
Elasticsearch Version\*\*: 8.16.1.

**Error Details** :

EXCEPTION\_ACCESS\_VIOLATION (0xc0000005) at pc=0x000002c55fc5aaa1  
Problematic frame: J 5866 c2 java.lang.String.compareTo(Ljava/lang/Object;)I java.base@17.0.12

```auto

Steps Taken:

1-Verified JAVA_HOME is set correctly to jdk-17.
2-Removed bundled JDK to force the use of external JDK.
3-Created a custom jvm.options.d file to adjust heap size but kept encountering the same crash.

Questions:

Is the access violation due to my heap size configuration? Should I reduce it further?
Could this be a bug in Elasticsearch or Java 17?
```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 1, 2024, 12:17pm UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/2 "2024-12-01T12:17:21Z")

</div>

Why are you not using the bundled JVM?

Which JVM are you using? Is it listed [in the support matrix](https://www.elastic.co/support/matrix/#matrix_jvm)?

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 1, 2024, 12:37pm UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/3 "2024-12-01T12:37:40Z")

</div>

when i run it , i get this message :

warning: ignoring JAVA\_HOME=C:\Program Files\Java\jdk-17; using bundled JDK

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 1, 2024, 1:00pm UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/4 "2024-12-01T13:00:43Z")

</div>

That is fine as it says it is using the bundled JDK, which is the recommended option.

Does this work or does it produce any error (not warning)?

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 1, 2024, 1:37pm UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/5 "2024-12-01T13:37:06Z")

</div>

each time i try to run elasticsearch i get this error:

# A fatal error has been detected by the Java Runtime Environment:

# 

# EXCEPTION\_ACCESS\_VIOLATION (0xc0000005) at pc=0x000002c55fc5aaa1, pid=2344, tid=7976

# 

# JRE version: Java(TM) SE Runtime Environment (17.0.12+8) (build 17.0.12+8-LTS-286)

# Java VM: Java HotSpot(TM) 64-Bit Server VM (17.0.12+8-LTS-286, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)

# Problematic frame:

# J 5866 c2 java.lang.String.compareTo(Ljava/lang/Object;)I java.base@17.0.12 (9 bytes) @ 0x000002c55fc5aaa1 [0x000002c55fc5a9a0+0x0000000000000101]

# 

# Core dump will be written. Default location: E:\ELK\elasticsearch-8.16.1\hs\_err\_pid2344.mdmp

# 

# An error report file with more information is saved as:

# logs/hs\_err\_pid2344.log

# 

# If you would like to submit a bug report, please visit:

# [Crash Report](https://bugreport.java.com/bugreport/crash.jsp)

# 

ERROR: Elasticsearch exited unexpectedly, with exit code 1  
'%\*' is not recognized as an internal or external command,  
operable program or batch file.  
|| was unexpected at this time.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 1, 2024, 3:10pm UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/6 "2024-12-01T15:10:56Z")

</div>

I thought the latest version of Elasticsearch bundle a newer JVM. Is this error when you are using the bundled version?

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 2, 2024, 4:59am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/7 "2024-12-02T04:59:26Z")

</div>

Yes, Because it ignores the JAVA\_HOME that I set in the environment variables.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 2, 2024, 5:43am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/8 "2024-12-02T05:43:47Z")

</div>

I believe Elasticsearch 8.16.1 comes bundled with Java 23 but your error relates to Java 17. Please check the version in your install folder and try unsetting JAVA\_HOME to see if that makes a difference.

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 2, 2024, 6:38am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/9 "2024-12-02T06:38:08Z")

</div>

i removed JAVA\_HOME from environment variables, i got this error:

**[2024-12-02T09:34:28,455][ERROR][o.e.b.Elasticsearch] [JIC-AT] fatal exception while booting Elasticsearchjava.lang.ExceptionInInitializerError: null**  
\*\* at org.elasticsearch.xcontent.impl@8.16.1/org.elasticsearch.xcontent.provider.XContentProviderImpl$2.XContent(XContentProviderImpl.java:54)\*\*  
\*\* at org.elasticsearch.xcontent@8.16.1/org.elasticsearch.xcontent.json.JsonXContent.(JsonXContent.java:37)\*\*  
\*\* at org.elasticsearch.xcontent@8.16.1/org.elasticsearch.xcontent.XContentType.(XContentType.java:28)\*\*  
\*\* at org.elasticsearch.server@8.16.1/org.elasticsearch.plugins.scanners.ExtensibleFileReader.readFromFile(ExtensibleFileReader.java:38)\*\*  
\*\* at org.elasticsearch.server@8.16.1/org.elasticsearch.plugins.scanners.ExtensiblesRegistry.(ExtensiblesRegistry.java:78)\*\*

**See logs for more details.**

**ERROR: Elasticsearch did not exit normally - check the logs at E:\ELK\elasticsearch-8.16.1\logs\elasticsearch.log**

**ERROR: Elasticsearch died while starting up, with exit code 1**

elasticsearch.logs:

**[2024-12-02T09:34:28,455][ERROR][o.e.b.Elasticsearch] [JIC-AT] fatal exception while booting Elasticsearch**  
**java.lang.ExceptionInInitializerError: null**  
\*\* at org.elasticsearch.xcontent.provider.XContentProviderImpl$2.XContent(XContentProviderImpl.java:54) ~[?:?]\*\*  
\*\* at org.elasticsearch.xcontent.json.JsonXContent.(JsonXContent.java:37) ~[elasticsearch-x-content-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.xcontent.XContentType.(XContentType.java:28) ~[elasticsearch-x-content-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.scanners.ExtensibleFileReader.readFromFile(ExtensibleFileReader.java:38) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.scanners.ExtensiblesRegistry.(ExtensiblesRegistry.java:78) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.scanners.ExtensiblesRegistry.(ExtensiblesRegistry.java:70) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.scanners.NamedComponentReader.(NamedComponentReader.java:47) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.scanners.StablePluginsRegistry.(StablePluginsRegistry.java:38) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.plugins.PluginsService.(PluginsService.java:113) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.node.NodeServiceProvider.newPluginService(NodeServiceProvider.java:56) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.node.NodeConstruction.createEnvironment(NodeConstruction.java:473) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.node.NodeConstruction.prepareConstruction(NodeConstruction.java:267) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.node.Node.(Node.java:200) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.bootstrap.Elasticsearch$2.(Elasticsearch.java:240) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:240) ~[elasticsearch-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:75) ~[elasticsearch-8.16.1.jar:?]\*\*  
**Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "E:\ELK\elasticse" "read")**  
\*\* at java.security.AccessControlContext.checkPermission(AccessControlContext.java:488) ~[?:?]\*\*  
\*\* at java.security.AccessController.checkPermission(AccessController.java:1085) ~[?:?]\*\*  
\*\* at java.lang.SecurityManager.checkPermission(SecurityManager.java:411) ~[?:?]\*\*  
\*\* at java.lang.SecurityManager.checkRead(SecurityManager.java:742) ~[?:?]\*\*  
\*\* at java.util.zip.ZipFile.(ZipFile.java:243) ~[?:?]\*\*  
\*\* at java.util.zip.ZipFile.(ZipFile.java:181) ~[?:?]\*\*  
\*\* at java.util.jar.JarFile.(JarFile.java:345) ~[?:?]\*\*  
\*\* at sun.net.www.protocol.jar.URLJarFile.(URLJarFile.java:73) ~[?:?]\*\*  
\*\* at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:59) ~[?:?]\*\*  
\*\* at sun.net.www.protocol.jar.JarFileFactory.getOrCreate(JarFileFactory.java:106) ~[?:?]\*\*  
\*\* at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:117) ~[?:?]\*\*  
\*\* at sun.net.www.protocol.jar.JarURLConnection.getInputStream(JarURLConnection.java:160) ~[?:?]\*\*  
\*\* at java.net.URL.openStream(URL.java:1325) ~[?:?]\*\*  
\*\* at java.lang.ClassLoader.getResourceAsStream(ClassLoader.java:1755) ~[?:?]\*\*  
\*\* at org.elasticsearch.core.internal.provider.EmbeddedImplClassLoader.findResourceInLoaderPkgOrNull(EmbeddedImplClassLoader.java:198) ~[elasticsearch-core-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.core.internal.provider.EmbeddedImplClassLoader.lambda$privilegedGetResourceOrNull$3(EmbeddedImplClassLoader.java:125) ~[elasticsearch-core-8.16.1.jar:?]\*\*  
\*\* at java.security.AccessController.doPrivileged(AccessController.java:319) ~[?:?]\*\*  
\*\* at org.elasticsearch.core.internal.provider.EmbeddedImplClassLoader.privilegedGetResourceOrNull(EmbeddedImplClassLoader.java:124) ~[elasticsearch-core-8.16.1.jar:?]\*\*  
\*\* at org.elasticsearch.core.internal.provider.EmbeddedImplClassLoader.findClass(EmbeddedImplClassLoader.java:151) ~[elasticsearch-core-8.16.1.jar:?]\*\*  
\*\* at java.lang.ClassLoader.loadClass(ClassLoader.java:595) ~[?:?]\*\*  
\*\* at java.lang.ClassLoader.loadClass(ClassLoader.java:528) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.sym.CharsToNameCanonicalizer$TableInfo.createInitial(CharsToNameCanonicalizer.java:940) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.sym.CharsToNameCanonicalizer.(CharsToNameCanonicalizer.java:260) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.sym.CharsToNameCanonicalizer.createRoot(CharsToNameCanonicalizer.java:358) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.sym.CharsToNameCanonicalizer.createRoot(CharsToNameCanonicalizer.java:336) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.JsonFactory.(JsonFactory.java:448) ~[?:?]\*\*  
\*\* at com.fasterxml.jackson.core.JsonFactoryBuilder.build(JsonFactoryBuilder.java:236) ~[?:?]\*\*  
\*\* at org.elasticsearch.xcontent.provider.XContentImplUtils.configure(XContentImplUtils.java:20) ~[?:?]\*\*  
\*\* at org.elasticsearch.xcontent.provider.json.JsonXContentImpl.(JsonXContentImpl.java:50) ~[?:?]\*\*  
\*\* ... 16 more\*\*

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 2, 2024, 6:51am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/10 "2024-12-02T06:51:47Z")

</div>

> [@SalehEska](#):
>
> Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "E:\ELK\elasticse" "read")

Seems to be an issue with permissions? I do not run Elasticsearch on Windows so will likely not be able to help much if there are any Windows specific issues.

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 2, 2024, 7:16am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/11 "2024-12-02T07:16:06Z")

</div>

I have resolved the permission issue and reran the process, but I encountered this error:

# A fatal error has been detected by the Java Runtime Environment:

# 

# EXCEPTION\_ACCESS\_VIOLATION (0xc0000005) at pc=0x00000241b52f8ecd, pid=3856, tid=4828

# 

# JRE version: OpenJDK Runtime Environment (23.0+37) (build 23+37-2369)

# Java VM: OpenJDK 64-Bit Server VM (23+37-2369, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)

# Problematic frame:

# J 11542 c2 java.util.TreeMap.get(Ljava/lang/Object;)Ljava/lang/Object; java.base@23 (19 bytes) @ 0x00000241b52f8ecd [0x00000241b52f8d40+0x000000000000018d]

# 

# Core dump will be written. Default location: E:\ELK\elasticsearch-8.16.1\hs\_err\_pid3856.mdmp

# 

# An error report file with more information is saved as:

# logs/hs\_err\_pid3856.log

[76.953s][warning][os] Loading hsdis library failed

# 

# If you would like to submit a bug report, please visit:

# [Crash Report](https://bugreport.java.com/bugreport/crash.jsp)

#Elastic Stack > Elasticsearch

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 2, 2024, 7:20am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/12 "2024-12-02T07:20:20Z")

</div>

What is in the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 2, 2024, 7:27am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/13 "2024-12-02T07:27:24Z")

</div>

The error is not present in the Elasticsearch logs. Here is what exists:

[2024-12-02T10:21:54,672][INFO][o.e.x.m.p.NativeController] [JIC-AT] Native controller process has stopped - no new native processes can be started  
[2024-12-02T10:23:51,230][INFO][o.e.n.NativeAccess] [JIC-AT] Using [jdk] native provider and native methods for [Windows]  
[2024-12-02T10:23:51,667][INFO][o.a.l.i.v.PanamaVectorizationProvider] [JIC-AT] Java vector incubator API enabled; uses preferredBitSize=128; floating-point vectors only  
[2024-12-02T10:23:56,199][INFO][o.e.n.Node] [JIC-AT] version[8.16.1], pid[3544], build[zip/ffe992aa682c1968b5df375b5095b3a21f122bf3/2024-11-19T16:00:31.793213192Z], OS[Windows Server 2016/10.0/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/23/23+37-2369]  
[2024-12-02T10:23:56,199][INFO][o.e.n.Node] [JIC-AT] JVM home [E:\ELK\elasticsearch-8.16.1\jdk], using bundled JDK [true]  
[2024-12-02T10:23:56,199][INFO][o.e.n.Node] [JIC-AT] JVM arguments [-Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -Djava.security.manager=allow, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=CLDR, --enable-native-access=org.elasticsearch.nativeaccess,org.apache.lucene.core, -XX:ReplayDataFile=logs/replay\_pid%p.log, -Des.distribution.type=zip, -XX:+UseG1GC, -Djava.io.tmpdir=C:\Users\ADMINI~1\AppData\Local\Temp\2\elasticsearch, --add-modules=jdk.incubator.vector, -XX:CompileCommand=dontinline,java/lang/invoke/MethodHandle.setAsTypeCache, -XX:CompileCommand=dontinline,java/lang/invoke/MethodHandle.asTypeUncached, -XX:+HeapDumpOnOutOfMemoryError, -XX:+ExitOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=logs/hs\_err\_pid%p.log, -Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,level,pid,tags:filecount=32,filesize=64m, -Djava.security.policy=E:\ELK\elasticsearch-8.16.1\config\elasticsearch.policy, -Xms16383m, -Xmx16383m, -XX:MaxDirectMemorySize=8589934592, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=25, --module-path=E:\ELK\elasticsearch-8.16.1\lib, --add-modules=[jdk.net](http://jdk.net), --add-modules=ALL-MODULE-PATH, -Djdk.module.main=org.elasticsearch.server]  
[2024-12-02T10:23:56,199][INFO][o.e.n.Node] [JIC-AT] Default Locale [en\_US]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [repository-url]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [rest-root]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-core]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-redact]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [ingest-user-agent]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-async-search]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-monitoring]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [repository-s3]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-analytics]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-esql-core]  
[2024-12-02T10:24:08,793][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-ent-search]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-autoscaling]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [lang-painless]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-ml]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [lang-mustache]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [legacy-geo]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [logsdb]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-ql]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [rank-rrf]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [analysis-common]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [health-shards-availability]  
[2024-12-02T10:24:08,808][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [transport-netty4]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [aggregations]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [ingest-common]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [frozen-indices]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-identity-provider]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-shutdown]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-text-structure]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [snapshot-repo-test-kit]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [ml-package-loader]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [kibana]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [constant-keyword]  
[2024-12-02T10:24:08,824][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-logstash]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-ccr]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-graph]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-esql]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [parent-join]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [counted-keyword]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-enrich]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [repositories-metering-api]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [transform]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [repository-azure]  
[2024-12-02T10:24:08,840][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [dot-prefix-validation]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [repository-gcs]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [spatial]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-otel-data]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [apm]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [mapper-extras]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [mapper-version]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-rollup]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [percolator]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [data-streams]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-stack]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [rank-eval]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [reindex]  
[2024-12-02T10:24:08,855][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-security]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [blob-cache]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [searchable-snapshots]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-slm]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-geoip-enterprise-downloader]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [snapshot-based-recoveries]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-watcher]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [old-lucene-versions]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-ilm]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-inference]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-voting-only-node]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-deprecation]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-fleet]  
[2024-12-02T10:24:08,871][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-aggregate-metric]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-downsample]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-profiling]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [ingest-geoip]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-write-load-forecaster]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [search-business-rules]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [ingest-attachment]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [wildcard]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-apm-data]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [unsigned-long]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-sql]  
[2024-12-02T10:24:08,886][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [runtime-fields-common]  
[2024-12-02T10:24:08,902][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-async]  
[2024-12-02T10:24:08,902][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [vector-tile]  
[2024-12-02T10:24:08,902][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [lang-expression]  
[2024-12-02T10:24:08,902][INFO][o.e.p.PluginsService] [JIC-AT] loaded module [x-pack-eql]  
[2024-12-02T10:24:12,755][INFO][o.e.e.NodeEnvironment] [JIC-AT] using [1] data paths, mounts [[New Volume (E:)]], net usable\_space [376.8gb], net total\_space [399.9gb], types [NTFS]  
[2024-12-02T10:24:12,755][INFO][o.e.e.NodeEnvironment] [JIC-AT] heap size [16gb], compressed ordinary object pointers [true]  
[2024-12-02T10:24:12,896][INFO][o.e.n.Node] [JIC-AT] node name [JIC-AT], node ID [HqyHXNslTDyMAf1y2Jqwjg], cluster name [elasticsearch], roles [ml, data\_hot, transform, data\_content, data\_warm, master, remote\_cluster\_client, data, data\_cold, ingest, data\_frozen]

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 2, 2024, 7:34am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/14 "2024-12-02T07:34:45Z")

</div>

> [@SalehEska](#):
>
> [76.953s][warning][os] Loading hsdis library failed

This seems to be the issue. Have not seen this before, maybe it is a Windows specific issue.

---

<div class="post-metadata">

**Author:** ![SalehEska](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saleheska/32/121805_2.png) [@SalehEska](https://discuss.elastic.co/u/SalehEska)\
**Post date:** [December 2, 2024, 7:51am UTC](https://discuss.elastic.co/t/exception-access-violation-in-elasticsearch-8-16-1-running-on-java-17/371277/15 "2024-12-02T07:51:16Z")

</div>

You were right; that caused the error. I added a line to the JVM.options file located in elasticsearch/config, and it resolved the issue.

-XX:UseSSE=2
