# Exception at startup: failed to send ping request over multicast

**URL:** https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671
**Category:** Elasticsearch
**Created:** [December 16, 2010, 11:55am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671 "2010-12-16T11:55:48Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![cabal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cabal/32/3292_2.png) [@cabal](https://discuss.elastic.co/u/cabal)
#### Post date: [December 16, 2010, 11:55am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/1 "2010-12-16T11:55:48Z")

</div>

Hi,

I'm new here and I hope I'm in the right place.

I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1, and when I start it up with bin/elasticsearch -f this is what happens:  
[2010-12-16 12:12:42,209][INFO][node] [Sefton, Amanda] {elasticsearch/0.13.1}[12244]: initializing ...  
[2010-12-16 12:12:42,215][INFO][plugins] [Sefton, Amanda] loaded []  
[2010-12-16 12:12:46,213][INFO][node] [Sefton, Amanda] {elasticsearch/0.13.1}[12244]: initialized  
[2010-12-16 12:12:46,213][INFO][node] [Sefton, Amanda] {elasticsearch/0.13.1}[12244]: starting ...  
[2010-12-16 12:12:46,396][INFO][transport] [Sefton, Amanda] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/192.168.0.100:9300]}  
Exception in thread "elasticsearch[Sefton, Amanda][tp]-pool-1-thread-1" org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send ping request over multicast  
at org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)  
at org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)  
at org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)  
at org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)  
at org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)  
at org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)  
at org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)  
at org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
at java.lang.Thread.run(Thread.java:636)  
Caused by: java.io.IOException: Operation not permitted  
at java.net.PlainDatagramSocketImpl.send(Native Method)  
at java.net.DatagramSocket.send(DatagramSocket.java:629)  
at org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)  
... 10 more  
[2010-12-16 12:13:16,434][WARN][discovery] [Sefton, Amanda] waited for 30s and no initial state was set by the discovery  
[2010-12-16 12:13:16,435][INFO][discovery] [Sefton, Amanda] elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
[2010-12-16 12:13:16,442][INFO][http] [Sefton, Amanda] bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address {inet[/192.168.0.100:9200]}  
[2010-12-16 12:13:16,443][INFO][node] [Sefton, Amanda] {elasticsearch/0.13.1}[12244]: started  
As you can see, an exception is raised about ping over multicast.  
This also happens with versions 0.13.0 and 0.12.1, and also with the latest one compiled from source.

Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException[]"}  
I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [December 16, 2010, 7:15pm UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/2 "2010-12-16T19:15:48Z")

</div>

Do you have multicast enabled on your network? You can move to unicast  
discovery.

On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com) wrote:

> Hi,
> 
> I'm new here and I hope I'm in the right place.
> 
> I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1, and  
> when  
> I start it up with bin/elasticsearch -f this is what happens:  
> [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> Amanda]  
> {elasticsearch/0.13.1}[12244]: initializing ...  
> [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> Amanda]  
> loaded   
> [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> Amanda]  
> {elasticsearch/0.13.1}[12244]: initialized  
> [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> Amanda]  
> {elasticsearch/0.13.1}[12244]: starting ...  
> [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> Amanda]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> {inet[/192.168.0.100:9300]}  
> Exception in thread "elasticsearch[Sefton, Amanda][tp]-pool-1-thread-1"  
> org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send ping  
> request over multicast  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)  
> at
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)  
> at
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)  
> at
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)  
> at
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)  
> at
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)  
> at  
> org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)  
> at
> 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> at
> 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> at java.lang.Thread.run(Thread.java:636)  
> Caused by: java.io.IOException: Operation not permitted  
> at java.net.PlainDatagramSocketImpl.send(Native Method)  
> at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)  
> ... 10 more  
> [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> Amanda]  
> waited for 30s and no initial state was set by the discovery  
> [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> Amanda]  
> elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> Amanda]  
> bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> {inet[/192.168.0.100:9200]}  
> [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> Amanda]  
> {elasticsearch/0.13.1}[12244]: started  
> As you can see, an exception is raised about ping over multicast.  
> This also happens with versions 0.13.0 and 0.12.1, and also with the latest  
> one compiled from source.
> 
> ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> 
> View this message in context:  
> [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)  
> Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![cabal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cabal/32/3292_2.png) [@cabal](https://discuss.elastic.co/u/cabal)
#### Post date: [December 17, 2010, 8:42am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/3 "2010-12-17T08:42:17Z")

</div>

2010/12/16 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):

> Do you have multicast enabled on your network?

Er, I'm not 100% sure about that (I'm deeply ignorant of this  
subject), but I think it's enabled, since ifconfig reads:

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

for both eth0 and eth1; of course it is not enabled fot lo:

UP LOOPBACK RUNNING MTU:16436 Metric:1

so I still don't know what the problem with multicast may be.

> You can move to unicast discovery.

I tried this by writing this into config/elasticsearch.yml

discovery.zen.ping.multicast:  
enabled: false

With this, everything seems to work correctly (al least locally).  
Thanks a lot! That probably does it for me.

Carlo

> On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com) wrote:
> 
> > Hi,
> > 
> > I'm new here and I hope I'm in the right place.
> > 
> > I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1, and  
> > when  
> > I start it up with bin/elasticsearch -f this is what happens:  
> > [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> > Amanda]  
> > {elasticsearch/0.13.1}[12244]: initializing ...  
> > [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> > Amanda]  
> > loaded   
> > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > Amanda]  
> > {elasticsearch/0.13.1}[12244]: initialized  
> > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > Amanda]  
> > {elasticsearch/0.13.1}[12244]: starting ...  
> > [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> > Amanda]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > {inet[/192.168.0.100:9300]}  
> > Exception in thread "elasticsearch[Sefton, Amanda][tp]-pool-1-thread-1"  
> > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send ping  
> > request over multicast  
> > at
> > 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)  
> > at  
> > org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)  
> > at
> > 
> > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > at
> > 
> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > at java.lang.Thread.run(Thread.java:636)  
> > Caused by: java.io.IOException: Operation not permitted  
> > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> > at
> > 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)  
> > ... 10 more  
> > [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> > Amanda]  
> > waited for 30s and no initial state was set by the discovery  
> > [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> > Amanda]  
> > elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> > [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> > Amanda]  
> > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > {inet[/192.168.0.100:9200]}  
> > [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> > Amanda]  
> > {elasticsearch/0.13.1}[12244]: started  
> > As you can see, an exception is raised about ping over multicast.  
> > This also happens with versions 0.13.0 and 0.12.1, and also with the  
> > latest  
> > one compiled from source.
> > 
> > ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> > 
> > View this message in context:  
> > [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)  
> > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [December 19, 2010, 12:50am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/4 "2010-12-19T00:50:40Z")

</div>

You will still need to configure unicast discovery if you want it to work on  
several machines. The address used to send the multicast requests on is the  
publish address that you see in the log (for the transport for example).  
Maybe the one guesses by ES to use is not the correct one?

On Fri, Dec 17, 2010 at 10:42 AM, Carlo Baldassi [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)wrote:

> 2010/12/16 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):
> 
> > Do you have multicast enabled on your network?
> 
> Er, I'm not 100% sure about that (I'm deeply ignorant of this  
> subject), but I think it's enabled, since ifconfig reads:
> 
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> 
> for both eth0 and eth1; of course it is not enabled fot lo:
> 
> UP LOOPBACK RUNNING MTU:16436 Metric:1
> 
> so I still don't know what the problem with multicast may be.
> 
> > You can move to unicast discovery.
> 
> I tried this by writing this into config/elasticsearch.yml
> 
> discovery.zen.ping.multicast:  
> enabled: false
> 
> With this, everything seems to work correctly (al least locally).  
> Thanks a lot! That probably does it for me.
> 
> Carlo
> 
> > On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com) wrote:
> > 
> > > Hi,
> > > 
> > > I'm new here and I hope I'm in the right place.
> > > 
> > > I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1, and  
> > > when  
> > > I start it up with bin/elasticsearch -f this is what happens:  
> > > [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> > > Amanda]  
> > > {elasticsearch/0.13.1}[12244]: initializing ...  
> > > [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> > > Amanda]  
> > > loaded   
> > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > Amanda]  
> > > {elasticsearch/0.13.1}[12244]: initialized  
> > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > Amanda]  
> > > {elasticsearch/0.13.1}[12244]: starting ...  
> > > [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> > > Amanda]  
> > > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > > {inet[/192.168.0.100:9300]}  
> > > Exception in thread "elasticsearch[Sefton, Amanda][tp]-pool-1-thread-1"  
> > > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> > > ping  
> > > request over multicast  
> > > at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> 
> > > ```
> > > at
> > > 
> > > ```
> 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> 
> > > ```
> > > at java.lang.Thread.run(Thread.java:636)
> > > 
> > > ```
> > > 
> > > Caused by: java.io.IOException: Operation not permitted  
> > > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > > at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> > > at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)
> 
> > > ```
> > > ... 10 more
> > > 
> > > ```
> > > 
> > > [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> > > Amanda]  
> > > waited for 30s and no initial state was set by the discovery  
> > > [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> > > Amanda]  
> > > elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> > > [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> > > Amanda]  
> > > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > > {inet[/192.168.0.100:9200]}  
> > > [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> > > Amanda]  
> > > {elasticsearch/0.13.1}[12244]: started  
> > > As you can see, an exception is raised about ping over multicast.  
> > > This also happens with versions 0.13.0 and 0.12.1, and also with the  
> > > latest  
> > > one compiled from source.
> > > 
> > > ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> > > 
> > > View this message in context:
> 
> [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)
> 
> > > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![cabal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cabal/32/3292_2.png) [@cabal](https://discuss.elastic.co/u/cabal)
#### Post date: [December 20, 2010, 4:45pm UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/5 "2010-12-20T16:45:24Z")

</div>

> The address used to send the multicast requests on is the  
> publish address that you see in the log (for the transport for example).  
> Maybe the one guessed by ES to use is not the correct one?

First off: please note that I'm just experimenting on my laptop, not a  
server (yet), so my problems are probably outside the scope of ES and  
it would be more than understandable on my part if you'd just ignore  
them.

That said, in case you think it's worth trying to solve the issue,  
here's the answer to your questions: the address guessed by ES is the  
local network's 192.168.0.100, i.e. the same as that provided by  
ifconfig for eth0.  
I guess that the use of the local network might cause the issue with  
multicast (but as I said I'm deeply ignorant of the subject). Perhaps  
I should somehow force ES to use the public IP? Or modify my network's  
configuration? (I tried opening the relevant ports and modifying my  
router's configuration, with no luck.)

## Log of ElasticSerach:

[2010-12-20 17:25:46,552][INFO][transport]  
[Tarantula] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]},  
publish\_address {inet[/192.168.0.100:9300]}

## Output of ifconfig:

inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0

thanks,  
Carlo

> On Fri, Dec 17, 2010 at 10:42 AM, Carlo Baldassi [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)  
> wrote:
> 
> > 2010/12/16 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):
> > 
> > > Do you have multicast enabled on your network?
> > 
> > Er, I'm not 100% sure about that (I'm deeply ignorant of this  
> > subject), but I think it's enabled, since ifconfig reads:
> > 
> > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> > 
> > for both eth0 and eth1; of course it is not enabled fot lo:
> > 
> > UP LOOPBACK RUNNING MTU:16436 Metric:1
> > 
> > so I still don't know what the problem with multicast may be.
> > 
> > > You can move to unicast discovery.
> > 
> > I tried this by writing this into config/elasticsearch.yml
> > 
> > discovery.zen.ping.multicast:  
> > enabled: false
> > 
> > With this, everything seems to work correctly (al least locally).  
> > Thanks a lot! That probably does it for me.
> > 
> > Carlo
> > 
> > > On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com) wrote:
> > > 
> > > > Hi,
> > > > 
> > > > I'm new here and I hope I'm in the right place.
> > > > 
> > > > I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1, and  
> > > > when  
> > > > I start it up with bin/elasticsearch -f this is what happens:  
> > > > [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> > > > Amanda]  
> > > > {elasticsearch/0.13.1}[12244]: initializing ...  
> > > > [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> > > > Amanda]  
> > > > loaded   
> > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > Amanda]  
> > > > {elasticsearch/0.13.1}[12244]: initialized  
> > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > Amanda]  
> > > > {elasticsearch/0.13.1}[12244]: starting ...  
> > > > [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> > > > Amanda]  
> > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > > > {inet[/192.168.0.100:9300]}  
> > > > Exception in thread "elasticsearch[Sefton, Amanda][tp]-pool-1-thread-1"  
> > > > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> > > > ping  
> > > > request over multicast  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)  
> > > > at
> > > > 
> > > > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > > > at
> > > > 
> > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > > > at java.lang.Thread.run(Thread.java:636)  
> > > > Caused by: java.io.IOException: Operation not permitted  
> > > > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > > > at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> > > > at
> > > > 
> > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)  
> > > > ... 10 more  
> > > > [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> > > > Amanda]  
> > > > waited for 30s and no initial state was set by the discovery  
> > > > [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> > > > Amanda]  
> > > > elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> > > > [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> > > > Amanda]  
> > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > > > {inet[/192.168.0.100:9200]}  
> > > > [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> > > > Amanda]  
> > > > {elasticsearch/0.13.1}[12244]: started  
> > > > As you can see, an exception is raised about ping over multicast.  
> > > > This also happens with versions 0.13.0 and 0.12.1, and also with the  
> > > > latest  
> > > > one compiled from source.
> > > > 
> > > > ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> > > > 
> > > > View this message in context:
> > > > 
> > > > [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)  
> > > > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [December 20, 2010, 6:08pm UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/6 "2010-12-20T18:08:04Z")

</div>

It seems like mcast should be enabled for eth0, so thats strange... . You  
can try and change the network.publish\_host to a different ip and see if it  
helps?

On Mon, Dec 20, 2010 at 6:45 PM, Carlo Baldassi [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)wrote:

> > The address used to send the multicast requests on is the  
> > publish address that you see in the log (for the transport for example).  
> > Maybe the one guessed by ES to use is not the correct one?
> 
> First off: please note that I'm just experimenting on my laptop, not a  
> server (yet), so my problems are probably outside the scope of ES and  
> it would be more than understandable on my part if you'd just ignore  
> them.
> 
> That said, in case you think it's worth trying to solve the issue,  
> here's the answer to your questions: the address guessed by ES is the  
> local network's 192.168.0.100, i.e. the same as that provided by  
> ifconfig for eth0.  
> I guess that the use of the local network might cause the issue with  
> multicast (but as I said I'm deeply ignorant of the subject). Perhaps  
> I should somehow force ES to use the public IP? Or modify my network's  
> configuration? (I tried opening the relevant ports and modifying my  
> router's configuration, with no luck.)
> 
> ## Log of ElasticSerach:
> 
> [2010-12-20 17:25:46,552][INFO][transport]  
> [Tarantula] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]},  
> publish\_address {inet[/192.168.0.100:9300]}
> 
> ## Output of ifconfig:
> 
> inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
> 
> thanks,  
> Carlo
> 
> > On Fri, Dec 17, 2010 at 10:42 AM, Carlo Baldassi \<  
> > [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)\>  
> > wrote:
> > 
> > > 2010/12/16 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):
> > > 
> > > > Do you have multicast enabled on your network?
> > > 
> > > Er, I'm not 100% sure about that (I'm deeply ignorant of this  
> > > subject), but I think it's enabled, since ifconfig reads:
> > > 
> > > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> > > 
> > > for both eth0 and eth1; of course it is not enabled fot lo:
> > > 
> > > UP LOOPBACK RUNNING MTU:16436 Metric:1
> > > 
> > > so I still don't know what the problem with multicast may be.
> > > 
> > > > You can move to unicast discovery.
> > > 
> > > I tried this by writing this into config/elasticsearch.yml
> > > 
> > > discovery.zen.ping.multicast:  
> > > enabled: false
> > > 
> > > With this, everything seems to work correctly (al least locally).  
> > > Thanks a lot! That probably does it for me.
> > > 
> > > Carlo
> > > 
> > > > On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)  
> > > > wrote:
> > > > 
> > > > > Hi,
> > > > > 
> > > > > I'm new here and I hope I'm in the right place.
> > > > > 
> > > > > I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1,  
> > > > > and  
> > > > > when  
> > > > > I start it up with bin/elasticsearch -f this is what happens:  
> > > > > [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> > > > > Amanda]  
> > > > > {elasticsearch/0.13.1}[12244]: initializing ...  
> > > > > [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> > > > > Amanda]  
> > > > > loaded   
> > > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > > Amanda]  
> > > > > {elasticsearch/0.13.1}[12244]: initialized  
> > > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > > Amanda]  
> > > > > {elasticsearch/0.13.1}[12244]: starting ...  
> > > > > [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> > > > > Amanda]  
> > > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > > > > {inet[/192.168.0.100:9300]}  
> > > > > Exception in thread "elasticsearch[Sefton,  
> > > > > Amanda][tp]-pool-1-thread-1"  
> > > > > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> > > > > ping  
> > > > > request over multicast  
> > > > > at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> 
> > > > > ```
> > > > > at
> > > > > 
> > > > > ```
> 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> 
> > > > > ```
> > > > > at java.lang.Thread.run(Thread.java:636)
> > > > > 
> > > > > ```
> > > > > 
> > > > > Caused by: java.io.IOException: Operation not permitted  
> > > > > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > > > > at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> > > > > at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)
> 
> > > > > ```
> > > > > ... 10 more
> > > > > 
> > > > > ```
> > > > > 
> > > > > [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> > > > > Amanda]  
> > > > > waited for 30s and no initial state was set by the discovery  
> > > > > [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> > > > > Amanda]  
> > > > > elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> > > > > [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> > > > > Amanda]  
> > > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > > > > {inet[/192.168.0.100:9200]}  
> > > > > [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> > > > > Amanda]  
> > > > > {elasticsearch/0.13.1}[12244]: started  
> > > > > As you can see, an exception is raised about ping over multicast.  
> > > > > This also happens with versions 0.13.0 and 0.12.1, and also with the  
> > > > > latest  
> > > > > one compiled from source.
> > > > > 
> > > > > ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> > > > > 
> > > > > View this message in context:
> 
> [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)
> 
> > > > > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![cabal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cabal/32/3292_2.png) [@cabal](https://discuss.elastic.co/u/cabal)
#### Post date: [December 21, 2010, 3:51am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/7 "2010-12-21T03:51:51Z")

</div>

I seem to have been successful by setting network.publish\_host: 127.0.0.1 !!  
At least, startup is smooth and everything seems to work just fine.

When I tried with my public IP instead it failed, like this:

[2010-12-20 19:56:43,476][INFO][transport] [Araña]  
bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
{inet[/xx.yy.zzz.kkk:9300]}  
[2010-12-20 19:56:43,539][ERROR][bootstrap] [Araña]  
{elasticsearch/0.13.1}: Startup Failed ...

- DiscoveryException[Failed to setup multicast socket]  
SocketException[Cannot assign requested address]

thanks  
Carlo

2010/12/20 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):

> It seems like mcast should be enabled for eth0, so thats strange... . You  
> can try and change the network.publish\_host to a different ip and see if it  
> helps?
> 
> On Mon, Dec 20, 2010 at 6:45 PM, Carlo Baldassi [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)  
> wrote:
> 
> > > The address used to send the multicast requests on is the  
> > > publish address that you see in the log (for the transport for example).  
> > > Maybe the one guessed by ES to use is not the correct one?
> > 
> > First off: please note that I'm just experimenting on my laptop, not a  
> > server (yet), so my problems are probably outside the scope of ES and  
> > it would be more than understandable on my part if you'd just ignore  
> > them.
> > 
> > That said, in case you think it's worth trying to solve the issue,  
> > here's the answer to your questions: the address guessed by ES is the  
> > local network's 192.168.0.100, i.e. the same as that provided by  
> > ifconfig for eth0.  
> > I guess that the use of the local network might cause the issue with  
> > multicast (but as I said I'm deeply ignorant of the subject). Perhaps  
> > I should somehow force ES to use the public IP? Or modify my network's  
> > configuration? (I tried opening the relevant ports and modifying my  
> > router's configuration, with no luck.)
> > 
> > ## Log of ElasticSerach:
> > 
> > [2010-12-20 17:25:46,552][INFO][transport]  
> > [Tarantula] bound\_address {inet[/0:0:0:0:0:0:0:0:9300]},  
> > publish\_address {inet[/192.168.0.100:9300]}
> > 
> > ## Output of ifconfig:
> > 
> > inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
> > 
> > thanks,  
> > Carlo
> > 
> > > On Fri, Dec 17, 2010 at 10:42 AM, Carlo Baldassi  
> > > [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)  
> > > wrote:
> > > 
> > > > 2010/12/16 Shay Banon [shay.banon@elasticsearch.com](mailto:shay.banon@elasticsearch.com):
> > > > 
> > > > > Do you have multicast enabled on your network?
> > > > 
> > > > Er, I'm not 100% sure about that (I'm deeply ignorant of this  
> > > > subject), but I think it's enabled, since ifconfig reads:
> > > > 
> > > > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> > > > 
> > > > for both eth0 and eth1; of course it is not enabled fot lo:
> > > > 
> > > > UP LOOPBACK RUNNING MTU:16436 Metric:1
> > > > 
> > > > so I still don't know what the problem with multicast may be.
> > > > 
> > > > > You can move to unicast discovery.
> > > > 
> > > > I tried this by writing this into config/elasticsearch.yml
> > > > 
> > > > discovery.zen.ping.multicast:  
> > > > enabled: false
> > > > 
> > > > With this, everything seems to work correctly (al least locally).  
> > > > Thanks a lot! That probably does it for me.
> > > > 
> > > > Carlo
> > > > 
> > > > > On Thu, Dec 16, 2010 at 1:55 PM, cabal [carlobaldassi@gmail.com](mailto:carlobaldassi@gmail.com)  
> > > > > wrote:
> > > > > 
> > > > > > Hi,
> > > > > > 
> > > > > > I'm new here and I hope I'm in the right place.
> > > > > > 
> > > > > > I'm on Linux, Ubuntu 10.10. I have downloaded elasticsearch 0.13.1,  
> > > > > > and  
> > > > > > when  
> > > > > > I start it up with bin/elasticsearch -f this is what happens:  
> > > > > > [2010-12-16 12:12:42,209][INFO][node] [Sefton,  
> > > > > > Amanda]  
> > > > > > {elasticsearch/0.13.1}[12244]: initializing ...  
> > > > > > [2010-12-16 12:12:42,215][INFO][plugins] [Sefton,  
> > > > > > Amanda]  
> > > > > > loaded   
> > > > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > > > Amanda]  
> > > > > > {elasticsearch/0.13.1}[12244]: initialized  
> > > > > > [2010-12-16 12:12:46,213][INFO][node] [Sefton,  
> > > > > > Amanda]  
> > > > > > {elasticsearch/0.13.1}[12244]: starting ...  
> > > > > > [2010-12-16 12:12:46,396][INFO][transport] [Sefton,  
> > > > > > Amanda]  
> > > > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address  
> > > > > > {inet[/192.168.0.100:9300]}  
> > > > > > Exception in thread "elasticsearch[Sefton,  
> > > > > > Amanda][tp]-pool-1-thread-1"  
> > > > > > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to  
> > > > > > send  
> > > > > > ping  
> > > > > > request over multicast  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:240)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:201)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:129)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:111)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:470)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ZenDiscovery.joinCluster(ZenDiscovery.java:224)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ZenDiscovery.access$400(ZenDiscovery.java:62)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ZenDiscovery$1.run(ZenDiscovery.java:141)  
> > > > > > at
> > > > > > 
> > > > > > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
> > > > > > at
> > > > > > 
> > > > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
> > > > > > at java.lang.Thread.run(Thread.java:636)  
> > > > > > Caused by: java.io.IOException: Operation not permitted  
> > > > > > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > > > > > at java.net.DatagramSocket.send(DatagramSocket.java:629)  
> > > > > > at
> > > > > > 
> > > > > > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:234)  
> > > > > > ... 10 more  
> > > > > > [2010-12-16 12:13:16,434][WARN][discovery] [Sefton,  
> > > > > > Amanda]  
> > > > > > waited for 30s and no initial state was set by the discovery  
> > > > > > [2010-12-16 12:13:16,435][INFO][discovery] [Sefton,  
> > > > > > Amanda]  
> > > > > > elasticsearch/YLDVy\_Z3RJqbanuU5v7Q2g  
> > > > > > [2010-12-16 12:13:16,442][INFO][http] [Sefton,  
> > > > > > Amanda]  
> > > > > > bound\_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish\_address  
> > > > > > {inet[/192.168.0.100:9200]}  
> > > > > > [2010-12-16 12:13:16,443][INFO][node] [Sefton,  
> > > > > > Amanda]  
> > > > > > {elasticsearch/0.13.1}[12244]: started  
> > > > > > As you can see, an exception is raised about ping over multicast.  
> > > > > > This also happens with versions 0.13.0 and 0.12.1, and also with the  
> > > > > > latest  
> > > > > > one compiled from source.
> > > > > > 
> > > > > > ## Of course nothing works then: when I try to XPUT anything, just like shown in the examples, what I get all the time is {"error":"MasterNotDiscoveredException"} I guess this may be a problem of my configuration, but I don't know where to look at exactly, so help would be very much appreciated.
> > > > > > 
> > > > > > View this message in context:
> > > > > > 
> > > > > > [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-tp2097917p2097917.html)  
> > > > > > Sent from the Elasticsearch Users mailing list archive at  
> > > > > > [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 4:15am UTC](https://discuss.elastic.co/t/exception-at-startup-failed-to-send-ping-request-over-multicast/3671/8 "2017-07-06T04:15:05Z")

</div>


