# Exception in pipelineworker, the pipeline stopped processing new events,

**URL:** <https://discuss.elastic.co/t/exception-in-pipelineworker-the-pipeline-stopped-processing-new-events/125543>\
**Category:** Logstash\
**Created:** [March 26, 2018, 5:37am UTC](https://discuss.elastic.co/t/exception-in-pipelineworker-the-pipeline-stopped-processing-new-events/125543 "2018-03-26T05:37:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amit\_Hora](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_hora/32/45312_2.png) [@Amit\_Hora](https://discuss.elastic.co/u/Amit_Hora)\
**Post date:** [March 26, 2018, 5:37am UTC](https://discuss.elastic.co/t/exception-in-pipelineworker-the-pipeline-stopped-processing-new-events/125543/1 "2018-03-26T05:37:32Z")

</div>

Hi,

Logstash stop processing new events after every 2 hours. Log file is filled with ERROR unable to reach host and then pipeline has stopped processing any new events  
`[2018-03-26T00:00:15,491][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch' but Elasticsearch appears to be unreachable or down! {:error_message=>"Elasticsearch Unreachable: [https://kkr:xxxxxx@esxxxnet:9200/][Manticore::SocketTimeout] Read timed out", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError", :will_retry_in_seconds=>2} [2018-03-26T00:11:11,249][ERROR][logstash.pipeline] Exception in pipelineworker, the pipeline stopped processing new events, please check your filter configuration and restart Logstash. {"exception"=>"", "backtrace"=>[]}`

Everything starts working , if i restart the logstash.  
I can see other logstash instances also filled with logs `host unreachable` but they keep retrying. It is only on one particular instance where i see logs  
`Pipeline has stooped processing new events , check filter configuration`  
Any pointers to solve the problem ?

Regards,  
Amit

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 23, 2018, 5:38am UTC](https://discuss.elastic.co/t/exception-in-pipelineworker-the-pipeline-stopped-processing-new-events/125543/2 "2018-04-23T05:38:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
