# Exception installing shield 2.4.0

**URL:** <https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [January 25, 2017, 3:59pm UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790 "2017-01-25T15:59:14Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![sss](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sss/32/31486_2.png) [@sss](https://discuss.elastic.co/u/sss)\
**Post date:** [January 25, 2017, 3:59pm UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/1 "2017-01-25T15:59:14Z")

</div>

Hi, i get this error while installing shield 2.4.0

Caused by: org.elasticsearch.common.inject.CreationException: Guice creation errors:

1. No implementation for org.elasticsearch.license.plugin.core.LicenseeRegistry was bound.  
while locating org.elasticsearch.license.plugin.core.LicenseeRegistry  
for parameter 1 at org.elasticsearch.shield.license.ShieldLicensee.(Unknown Source)  
at _unknown_

1 error  
at org.elasticsearch.common.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:360)  
at org.elasticsearch.common.inject.InjectorBuilder.initializeStatically(InjectorBuilder.java:151)  
at org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:102)  
at org.elasticsearch.common.inject.Guice.createInjector(Guice.java:93)  
at org.elasticsearch.common.inject.Guice.createInjector(Guice.java:70)  
at org.elasticsearch.common.inject.ModulesBuilder.createInjector(ModulesBuilder.java:46)  
at org.elasticsearch.node.Node.(Node.java:213)

I have installed license-2.4.0.zip and shield 2.4.0.zip and i have Elastic Search version 2.4.0.

Any help is appreciated

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [January 27, 2017, 2:22am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/2 "2017-01-27T02:22:11Z")

</div>

It's not immediately obvious what has gone wrong with your install.

It looks like the best course of action would be to start the install again from the beginning.

Try and record (copy-n-paste from your terminal) the steps that you take, so that if this problem reoccurs we have a bit more to go on to try and work out what caused it.

---

<div class="post-metadata">

**Author:** ![sss](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sss/32/31486_2.png) [@sss](https://discuss.elastic.co/u/sss)\
**Post date:** [January 28, 2017, 7:32am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/3 "2017-01-28T07:32:42Z")

</div>

hello tim,

I tried the steps again which i am describing below. WE have an application where in we embed the elastic search into our application which means es is not installed as a service, rather a service integrated into our application

i have added all the jars Shield, automaton and unbound jars that comes with Shield 2.4.0 and also the licensing related jars (license,license-core and license plugin-api) into the classpath of our application. Looking at the exception, and the decompiled code,the below snippet from the LicenseModule class should be related to the exception, i see licenseeRegistry is bounded to licenseService when it is not a tribe node. I am quite sure that i havent started my node as a tribe node.

![](https://us1.discourse-cdn.com/elastic/original/2X/2/22e9a1921c7a475396cf2da565c82353cd544175.PNG)

What else could be the problems ? why licenseeRegistry could not find any bindings. In the worst case(i.e.. when node is a tribe node, licenseeRegistry has a no-opbinding defined )

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 28, 2017, 9:14am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/4 "2017-01-28T09:14:39Z")

</div>

Shield requires Elasticsearch to be running as a standalone server and does not support embedded mode.

---

<div class="post-metadata">

**Author:** ![sss](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sss/32/31486_2.png) [@sss](https://discuss.elastic.co/u/sss)\
**Post date:** [January 28, 2017, 10:45am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/5 "2017-01-28T10:45:35Z")

</div>

HI Christian,

Thanks for the response,

Any specific reason for Shield not supporting ES in embedded mode ? Is that because of the licensing jars or other technical difficulties ? I am curious to find out, because i could get SearchGuard/SSL working with ES installed in embedded mode.

Thanks,

---

<div class="post-metadata">

**Author:** ![jaymode](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jaymode/32/50103_2.png) [@jaymode](https://discuss.elastic.co/u/jaymode)\
**Post date:** [January 30, 2017, 11:52am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/6 "2017-01-30T11:52:02Z")

</div>

Please see this blog post for all of the details of why we cannot support the embedding of elasticsearch and shield. [https://www.elastic.co/blog/elasticsearch-the-server](https://www.elastic.co/blog/elasticsearch-the-server)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 27, 2017, 11:52am UTC](https://discuss.elastic.co/t/exception-installing-shield-2-4-0/72790/7 "2017-02-27T11:52:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
