# Exception when a new record comes to elastic search from logstash

**URL:** https://discuss.elastic.co/t/exception-when-a-new-record-comes-to-elastic-search-from-logstash/55591
**Category:** Elasticsearch
**Created:** [July 15, 2016, 6:48am UTC](https://discuss.elastic.co/t/exception-when-a-new-record-comes-to-elastic-search-from-logstash/55591 "2016-07-15T06:48:48Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![chinmoyd](https://avatars.discourse-cdn.com/v4/letter/c/e495f1/32.png) [@chinmoyd](https://discuss.elastic.co/u/chinmoyd)
#### Post date: [July 15, 2016, 6:48am UTC](https://discuss.elastic.co/t/exception-when-a-new-record-comes-to-elastic-search-from-logstash/55591/1 "2016-07-15T06:48:48Z")

</div>

Can you please tell me how to fix the following? This is happening in our production box.

[2016-07-15 11:59:09,718][WARN][cluster.action.shard] [dr\_app2] [logstasht2-2016.07.05][4] received shard failed for [logstasht2-2016.07.05][4], node[S-QmrBj\_QB6NIBAAfVD1iw], [P], v[12474], s[INITIALIZING], a[id=h2iASeaZSreJ37zThcS01Q], unassigned\_info[[reason=ALLOCATION\_FAILED], at[2016-07-15T06:29:09.699Z], details[failed recovery, failure IndexShardRecoveryException[failed to recovery from gateway]; nested: EngineCreationFailureException[failed to create engine]; nested: NoSuchFileException[/home/user1/Desktop/UPI/elasticsearch-2.2.0/data/dr\_site/nodes/0/indices/logstasht2-2016.07.05/4/translog/translog-93.ckp]; ]], indexUUID [GNuXYw2ZTBOO5TUtUpZT-w], message [failed recovery], failure [IndexShardRecoveryException[failed to recovery from gateway]; nested: EngineCreationFailureException[failed to create engine]; nested: NoSuchFileException[/home/user1/Desktop/UPI/elasticsearch-2.2.0/data/dr\_site/nodes/0/indices/logstasht2-2016.07.05/4/translog/translog-93.ckp]; ]  
[logstasht2-2016.07.05][[logstasht2-2016.07.05][4]] IndexShardRecoveryException[failed to recovery from gateway]; nested: EngineCreationFailureException[failed to create engine]; nested: NoSuchFileException[/home/user1/Desktop/UPI/elasticsearch-2.2.0/data/dr\_site/nodes/0/indices/logstasht2-2016.07.05/4/translog/translog-93.ckp];  
at org.elasticsearch.index.shard.StoreRecoveryService.recoverFromStore(StoreRecoveryService.java:254)  
at org.elasticsearch.index.shard.StoreRecoveryService.access$100(StoreRecoveryService.java:56)  
at org.elasticsearch.index.shard.StoreRecoveryService$1.run(StoreRecoveryService.java:129)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: [logstasht2-2016.07.05][[logstasht2-2016.07.05][4]] EngineCreationFailureException[failed to create engine]; nested: NoSuchFileException[/home/user1/Desktop/UPI/elasticsearch-2.2.0/data/dr\_site/nodes/0/indices/logstasht2-2016.07.05/4/translog/translog-93.ckp];  
at org.elasticsearch.index.engine.InternalEngine.(InternalEngine.java:156)  
at org.elasticsearch.index.engine.InternalEngineFactory.newReadWriteEngine(InternalEngineFactory.java:25)  
at org.elasticsearch.index.shard.IndexShard.newEngine(IndexShard.java:1450)  
at org.elasticsearch.index.shard.IndexShard.createNewEngine(IndexShard.java:1434)  
at org.elasticsearch.index.shard.IndexShard.internalPerformTranslogRecovery(IndexShard.java:925)  
at org.elasticsearch.index.shard.IndexShard.performTranslogRecovery(IndexShard.java:897)  
at org.elasticsearch.index.shard.StoreRecoveryService.recoverFromStore(StoreRecoveryService.java:245)

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 17, 2016, 6:32am UTC](https://discuss.elastic.co/t/exception-when-a-new-record-comes-to-elastic-search-from-logstash/55591/2 "2016-07-17T06:32:47Z")

</div>

Does this file exist - `/home/user1/Desktop/UPI/elasticsearch-2.2.0/data/dr_site/nodes/0/indices/logstasht2-2016.07.05/4/translog/translog-93.ckp`? If no what is under that translog dir?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:35pm UTC](https://discuss.elastic.co/t/exception-when-a-new-record-comes-to-elastic-search-from-logstash/55591/3 "2017-07-05T22:35:00Z")

</div>


