# Exclude log lines with nginx filebeat module

**URL:** https://discuss.elastic.co/t/exclude-log-lines-with-nginx-filebeat-module/222019
**Category:** Beats
**Tags:** filebeat
**Created:** [March 4, 2020, 8:59am UTC](https://discuss.elastic.co/t/exclude-log-lines-with-nginx-filebeat-module/222019 "2020-03-04T08:59:02Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![thomas\_vega](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thomas_vega/32/63773_2.png) [@thomas\_vega](https://discuss.elastic.co/u/thomas_vega)
#### Post date: [March 4, 2020, 8:59am UTC](https://discuss.elastic.co/t/exclude-log-lines-with-nginx-filebeat-module/222019/1 "2020-03-04T08:59:03Z")

</div>

I am using the filebeat nginx module and want to exclude certain lines. Therefore I want to add a `drop_event` processor to the module configuration. This fails with following error message:

```
filebeat.modules:
- module: nginx
  access:
    enabled: true
    var.paths:
    - "/var/log/nginx/*.access.log*"
    input:
      processors:
      - drop_event:
          when.regexp.message: "/status"
  error:
    enabled: true
    var.paths:
    - "/var/log/nginx/*.error.log*"

```

Here is the relevant section of my `filebeat.yml` configuration:

```
Exiting: Error while initializing input: each processor must have exactly one action, but found 2 actions (drop_event,add_locale)

```

Reading through the source of the filebeat module, it seems the add\_locale event is added by the module. Any way to resolve this, or should I add the processor on a higher level?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 1, 2020, 9:13am UTC](https://discuss.elastic.co/t/exclude-log-lines-with-nginx-filebeat-module/222019/2 "2020-04-01T09:13:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
