# Existing Scripts breaking after updating to Elastic Search 7.4 from 6.3

**URL:** <https://discuss.elastic.co/t/existing-scripts-breaking-after-updating-to-elastic-search-7-4-from-6-3/212242>\
**Category:** Elasticsearch\
**Tags:** painless\
**Created:** [December 18, 2019, 12:37am UTC](https://discuss.elastic.co/t/existing-scripts-breaking-after-updating-to-elastic-search-7-4-from-6-3/212242 "2019-12-18T00:37:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vkandiva](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vkandiva/32/42845_2.png) [@vkandiva](https://discuss.elastic.co/u/vkandiva)\
**Post date:** [December 18, 2019, 12:37am UTC](https://discuss.elastic.co/t/existing-scripts-breaking-after-updating-to-elastic-search-7-4-from-6-3/212242/1 "2019-12-18T00:37:57Z")

</div>

So after the upgrade most of our scripts are breaking and giving an error "A document doesn't have a value for a field! Use doc[].size()==0 to check if a document is missing a field!"

Is there an option for this error to be ignored? We have a lot of different scripts being used and would like this validation to be turned off.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 15, 2020, 12:38am UTC](https://discuss.elastic.co/t/existing-scripts-breaking-after-updating-to-elastic-search-7-4-from-6-3/212242/2 "2020-01-15T00:38:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
