# Exiting: error loading template: failed to load template: couldn't load template: 400 Bad Request:

**URL:** https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423
**Category:** Beats
**Tags:** filebeat, winlogbeat
**Created:** [December 20, 2021, 4:10am UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423 "2021-12-20T04:10:29Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![mshah](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mshah](https://discuss.elastic.co/u/mshah)
#### Post date: [December 20, 2021, 4:10am UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423/1 "2021-12-20T04:10:29Z")

</div>

Hi All,

I am new to Elastic stack and trying out a PoC to get approval but i am unable to get winlogBeat or File beat working. Tried multiple time and looked around online but not sure where i am missing.

I get below error when i tried to use winlogbeat. I have used unattended installation script to install Elasticsearch stack on a Ubuntu 20.04.

```auto
C:\winlogbeat\ .\winlogbeat.exe setup
>> Start-Service winlogbeattype 

Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Exiting: error loading template: failed to load template: couldn't load template: 400 Bad Request: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"composable template [winlogbeat-7.16.2] template after composition is invalid"}],"type":"illegal_argument_exception","reason":"composable template [winlogbeat-7.16.2] template after composition is invalid","caused_by":{"type":"illegal_argument_exception","reason":"invalid composite mappings for [winlogbeat-7.16.2]","caused_by":{"type":"mapper_parsing_exception","reason":"Failed to parse mapping [_doc]: No handler for type [flattened] declared on field [imports]","caused_by":{"type":"mapper_parsing_exception","reason":"No handler for type [flattened] declared on field [imports]"}}}},"status":400}. Response body: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"composable template [winlogbeat-7.16.2] template after composition is invalid"}],"type":"illegal_argument_exception","reason":"composable template [winlogbeat-7.16.2] template after composition is invalid","caused_by":{"type":"illegal_argument_exception","reason":"invalid composite mappings for [winlogbeat-7.16.2]","caused_by":{"type":"mapper_parsing_exception","reason":"Failed to parse mapping [_doc]: No handler for type [flattened] declared on field [imports]","caused_by":{"type":"mapper_parsing_exception","reason":"No handler for type [flattened] declared on field [imports]"}}}},"status":400}
PS C:\Program Files\Winlogbeat>

```

Both Elasticsearch & Kibana are installed on same host using un-attended script provided.

My "winlogbeat.yml" is as below,

```auto

winlogbeat.event_logs:
  - name: Application
    ignore_older: 72h

  - name: System

  - name: Security
    processors:
      - script:
          lang: javascript
          id: security
          file: ${path.home}/module/security/config/winlogbeat-security.js

  - name: Microsoft-Windows-Sysmon/Operational
    processors:
      - script:
          lang: javascript
          id: sysmon
          file: ${path.home}/module/sysmon/config/winlogbeat-sysmon.js

  - name: Windows PowerShell
    event_id: 400, 403, 600, 800
    processors:
      - script:
          lang: javascript
          id: powershell
          file: ${path.home}/module/powershell/config/winlogbeat-powershell.js

  - name: Microsoft-Windows-PowerShell/Operational
    event_id: 4103, 4104, 4105, 4106
    processors:
      - script:
          lang: javascript
          id: powershell
          file: ${path.home}/module/powershell/config/winlogbeat-powershell.js

  - name: ForwardedEvents
    tags: [forwarded]
    processors:
      - script:
          when.equals.winlog.channel: Security
          lang: javascript
          id: security
          file: ${path.home}/module/security/config/winlogbeat-security.js
      - script:
          when.equals.winlog.channel: Microsoft-Windows-Sysmon/Operational
          lang: javascript
          id: sysmon
          file: ${path.home}/module/sysmon/config/winlogbeat-sysmon.js
      - script:
          when.equals.winlog.channel: Windows PowerShell
          lang: javascript
          id: powershell
          file: ${path.home}/module/powershell/config/winlogbeat-powershell.js
      - script:
          when.equals.winlog.channel: Microsoft-Windows-PowerShell/Operational
          lang: javascript
          id: powershell
          file: ${path.home}/module/powershell/config/winlogbeat-powershell.js

# ====================== Elasticsearch template settings =======================

setup.template.settings:
  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.

#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
#setup.kibana:
# host: "https://IPAddress:5601"

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  #host: "localhost:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:

# =============================== Elastic Cloud ================================

# These settings simplify using Winlogbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["https://ipaddress:9200"]

  # Protocol - either `http` (default) or `https`.
  #protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
  username: "xxxx"
  password: "xxxxxxxxxx"
  ssl.verification_mode: none
  
setup.kibana:
   host: "https://ipaddress:9200"
   ssl.verification_mode: none
# ------------------------------ Logstash Output -------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================
processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publisher", "service".
#logging.selectors: ["*"]

# ============================= X-Pack Monitoring ==============================
# Winlogbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Winlogbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

# ============================== Instrumentation ===============================

# Instrumentation support for the winlogbeat.
#instrumentation:
    # Set to true to enable instrumentation of winlogbeat.
    #enabled: false

    # Environment in which winlogbeat is running on (eg: staging, production, etc.)
    #environment: ""

    # APM Server hosts to report instrumentation results to.
    #hosts:
    # - http://localhost:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.
    #api_key:

    # Secret token for the APM Server(s).
    #secret_token:

# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true

```

You help will greatly appreciated.

Thanks

Shah

---

<div class="post-metadata">

### Author: ![mtojek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mtojek/32/63863_2.png) [@mtojek](https://discuss.elastic.co/u/mtojek)
#### Post date: [December 20, 2021, 2:04pm UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423/2 "2021-12-20T14:04:06Z")

</div>

Hi,

Could you please format the post using `code tags`. It will be easier to read. Thanks!

---

<div class="post-metadata">

### Author: ![mshah](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mshah](https://discuss.elastic.co/u/mshah)
#### Post date: [December 20, 2021, 10:00pm UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423/3 "2021-12-20T22:00:07Z")

</div>

Hi mtojek,

Sorry, My bad was not aware of this. now i have update the post.

Thank you.

---

<div class="post-metadata">

### Author: ![mshah](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@mshah](https://discuss.elastic.co/u/mshah)
#### Post date: [January 4, 2022, 12:34am UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423/4 "2022-01-04T00:34:10Z")

</div>

Anyone can help me with this?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 1, 2022, 2:34am UTC](https://discuss.elastic.co/t/exiting-error-loading-template-failed-to-load-template-couldnt-load-template-400-bad-request/292423/5 "2022-02-01T02:34:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
