# Facing connection refused issue while starting metricbeat

**URL:** <https://discuss.elastic.co/t/facing-connection-refused-issue-while-starting-metricbeat/186716>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [June 20, 2019, 2:52pm UTC](https://discuss.elastic.co/t/facing-connection-refused-issue-while-starting-metricbeat/186716 "2019-06-20T14:52:37Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![krish2](https://avatars.discourse-cdn.com/v4/letter/k/b5a626/32.png) [@krish2](https://discuss.elastic.co/u/krish2)\
**Post date:** [June 20, 2019, 2:52pm UTC](https://discuss.elastic.co/t/facing-connection-refused-issue-while-starting-metricbeat/186716/1 "2019-06-20T14:52:38Z")

</div>

**Hi ,**

**I have installed elk stack on some server A with IP: x.x.x.x.**  
**I have installed metricbeat on another server B with IP: y.y.y.y**

**I have configured metricbeat.yml as below**

####### Metricbeat Configuration Example

# This file is an example configuration file highlighting only the most common

# options. The metricbeat.reference.yml file from the same directory contains all the

# supported options with more comments. You can use it as a reference.

# 

# You can find the full configuration reference here:

# [https://www.elastic.co/guide/en/beats/metricbeat/index.html](https://www.elastic.co/guide/en/beats/metricbeat/index.html)

=========== Modules configuration ==========  
metricbeat.config.modules:

# Glob pattern for configuration loading

path: ${path.config}/modules.d/\*.yml

# Set to true to enable config reloading

reload.enabled: false

# Period on which files under path should be checked for changes

#reload.period: 10s  
========== Elasticsearch template setting =========

setup.template.settings:  
index.number\_of\_shards: 1  
index.codec: best\_compression  
#\_source.enabled: false

====================== General ========

# The name of the shipper that publishes the network data. It can be used to group

# all the transactions sent by a single shipper in the web interface.

#name:

# The tags of the shipper are included in their own field with each

# transaction published.

#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the

# output.

#fields:

# env: staging

======================= Dashboards ============

# These settings control loading the sample dashboards to the Kibana index. Loading

# the dashboards is disabled by default and can be enabled either by setting the

# options here, or by using the `-setup` CLI flag or the `setup` command.

#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL

# has a value which is computed based on the Beat name and version. For released

# versions, this URL points to the dashboard archive on the [artifacts.elastic.co](http://artifacts.elastic.co)

# website.

#setup.dashboards.url:

============ Kibana ============

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

# This requires a Kibana endpoint configuration.

setup.kibana:  
host: "x.x.x.x:5601"

# Kibana Host

# Scheme and port can be left out and will be set to the default (http and 5601)

# In case you specify and additional path, the scheme is required: [http://localhost:5601/path](http://localhost:5601/path)

# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

#host: ["ip-10-228-3-241.ec2.internal:5601"]

# Kibana Space ID

# ID of the Kibana Space into which the dashboards should be loaded. By default,

# the Default Space will be used.

#space.id:

============== Elastic Cloud ============

# These settings simplify using metricbeat with the Elastic Cloud ([https://cloud.elastic.co/](https://cloud.elastic.co/)).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and

# `setup.kibana.host` options.

# You can find the `cloud.id` in the Elastic Cloud web UI.

#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and

# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------  
#output.elasticsearch:

# Array of hosts to connect to.

#hosts: "x.x.x.x:9300"

# Enabled ilm (beta) to use index lifecycle management instead daily indices.

#ilm.enabled: false

# Optional protocol and basic auth credentials.

#protocol: "https"  
#username: "elastic"  
#password: "changeme"

#----------------------------- Logstash output --------------------------------  
output.logstash:

# The Logstash hosts

hosts: "x.x.x.x:5044"

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:

- add\_host\_metadata: ~
- add\_cloud\_metadata: ~

================= Logging ==============

# Sets log level. The default log level is info.

# Available log levels are: error, warning, info, debug

#logging.level: debug

# At debug level, you can selectively enable logging only for some components.

# To enable all selectors use ["\*"]. Examples of other selectors are "beat",

# "publish", "service".

#logging.selectors: ["\*"]

#============================== Xpack Monitoring ===============================

# metricbeat can export internal metrics to a central Elasticsearch monitoring

# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The

# reporting is disabled by default.

# Set to true to enable the monitoring reporter.

#xpack.monitoring.enabled: false

# Uncomment to send the metrics to Elasticsearch. Most settings from the

# Elasticsearch output are accepted here as well. Any setting that is not set is

# automatically inherited from the Elasticsearch output configuration, so if you

# have the Elasticsearch output configured, you can simply uncomment the

# following line.

#xpack.monitoring.elasticsearch:

**while I start the metricbeats service I got the below log.**

2019-06-20T10:44:20.932-0400 ERROR pipeline/output.go:100 Failed to connect to backoff(async(tcp://x.x.x.x:5044)): dial tcp x.x.x.x:5044: i/o timeout  
2019-06-20T10:44:20.932-0400 INFO pipeline/output.go:93 Attempting to reconnect to backoff(async(tcp://10.228.3.241:5044)) with 13 reconnect attempt(s)  
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:189 retryer: send unwait-signal to consumer  
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:191 done  
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:166 retryer: send wait signal to consumer  
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:168 done  
2019-06-20T10:44:29.747-0400 ERROR [kibana] elastic/elastic.go:107 error making http request: Get [http://localhost:5601/api/status:](http://localhost:5601/api/status:) dial tcp 127.0.0.1:5601: connect: connection refused  
2019-06-20T10:44:39.747-0400 ERROR [kibana] elastic/elastic.go:107 error making http request: Get [http://localhost:5601/api/status:](http://localhost:5601/api/status:) dial tcp 127.0.0.1:5601: connect: connection refused  
Please help me how to solve this issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 18, 2019, 2:52pm UTC](https://discuss.elastic.co/t/facing-connection-refused-issue-while-starting-metricbeat/186716/2 "2019-07-18T14:52:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
