# Facing issue in logstash after applying basic authentication on ES

**URL:** <https://discuss.elastic.co/t/facing-issue-in-logstash-after-applying-basic-authentication-on-es/299308>\
**Category:** Logstash\
**Tags:** elastic-stack-monitoring\
**Created:** [March 10, 2022, 9:01am UTC](https://discuss.elastic.co/t/facing-issue-in-logstash-after-applying-basic-authentication-on-es/299308 "2022-03-10T09:01:39Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sandeep\_Thakur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sandeep_thakur/32/95737_2.png) [@Sandeep\_Thakur](https://discuss.elastic.co/u/Sandeep_Thakur)\
**Post date:** [March 10, 2022, 9:01am UTC](https://discuss.elastic.co/t/facing-issue-in-logstash-after-applying-basic-authentication-on-es/299308/1 "2022-03-10T09:01:39Z")

</div>

Hi Team,  
We are trying to applying basic authentication on ELk stack, when we enable security true in Elasticsearch.yml then logstash stopping pushing log on ES and give following error

```auto
[2022-03-10T08:39:43,365][WARN][logstash.javapipeline][.monitoring-logstash] 'pipeline.ordered' is enabled and is likely less efficient, consider disabling if preserving event order is not necessary
[2022-03-10T08:39:43,764][INFO][logstash.javapipeline][.monitoring-logstash] Starting pipeline {:pipeline_id=>".monitoring-logstash", "pipeline.workers"=>1, "pipeline.batch.size"=>2, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>2, "pipeline.sources"=>["monitoring pipeline"], :thread=>"#<Thread:0x356dc2cb run>"}
[2022-03-10T08:39:48,040][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://elastic:xxxxxx@SERVERIP:9200/]}}
[2022-03-10T08:39:48,138][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline started {"pipeline.id"=>".monitoring-logstash"}
[2022-03-10T08:39:48,139][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=>"http://elastic:xxxxxx@SERVERIP:9200/"}
[2022-03-10T08:39:48,249][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2022-03-10T08:39:48,613][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2022-03-10T08:39:16,101][INFO][logstash.javapipeline] Pipeline terminated {"pipeline.id"=>".monitoring-logstash"}
[2022-03-10T08:39:16,165][INFO][logstash.runner] Logstash shut down.

```

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 10, 2022, 3:51pm UTC](https://discuss.elastic.co/t/facing-issue-in-logstash-after-applying-basic-authentication-on-es/299308/2 "2022-03-10T15:51:35Z")

</div>

If you enabled `--log.level debug` do you get a more informative error message?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 7, 2022, 3:52pm UTC](https://discuss.elastic.co/t/facing-issue-in-logstash-after-applying-basic-authentication-on-es/299308/3 "2022-04-07T15:52:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
