# Faield to start elastic search

**URL:** <https://discuss.elastic.co/t/faield-to-start-elastic-search/302608>\
**Category:** Elasticsearch\
**Created:** [April 18, 2022, 10:05am UTC](https://discuss.elastic.co/t/faield-to-start-elastic-search/302608 "2022-04-18T10:05:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Paritosh\_Pandey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/paritosh_pandey/32/104479_2.png) [@Paritosh\_Pandey](https://discuss.elastic.co/u/Paritosh_Pandey)\
**Post date:** [April 18, 2022, 10:05am UTC](https://discuss.elastic.co/t/faield-to-start-elastic-search/302608/1 "2022-04-18T10:05:05Z")

</div>

I am unable to start Elasticsearch, it shows code exited  
\</\>  
Elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/Elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2022-04-18 05:17:42 EDT; 59s ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 21013 ExecStart=/usr/share/Elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/Elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 21013 (code=exited, status=1/FAILURE)

Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:157)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:81)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.cli.Command.main(Command.java:77)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:122)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: at org.Elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80)  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd-entrypoint[21013]: For complete error details, refer to the log at /usr/share/Elasticsearch/logs/Elasticsearch.log  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd[1]: Elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd[1]: Elasticsearch.service: Failed with result 'exit-code'.  
Apr 18 05:17:42 [kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com](http://kd-4c4c4544-004d-4c10-8030-c8c04f324633.ibm.com) systemd[1]: Failed to start Elasticsearch.\<\>

I tried to look into the logs as suggested but logs folder is not there

---

<div class="post-metadata">

**Author:** ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)\
**Post date:** [April 18, 2022, 1:41pm UTC](https://discuss.elastic.co/t/faield-to-start-elastic-search/302608/2 "2022-04-18T13:41:32Z")

</div>

HI @Paritosh_Pandey

What operating system are you using? Was Elasticsearch installed via package management? is it a container? Was the service already installed before or are you doing a fresh install?

Best regards

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [April 18, 2022, 4:37pm UTC](https://discuss.elastic.co/t/faield-to-start-elastic-search/302608/3 "2022-04-18T16:37:24Z")

</div>

Hi @Paritosh_Pandey Welcome to the community

Per the docs [here](https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html#deb-running-systemd) To look at the logs try

`sudo journalctl -f --unit elasticsearch`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 16, 2022, 4:38pm UTC](https://discuss.elastic.co/t/faield-to-start-elastic-search/302608/4 "2022-05-16T16:38:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
