# Fail for update certificate elastic cloud enterprise

**URL:** <https://discuss.elastic.co/t/fail-for-update-certificate-elastic-cloud-enterprise/253607>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [October 28, 2020, 6:33pm UTC](https://discuss.elastic.co/t/fail-for-update-certificate-elastic-cloud-enterprise/253607 "2020-10-28T18:33:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)\
**Post date:** [October 28, 2020, 6:33pm UTC](https://discuss.elastic.co/t/fail-for-update-certificate-elastic-cloud-enterprise/253607/1 "2020-10-28T18:33:29Z")

</div>

Hi everyone,

I'm new with Elastic Cloud Enterprise and installation worked fine but when tested in my web browser, say that certificate not trusted.

 ![ece_certificate](https://us1.discourse-cdn.com/elastic/original/3X/8/8/88414c2ad4f5924120326d62c5123837a6c7a0d9.jpeg)

So i tryed [updated certificate](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-manage-certificates.html) generated with the "certbot" the ECE not work well, show the error message like this:

`Certificate chain was invalid [Invalid Entry: expected unencrypted rsa private key]`

 ![fail](https://us1.discourse-cdn.com/elastic/original/3X/a/5/a532dbcd7b8be0e312ec3cbb8d08235b31840e1e.png)

Containing the certificate file in PEM format structured like this:

> -----BEGIN RSA PRIVATE KEY-----  
> (Mykey.key)  
> -----END RSA PRIVATE KEY-----  
> -----BEGIN CERTIFICATE-----  
> (Mycertificate.crt)  
> -----END CERTIFICATE-----  
> -----BEGIN CERTIFICATE-----  
> (CA\_bundle.crt)  
> -----END CERTIFICATE-----

Also tried order inverted and command line way and showed the same error message. Someone have similar problem? how fix it?

best regards

---

<div class="post-metadata">

**Author:** ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)\
**Post date:** [November 10, 2020, 1:45pm UTC](https://discuss.elastic.co/t/fail-for-update-certificate-elastic-cloud-enterprise/253607/2 "2020-11-10T13:45:26Z")

</div>

Apparently the problem was with the root certificate. After updating and concatenating with the other certificates and keys, it worked correctly.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 24, 2020, 1:45pm UTC](https://discuss.elastic.co/t/fail-for-update-certificate-elastic-cloud-enterprise/253607/3 "2020-11-24T13:45:29Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
