# Fail load dashboard to kibana with apm-server setup

**URL:** <https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172>\
**Category:** APM\
**Created:** [October 17, 2017, 5:18am UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172 "2017-10-17T05:18:43Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [October 17, 2017, 5:18am UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/1 "2017-10-17T05:18:43Z")

</div>

1:  
Loaded index template  
`Exiting: Error importing Kibana dashboards: fail to import the dashboards in Elasticsearch: Error importing directory /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86_64/kibana: No dashboards to import. Please make sure the /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86_64/kibana/5.x directory contains a dashboard directory.`

2: i copy default directory/dashboard to 5.x/dashboard the other error is out put

[root@soc apm-server-6.0.0-rc1-linux-x86\_64]# ./apm-server setup  
Loaded index template  
Exiting: Error importing Kibana dashboards: fail to import the dashboards in Elasticsearch: Error importing directory /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86\_64/kibana: Failed to import dashboard: Failed to load directory /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86\_64/kibana/5.x/dashboard:  
error loading /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86\_64/kibana/5.x/dashboard/apm-dashboards.json: Failed to load /opt/elasticsearch-apm/apm-server-6.0.0-rc1-linux-x86\_64/kibana/5.x/dashboard/apm-dashboards.json under /.kibana/dashboard/apm-dashboards: couldn't load json. Error: 400 Bad Request: {"error":{"root\_cause":[{"type":"mapper\_parsing\_exception","reason":"failed to parse [version]"}],"type":"mapper\_parsing\_exception","reason":"failed to parse [version]","caused\_by":{"type":"number\_format\_exception","reason":"multiple points"}},"status":400}. Response body: {"error":{"root\_cause":[{"type":"mapper\_parsing\_exception","reason":"failed to parse [version]"}],"type":"mapper\_parsing\_exception","reason":"failed to parse [version]","caused\_by":{"type":"number\_format\_exception","reason":"multiple points"}},"status":400}

---

<div class="post-metadata">

**Author:** ![elast](https://avatars.discourse-cdn.com/v4/letter/e/b19c9b/32.png) [@elast](https://discuss.elastic.co/u/elast)\
**Post date:** [October 17, 2017, 10:39am UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/2 "2017-10-17T10:39:33Z")

</div>

jep, same with the debian package

---

<div class="post-metadata">

**Author:** ![roncohen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roncohen/32/22881_2.png) [@roncohen](https://discuss.elastic.co/u/roncohen)\
**Post date:** [October 23, 2017, 12:59pm UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/3 "2017-10-23T12:59:22Z")

</div>

Hi!

Sorry about that. Our documentation is a bit ahead of the latest release. That should be fixed shortly.  
In the mean time, to get dashboard setup with the APM Server alpha1, run the following command from the directory of a local checkout of the APM Server git repository:

`curl -XPOST http://localhost:5601/api/kibana/dashboards/import -H 'Content-type:application/json' -H 'kbn-xsrf:true' -d @./_meta/kibana/default/dashboard/apm-dashboards.json`

If you're on 5.6, you need to do this instead:

`curl -XPOST http://localhost:5601/api/kibana/dashboards/import -H 'Content-type:application/json' -H 'kbn-xsrf:true' -d @./_meta/kibana/5.x/dashboard/apm-dashboards.json`

Let me know if that helps!

---

<div class="post-metadata">

**Author:** ![wldev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wldev/32/44080_2.png) [@wldev](https://discuss.elastic.co/u/wldev)\
**Post date:** [October 25, 2017, 6:01pm UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/4 "2017-10-25T18:01:25Z")

</div>

Nice. Thanks for this

---

<div class="post-metadata">

**Author:** ![roncohen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roncohen/32/22881_2.png) [@roncohen](https://discuss.elastic.co/u/roncohen)\
**Post date:** [October 25, 2017, 6:26pm UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/5 "2017-10-25T18:26:56Z")

</div>

We updated the docs to be correct again. This should be the right approach: [https://www.elastic.co/guide/en/apm/get-started/current/install-and-run.html#kibana-dashboards](https://www.elastic.co/guide/en/apm/get-started/current/install-and-run.html#kibana-dashboards)

---

<div class="post-metadata">

**Author:** ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Post date:** [October 26, 2017, 4:58am UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/6 "2017-10-26T04:58:47Z")

</div>

i will try again.  
thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 16, 2017, 12:59am UTC](https://discuss.elastic.co/t/fail-load-dashboard-to-kibana-with-apm-server-setup/104172/7 "2017-11-16T00:59:21Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
