# Fail to Run Elasticsearch after X-Pack Plugin

**URL:** https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048
**Category:** Elasticsearch
**Created:** [December 11, 2017, 9:26am UTC](https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048 "2017-12-11T09:26:44Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![jpk](https://avatars.discourse-cdn.com/v4/letter/j/71e660/32.png) [@jpk](https://discuss.elastic.co/u/jpk)
#### Post date: [December 11, 2017, 9:26am UTC](https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048/1 "2017-12-11T09:26:44Z")

</div>

The following error occurred after installing X-Pack as a plugin to Elasticsearch on Windows Server 2012 VM:

[2017-12-11T00:34:15,318][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpac  
k.XPackPlugin]]; nested: InvocationTargetException; nested: IllegalArgumentException[none of the ciphers [TLS\_ECDHE\_RSA\_  
WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA, TLS\_ECDHE\_RSA\_WI  
TH\_AES\_128\_CBC\_SHA, TLS\_RSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_RSA\_WITH\_AES\_128\_CBC\_SHA] are supported by this JVM];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.5.0.  
jar:5.5.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.5.0.jar:5.5.0]  
Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:434) ~[elasticsearch-5.5.0.jar:5.5.0]

```
    at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:387) ~[elasticsearch-5.5.0.jar:5.5.0

```

]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:140) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:312) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:244) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.0.jar:5.5.0]  
... 6 more  
Caused by: java.lang.reflect.InvocationTargetException  
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:88) ~[?:?]  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57) ~[?:?]  
at java.lang.reflect.Constructor.newInstance(Constructor.java:437) ~[?:1.8.0]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:423) ~[elasticsearch-5.5.0.jar:5.5.0]

```
    at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:387) ~[elasticsearch-5.5.0.jar:5.5.0

```

]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:140) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:312) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:244) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.0.jar:5.5.0]  
... 6 more  
Caused by: java.lang.IllegalArgumentException: none of the ciphers [TLS\_ECDHE\_RSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECD  
SA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA, TLS\_ECDHE\_RSA\_WITH\_AES\_128\_CBC\_SHA, TLS\_RSA\_WITH\_AES\_1  
28\_CBC\_SHA256, TLS\_RSA\_WITH\_AES\_128\_CBC\_SHA] are supported by this JVM  
at org.elasticsearch.xpack.ssl.SSLService.supportedCiphers(SSLService.java:355) ~[?:?]  
at org.elasticsearch.xpack.ssl.SSLService.createSslContext(SSLService.java:388) ~[?:?]  
at org.elasticsearch.xpack.ssl.SSLService.loadSSLConfigurations(SSLService.java:401) ~[?:?]  
at org.elasticsearch.xpack.ssl.SSLService.(SSLService.java:79) ~[?:?]  
at org.elasticsearch.xpack.XPackPlugin.(XPackPlugin.java:205) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]  
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:88) ~[?:?]  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57) ~[?:?]  
at java.lang.reflect.Constructor.newInstance(Constructor.java:437) ~[?:1.8.0]  
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:423) ~[elasticsearch-5.5.0.jar:5.5.0]

```
    at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:387) ~[elasticsearch-5.5.0.jar:5.5.0

```

]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:140) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:312) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.node.Node.(Node.java:244) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.0.jar:5.5.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.0.jar:5.5.0]  
... 6 more  
PS C:\elasticsearch-5.5.0\elasticsearch-5.5.0\bin\> java -version

Please note the installed Java version on my VM:

PS C:\elasticsearch-5.5.0\elasticsearch-5.5.0\bin\> java -version  
java version "1.8.0\_152"  
Java(TM) SE Runtime Environment (build 1.8.0\_152-b16)  
Java HotSpot(TM) 64-Bit Server VM (build 25.152-b16, mixed mode)  
PS C:\elasticsearch-5.5.0\elasticsearch-5.5.0\bin\>

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [December 11, 2017, 11:01pm UTC](https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048/2 "2017-12-11T23:01:16Z")

</div>

Hi,

The problem is

> IllegalArgumentException[none of the ciphers [TLS\_ECDHE\_RSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA, TLS\_ECDHE\_RSA\_WI  
> TH\_AES\_128\_CBC\_SHA, TLS\_RSA\_WITH\_AES\_128\_CBC\_SHA256, TLS\_RSA\_WITH\_AES\_128\_CBC\_SHA] are supported by this JVM];

It looks almost as though Elasticsearch uses another JVM on that server. Can you please share the first lines of the log output when Elasticsearch starts ?

---

<div class="post-metadata">

### Author: ![jpk](https://avatars.discourse-cdn.com/v4/letter/j/71e660/32.png) [@jpk](https://discuss.elastic.co/u/jpk)
#### Post date: [December 12, 2017, 6:35am UTC](https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048/3 "2017-12-12T06:35:27Z")

</div>

Hi,

Thank you a lot, you were right, it was pointing to the JVM that it was used to install Websphere and not the "1.8.0\_152", and so I point it to it.

Thanks again.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 9, 2018, 6:35am UTC](https://discuss.elastic.co/t/fail-to-run-elasticsearch-after-x-pack-plugin/111048/4 "2018-01-09T06:35:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
