# Fail to start elasticsearch that is installed as non admin user on Centos 7 max file descriptors \[4096\] for elasticsearch process is too low, increase to at least \[65536\]

**URL:** <https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241>\
**Category:** Elasticsearch\
**Created:** [July 7, 2017, 9:22am UTC](https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241 "2017-07-07T09:22:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cristina](https://avatars.discourse-cdn.com/v4/letter/c/cdc98d/32.png) [@Cristina](https://discuss.elastic.co/u/Cristina)\
**Post date:** [July 7, 2017, 9:22am UTC](https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241/1 "2017-07-07T09:22:34Z")

</div>

Hello guys,  
I have installed jdk1.8.0\_131,elasticsearch-5.4.2 along with logstash 5.4.2 ,kibana 5.4.2 and X-Pack 5.4.2 for a non-admin user on Centos 7.  
I made also some configuration for elasticsearch.  
When trying to start elasticsearch I get:

[INFO][o.e.b.BootstrapChecks] [aOYJKcV] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
ERROR: [1] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]

I have tried to fix by following [https://github.com/elastic/elasticsearch/issues/17430](https://github.com/elastic/elasticsearch/issues/17430) but still have problem starting...  
Could you please help with some advice?  
Thank you!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 7, 2017, 9:39am UTC](https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241/2 "2017-07-07T09:39:59Z")

</div>

Please read [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![Cristina](https://avatars.discourse-cdn.com/v4/letter/c/cdc98d/32.png) [@Cristina](https://discuss.elastic.co/u/Cristina)\
**Post date:** [July 7, 2017, 2:36pm UTC](https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241/3 "2017-07-07T14:36:56Z")

</div>

Yay!!Thanks!Fixed.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2017, 2:37pm UTC](https://discuss.elastic.co/t/fail-to-start-elasticsearch-that-is-installed-as-non-admin-user-on-centos-7-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65536/92241/4 "2017-08-04T14:37:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
