# Fail to start Kibana after loading my own plugin

**URL:** <https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448>\
**Category:** Kibana\
**Created:** [June 22, 2017, 12:00pm UTC](https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448 "2017-06-22T12:00:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mathias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mathias/32/23176_2.png) [@mathias](https://discuss.elastic.co/u/mathias)\
**Post date:** [June 22, 2017, 12:00pm UTC](https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448/1 "2017-06-22T12:00:23Z")

</div>

Hi,

I try to learn how to make my own plugin and follow the tutorial:

> **[Writing Kibana Plugins – Custom applications](https://www.timroes.de/writing-kibana-plugins-custom-applications)**
>
> This tutorial series explains how to create own Kibana plugins. This part explains
> how to create a custom application plugin.

I have done come modifications (changed to lowercase) to be able to build and install the plugin.  
Installation looks successful but when I start kibana from my web browser I see the following:  
 ![](https://us1.discourse-cdn.com/elastic/original/3X/0/1/0104de0ebfe07a0b900a305d3278db8681948d70.png)

I can't figure outh what more I need to change to make it work.  
I am testing on Kibana 6.0.0.

This is the line it complain about (in file kibana.bundle.js):  
330486 **webpack\_require** (1494).register(TagcloudProvider);

I have tried to change to git branch 5.4 but can not start Elasticsearch nor Kibana on this branch.  
Can someone give me a hint?

Br Mathias

---

<div class="post-metadata">

**Author:** ![BigFunger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bigfunger/32/7323_2.png) [@BigFunger](https://discuss.elastic.co/u/BigFunger)\
**Post date:** [June 22, 2017, 4:04pm UTC](https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448/2 "2017-06-22T16:04:06Z")

</div>

Why don't you try using the [Kibana Plugin Generator](https://github.com/elastic/generator-kibana-plugin) as your starting point? That should at least get you up and running with a very basic, but valid plugin shell, and you can expand from there.

---

<div class="post-metadata">

**Author:** ![mathias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mathias/32/23176_2.png) [@mathias](https://discuss.elastic.co/u/mathias)\
**Post date:** [June 22, 2017, 7:49pm UTC](https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448/3 "2017-06-22T19:49:43Z")

</div>

Hi,

That is exactly what I have done.  
I created successful a plugin showing time.  
When I tried to expand with the info from the tutorial I fail to start Kibana.  
Therefore I would appreciate information about how to avoid the **web\_pack** require problem.

Br Mathias

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 20, 2017, 7:49pm UTC](https://discuss.elastic.co/t/fail-to-start-kibana-after-loading-my-own-plugin/90448/4 "2017-07-20T19:49:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
