# Failed on parsing mappings on index creation \[nyc\_taxis\]

**URL:** <https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977>\
**Category:** Elasticsearch\
**Tags:** rally\
**Created:** [September 8, 2022, 9:48am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977 "2022-09-08T09:48:08Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![amitsa](https://avatars.discourse-cdn.com/v4/letter/a/dbc845/32.png) [@amitsa](https://discuss.elastic.co/u/amitsa)\
**Post date:** [September 8, 2022, 9:48am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/1 "2022-09-08T09:48:08Z")

</div>

Hi All,

I got below error while running benchmarking with nyc\_taxis track.

failed on parsing mappings on index creation [nyc\_taxis]", "ecs.version": "1.2.0","service.name":"ES\_ECS","event.dataset":"elasticsearch.server","process.thread.name":"elasticsearch[es-master][masterService#updateTask][T#1]","log.logger":"org.elasticsearch.cluster.metadata.MetadataCreateIndexService","elasticsearch.cluster.uuid":"aTZW8zstTpGjcWl9aHTGhw","elasticsearch.node.id":"qfLV4yDySnyl9t9D0vKGlw","elasticsearch.node.name":"es-master","elasticsearch.cluster.name":"elasticsearch","error.type":"org.elasticsearch.index.mapper.MapperParsingException","error.message":"Failed to parse mapping: unknown parameter [mode] on mapper [\_source] of type [null]","error.stack\_trace":"org.elasticsearch.index.mapper.MapperParsingException: Failed to parse mapping: unknown parameter [mode] on mapper [\_source] of type [null]\n\tat org.elasticsearch.index.mapper.MapperService.parseMapping(MapperService.java:372)\n\tat org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:347)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.updateIndexMappingsAndBuildSortOrder(MetadataCreateIndexService.java:1230)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.lambda$applyCreateIndexWithTemporaryService$3(MetadataCreateIndexService.java:435)\n\tat org.elasticsearch.indices.IndicesService.withTempIndexService(IndicesService.java:671)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.applyCreateIndexWithTemporaryService(MetadataCreateIndexService.java:433)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.applyCreateIndexRequestWithV1Templates(MetadataCreateIndexService.java:546)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.applyCreateIndexRequest(MetadataCreateIndexService.java:395)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService.applyCreateIndexRequest(MetadataCreateIndexService.java:402)\n\tat org.elasticsearch.cluster.metadata.MetadataCreateIndexService$1.execute(MetadataCreateIndexService.java:295)\n\tat org.elasticsearch.cluster.ClusterStateTaskExecutor$1.execute(ClusterStateTaskExecutor.java:95)\n\tat org.elasticsearch.cluster.service.MasterService.innerExecuteTasks(MasterService.java:901)\n\tat org.elasticsearch.cluster.service.MasterService.executeTasks(MasterService.java:871)\n\tat org.elasticsearch.cluster.service.MasterService.runTasks(MasterService.java:253)\n\tat org.elasticsearch.cluster.service.MasterService$Batcher.run(MasterService.java:153)\n\tat org.elasticsearch.cluster.service.TaskBatcher.runIfNotProcessed(TaskBatcher.java:114)\n\tat org.elasticsearch.cluster.service.TaskBatcher$BatchedTask.run(TaskBatcher.java:170)\n\tat org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:714)\n\tat org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:260)\n\tat org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:223)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)\n\tat java.base/java.lang.Thread.run(Thread.java:833)\nCaused by: org.elasticsearch.index.mapper.MapperParsingException: unknown parameter [mode] on mapper [\_source] of type [null]\n\tat org.elasticsearch.index.mapper.FieldMapper$Builder.parse(FieldMapper.java:1323)\n\tat org.elasticsearch.index.mapper.MetadataFieldMapper$ConfigurableTypeParser.parse(MetadataFieldMapper.java:104)\n\tat org.elasticsearch.index.mapper.MappingParser.parse(MappingParser.java:118)\n\tat org.elasticsearch.index.mapper.MappingParser.parse(MappingParser.java:94)\n\tat org.elasticsearch.index.mapper.MapperService.parseMapping(MapperService.java:370)\n\t... 22 more\n"}

Kindly help.

---

<div class="post-metadata">

**Author:** ![Quentin\_Pradet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/quentin_pradet/32/94192_2.png) [@Quentin\_Pradet](https://discuss.elastic.co/u/Quentin_Pradet)\
**Post date:** [September 8, 2022, 11:43am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/2 "2022-09-08T11:43:53Z")

</div>

The actual error is here:

> [@amitsa](#):
>
> Failed to parse mapping: unknown parameter [mode] on mapper [\_source] of type [null]"

The `mode` parameter is only supported in Elasticsearch 8.4 and above but we currently use it on every Elasticsearch 8.x version. We should probably fix the issue on our end, but in the meantime you can work around this by using either Elasticsearch 8.4 (which supports the ` mode` parameter`) or Elasticsearh 7.17 (where we will not set it).

---

<div class="post-metadata">

**Author:** ![amitsa](https://avatars.discourse-cdn.com/v4/letter/a/dbc845/32.png) [@amitsa](https://discuss.elastic.co/u/amitsa)\
**Post date:** [September 15, 2022, 4:46am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/3 "2022-09-15T04:46:06Z")

</div>

Thankyou @Quentin_Pradet for quick response.

How long will it take to fix this issue on other releases? Any PR or issue raised for this one.?

---

<div class="post-metadata">

**Author:** ![RickBoyd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rickboyd/32/80022_2.png) [@RickBoyd](https://discuss.elastic.co/u/RickBoyd)\
**Post date:** [September 15, 2022, 2:51pm UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/4 "2022-09-15T14:51:41Z")

</div>

Hello @amitsa,

The upstream issue has been resolved. Can you please try again?

---

<div class="post-metadata">

**Author:** ![amitsa](https://avatars.discourse-cdn.com/v4/letter/a/dbc845/32.png) [@amitsa](https://discuss.elastic.co/u/amitsa)\
**Post date:** [September 15, 2022, 3:52pm UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/5 "2022-09-15T15:52:54Z")

</div>

I am using the docker image of version 8.2.0 is the fix updated on docker image as well?

---

<div class="post-metadata">

**Author:** ![amitsa](https://avatars.discourse-cdn.com/v4/letter/a/dbc845/32.png) [@amitsa](https://discuss.elastic.co/u/amitsa)\
**Post date:** [September 19, 2022, 1:05pm UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/6 "2022-09-19T13:05:31Z")

</div>

Hi @RickBoyd

Is the fix for issue updated on official docker images as well?  
I am using the docker images version 8.2

---

<div class="post-metadata">

**Author:** ![Quentin\_Pradet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/quentin_pradet/32/94192_2.png) [@Quentin\_Pradet](https://discuss.elastic.co/u/Quentin_Pradet)\
**Post date:** [September 19, 2022, 1:44pm UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/7 "2022-09-19T13:44:33Z")

</div>

The fix is independent of the version of Rally you're using, since it was done in the rally-tracks repository.

So yes the Rally Docker image should work, you don't have to update it.

---

<div class="post-metadata">

**Author:** ![amitsa](https://avatars.discourse-cdn.com/v4/letter/a/dbc845/32.png) [@amitsa](https://discuss.elastic.co/u/amitsa)\
**Post date:** [September 19, 2022, 1:46pm UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/8 "2022-09-19T13:46:56Z")

</div>

Hi @Quentin_Pradet  
I am talking about Elasticsearch version 8.2.0. The mode parameter error.

---

<div class="post-metadata">

**Author:** ![Quentin\_Pradet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/quentin_pradet/32/94192_2.png) [@Quentin\_Pradet](https://discuss.elastic.co/u/Quentin_Pradet)\
**Post date:** [September 21, 2022, 11:03am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/9 "2022-09-21T11:03:49Z")

</div>

The bug was in the tracks repository that Rally uses. Now Rally correctly supports all Elasticsearch versions, including 8.2.0, where we will stop setting that mode parameter.

Have you considered just trying again to see if the bug was indeed fixed for you?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 19, 2022, 11:04am UTC](https://discuss.elastic.co/t/failed-on-parsing-mappings-on-index-creation-nyc-taxis/313977/10 "2022-10-19T11:04:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
