# Failed starting 'elasticsearch-service-x64' service

**URL:** <https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784>\
**Category:** Elasticsearch\
**Created:** [July 19, 2017, 2:12pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784 "2017-07-19T14:12:55Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Navakanth\_B](https://avatars.discourse-cdn.com/v4/letter/n/898d66/32.png) [@Navakanth\_B](https://discuss.elastic.co/u/Navakanth_B)\
**Post date:** [July 19, 2017, 2:12pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/1 "2017-07-19T14:12:55Z")

</div>

ES version: elasticsearch-5.5.0  
Java version: 1.8.0\_91  
OS: Windows-7(64 bit)  
Description: Could not start elasticsearch-service-x64 service, showing Failed starting 'elasticsearch-service-x64' service message in console when I run elasticsearch-service.bat start

I referred to [Failed to start elasticsearch service · Issue #24187 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/issues/24187) and [Failed to start elasticsearch service · Issue #21774 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/issues/21774) but the issue is same

JAVA\_HOME in system variables is C:\Program Files\Java\jdk1.8.0\_91

![](https://us1.discourse-cdn.com/elastic/original/3X/2/d/2d4cb1cb7d2e11fb0db2d9a943584dbcfd21820b.png)

jvm.options are as follows

-Xms2g  
-Xmx2g  
-XX:+UseConcMarkSweepGC  
-XX:CMSInitiatingOccupancyFraction=75  
-XX:+UseCMSInitiatingOccupancyOnly  
-XX:+DisableExplicitGC  
-XX:+AlwaysPreTouch  
-Xss1m  
-Djava.awt.headless=true  
-Dfile.encoding=UTF-8  
-Djna.nosys=true  
-Djdk.io.permissionsUseCanonicalPath=true  
-Dio.netty.noUnsafe=true  
-Dio.netty.noKeySetOptimization=true  
-Dio.netty.recycler.maxCapacityPerThread=0  
-Dlog4j.shutdownHookEnabled=false  
-Dlog4j2.disable.jmx=true  
-Dlog4j.skipJansi=true  
-XX:+HeapDumpOnOutOfMemoryError  
-Delasticsearch  
-Des.path.home=D:\Nava\New folder\elasticsearch-5.5.0  
-Des.default.path.logs=D:\Nava\New folder\elasticsearch-5.5.0\logs  
-Des.default.path.data=D:\Nava\New folder\elasticsearch-5.5.0\data  
-Des.default.path.conf=D:\Nava\New folder\elasticsearch-5.5.0\config

elasticsearch-service-x64.log file shows this message

> [2017-07-18 19:11:17] [info] [17092] Service elasticsearch-service-x64 name Elasticsearch 5.5.0 (elasticsearch-service-x64)  
> [2017-07-18 19:11:18] [info] [17092] Service 'elasticsearch-service-x64' installed  
> [2017-07-18 19:11:18] [info] [17092] Commons Daemon procrun finished  
> [2017-07-18 19:11:25] [info] [2364] Commons Daemon procrun (1.0.15.0 64-bit) started  
> [2017-07-18 19:11:25] [info] [2364] Starting service 'elasticsearch-service-x64' ...  
> [2017-07-18 19:11:25] [info] [10024] Commons Daemon procrun (1.0.15.0 64-bit) started  
> [2017-07-18 19:11:25] [info] [10024] Running 'elasticsearch-service-x64' Service...  
> [2017-07-18 19:11:25] [info] [22144] Starting service...  
> [2017-07-18 19:11:28] [error] [2364] Failed to start 'elasticsearch-service-x64' service  
> [2017-07-18 19:11:28] [error] [2364] The data area passed to a system call is too small.  
> [2017-07-18 19:11:28] [info] [2364] Start service finished.  
> [2017-07-18 19:11:28] [error] [2364] Commons Daemon procrun failed with exit value: 5 (Failed to start service)  
> [2017-07-18 19:11:28] [error] [2364] The data area passed to a system call is too small.

elasticsearch-service-x64-stderr.log shows this message

> 2017-07-18 19:11:25 Commons Daemon procrun stderr initialized  
> The data area passed to a system call is too small.

elasticsearch-service-x64-stdout.log shows this message

> 2017-07-19 17:50:56 Commons Daemon procrun stdout initialized  
> starts elasticsearch

> Option Description
> 
> * * *
> 
> -E Configure a setting  
> -V, --version Prints elasticsearch version information and exits  
> -d, --daemonize Starts Elasticsearch in the background  
> -h, --help show help  
> -p, --pidfile Creates a pid file in the specified path on start  
> -q, --quiet Turns off standard ouput/error streams logging in console  
> -s, --silent show minimal output  
> -v, --verbose show verbose output  
> ERROR: Positional arguments not allowed, found [start]

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [July 21, 2017, 1:05pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/2 "2017-07-21T13:05:40Z")

</div>

I think that you ran the wrong command, I think that you ran `bin\elasticsearch.bat start` and instead you should be running `bin\elasticsearch-service.bat start`.

---

<div class="post-metadata">

**Author:** ![Navakanth\_B](https://avatars.discourse-cdn.com/v4/letter/n/898d66/32.png) [@Navakanth\_B](https://discuss.elastic.co/u/Navakanth_B)\
**Post date:** [July 24, 2017, 11:03am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/3 "2017-07-24T11:03:36Z")

</div>

No I am running it right, bin\> elasticsearch-service.bat start.  
When I do install elasticsearch-service-x64 is showing in the services and when I try to start it manually it is showing this message.

![](https://us1.discourse-cdn.com/elastic/original/3X/8/d/8d3ad5028440f8a820506c3c6ea6a8c46c53c343.png)

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [August 1, 2017, 9:09am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/4 "2017-08-01T09:09:47Z")

</div>

Well, something is not right here because these logs:

> [@Navakanth\_B](#):
>
> starts elasticsearch
> 
> Option Description
> 
> -E Configure a setting  
> -V, --version Prints elasticsearch version information and exits  
> -d, --daemonize Starts Elasticsearch in the background  
> -h, --help show help  
> -p, --pidfile Creates a pid file in the specified path on start  
> -q, --quiet Turns off standard ouput/error streams logging in console  
> -s, --silent show minimal output  
> -v, --verbose show verbose output  
> ERROR: Positional arguments not allowed, found [start]

are exactly the error message that you would see if you executed `bin\elasticsearch.bat start`. The service does not pass `start` to the main method of Elasticsearch. Maybe you changed the `Startup` tab for the service? Can you execute `bin\elasticsearch-service.bat manager` and show the contents of the `Arguments` on the `Startup` tab? It should be empty, but maybe it contains `start` for you? I can reproduce your problem _exactly_ if I put `start` there.

---

<div class="post-metadata">

**Author:** ![Navakanth\_B](https://avatars.discourse-cdn.com/v4/letter/n/898d66/32.png) [@Navakanth\_B](https://discuss.elastic.co/u/Navakanth_B)\
**Post date:** [August 7, 2017, 6:38am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/5 "2017-08-07T06:38:53Z")

</div>

@jasontedor worked, Thanks.  
I dont know from where that start argument has come, I just downloaded the zip file and ran it

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [August 7, 2017, 7:24am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/6 "2017-08-07T07:24:49Z")

</div>

You're welcome.

---

<div class="post-metadata">

**Author:** ![Navakanth\_B](https://avatars.discourse-cdn.com/v4/letter/n/898d66/32.png) [@Navakanth\_B](https://discuss.elastic.co/u/Navakanth_B)\
**Post date:** [August 11, 2017, 9:30am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/7 "2017-08-11T09:30:49Z")

</div>

Is there anyway I can remove that start argument from the command line, it is coming by default.  
We do extracting and running the elastic from build.gradle so the service is not getting started until I invoke manager tool and remove that start argument

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [August 13, 2017, 11:43am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/8 "2017-08-13T11:43:46Z")

</div>

I'm not sure what you mean it's coming by default, it should not be. Can you please provide a reproduction?

---

<div class="post-metadata">

**Author:** ![Navakanth\_B](https://avatars.discourse-cdn.com/v4/letter/n/898d66/32.png) [@Navakanth\_B](https://discuss.elastic.co/u/Navakanth_B)\
**Post date:** [August 14, 2017, 6:39am UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/9 "2017-08-14T06:39:38Z")

</div>

As per my observation 'Start' argument is coming only when I install Elasticsearch-5.5.1 in a machine for first time, when I remove 'start', delete the service and install in the same machine issue is not reproducible.  
Try unzipping and creating the elasticsearch service in a fresh VM you may find it.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [August 14, 2017, 3:47pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/10 "2017-08-14T15:47:12Z")

</div>

Can you please be more explicit about the steps to reproduce? I tried with the Elasticsearch 5.5.1 zip download on a fresh Windows VM. Here are the steps I took:

1. Download Elasticsearch 5.5.1 from [https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-5.5.1.zip](https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-5.5.1.zip)
2. Unzip the zip archive `elasticsearch-5.5.1.zip`
3. Run `.\elasticsearch-5.5.1\bin\elasticsearch-service.bat install`
4. Run `.\elasticsearch-5.5.1\bin\elasticsearch-service.bat manager`
5. Inspect the `Startup` tab; it was correct
6. Run `.\elasticsearch-5.5.1\bin\elasticsearch-service.bat start`; Elasticsearch started fine

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 11, 2017, 3:47pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service-x64-service/93784/11 "2017-09-11T15:47:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
