# Failed starting elasticsearch service

**URL:** <https://discuss.elastic.co/t/failed-starting-elasticsearch-service/73044>\
**Category:** Elasticsearch\
**Created:** [January 27, 2017, 4:45pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service/73044 "2017-01-27T16:45:26Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![DanPou](https://avatars.discourse-cdn.com/v4/letter/d/ecccb3/32.png) [@DanPou](https://discuss.elastic.co/u/DanPou)\
**Post date:** [January 27, 2017, 4:45pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service/73044/1 "2017-01-27T16:45:26Z")

</div>

Hello, I installed elasticsearch service on W2012 R2 but can't start it...  
in log I have : root cause : elasticsearchparseexception[malformed, expected settings to start with 'object', instead was [VALUE\_STRING]]

any idea ?

thank you !

---

<div class="post-metadata">

**Author:** ![DanPou](https://avatars.discourse-cdn.com/v4/letter/d/ecccb3/32.png) [@DanPou](https://discuss.elastic.co/u/DanPou)\
**Post date:** [January 27, 2017, 6:24pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service/73044/2 "2017-01-27T18:24:57Z")

</div>

I found a solution, the problem was in my yml file I didn't insert any space. I defined 2 key value in the yml file and I had to put a key and then a space, then a colon and then again a space, then value. e.g. script.inline : on  
working.. thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 24, 2017, 6:25pm UTC](https://discuss.elastic.co/t/failed-starting-elasticsearch-service/73044/3 "2017-02-24T18:25:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
