# Failed stopping 'elasticsearch-service-x64' service

**URL:** <https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460>\
**Category:** Elasticsearch\
**Created:** [January 2, 2015, 8:31pm UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460 "2015-01-02T20:31:28Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Garrett\_Johnson](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Garrett\_Johnson](https://discuss.elastic.co/u/Garrett_Johnson)\
**Post date:** [January 2, 2015, 8:31pm UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/1 "2015-01-02T20:31:28Z")

</div>

I'm getting this error every time I try to start and stop the elastic  
search windows service.

Takes a couple of minutes then fails. I can kill the task in task manager  
and then restart but cannot get it to stop on its own.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/9385bbd6-914d-438c-a12f-cf90f992e278%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/9385bbd6-914d-438c-a12f-cf90f992e278%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Garrett\_Johnson](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Garrett\_Johnson](https://discuss.elastic.co/u/Garrett_Johnson)\
**Post date:** [January 2, 2015, 8:32pm UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/2 "2015-01-02T20:32:52Z")

</div>

By own it's own I mean service stop or using services.msc and clicking  
restart on the service. Both attempts get the same error.

On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:

> I'm getting this error every time I try to start and stop the elastic  
> search windows service.
> 
> Takes a couple of minutes then fails. I can kill the task in task manager  
> and then restart but cannot get it to stop on its own.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![costin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/costin/32/44950_2.png) [@costin](https://discuss.elastic.co/u/costin)\
**Post date:** [January 3, 2015, 4:10pm UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/3 "2015-01-03T16:10:30Z")

</div>

Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?

On 1/2/15 10:32 PM, Garrett Johnson wrote:

> By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts get the  
> same error.
> 
> On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> 
> ```
> I'm getting this error every time I try to start and stop the elastic search windows service.
> 
> Takes a couple of minutes then fails. I can kill the task in task manager and then restart but cannot get it to
> stop on its own.
> 
> ```
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/54A81476.4020909%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/54A81476.4020909%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Garrett\_Johnson](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Garrett\_Johnson](https://discuss.elastic.co/u/Garrett_Johnson)\
**Post date:** [January 5, 2015, 12:25am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/4 "2015-01-05T00:25:40Z")

</div>

Log entries:  
[2015-01-04 18:13:56,185][INFO][node] [Bucky III]  
stopping ...  
[2015-01-04 18:13:56,202][INFO][river.jdbc.JDBCRiver] river closed  
[jdbc/users]  
[2015-01-04 18:13:56,203][INFO][river.jdbc.JDBCRiver] river closed  
[jdbc/product2]  
[2015-01-04 18:13:56,342][INFO][node] [Bucky III]  
stopped  
[2015-01-04 18:13:56,342][INFO][node] [Bucky III]  
closing ...  
[2015-01-04 18:13:56,355][INFO][node] [Bucky III]  
closed

Windows Server 2008R2

Elasticsearch 1.4.2  
Plugins Elasticsearch Head, jdbc river 1.4.0.6

Microsoft jdbc driver.

Thanks,

Garrett

On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:

> Do you see anything in the logs? Can you try removing and reinstalling the  
> service? What's your OS/configuration?
> 
> On 1/2/15 10:32 PM, Garrett Johnson wrote:
> 
> > By own it's own I mean service stop or using services.msc and clicking  
> > restart on the service. Both attempts get the  
> > same error.
> > 
> > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> > 
> > ```
> > I'm getting this error every time I try to start and stop the 
> > 
> > ```
> 
> Elasticsearch windows service.
> 
> > ```
> > Takes a couple of minutes then fails. I can kill the task in task 
> > 
> > ```
> 
> manager and then restart but cannot get it to
> 
> > ```
> > stop on its own. 
> > 
> > ```
> > 
> > --  
> > You received this message because you are subscribed to the Google  
> > Groups "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send  
> > an email to  
> > [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\> \<mailto:  
> > [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) \<javascript:\>\>.  
> > To view this discussion on the web visit
> 
> [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com)
> 
> > \<  
> > [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer)\>.
> 
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Itamar\_Syn\_Hershko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/itamar_syn_hershko/32/725_2.png) [@Itamar\_Syn\_Hershko](https://discuss.elastic.co/u/Itamar_Syn_Hershko)\
**Post date:** [January 5, 2015, 6:36am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/5 "2015-01-05T06:36:05Z")

</div>

Does it also happen when you uninstall the JDBC river?

Also, I'd highly recommend using Linux servers for Elasticsearch instances  
and not Windows ones

--

Itamar Syn-Hershko  
[http://code972.com](http://code972.com) | @synhershko [https://twitter.com/synhershko](https://twitter.com/synhershko)  
Freelance Developer & Consultant  
Author of RavenDB in Action [http://manning.com/synhershko/](http://manning.com/synhershko/)

On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson [garrettcjohnson@gmail.com](mailto:garrettcjohnson@gmail.com)  
wrote:

> Log entries:  
> [2015-01-04 18:13:56,185][INFO][node] [Bucky III]  
> stopping ...  
> [2015-01-04 18:13:56,202][INFO][river.jdbc.JDBCRiver] river closed  
> [jdbc/users]  
> [2015-01-04 18:13:56,203][INFO][river.jdbc.JDBCRiver] river closed  
> [jdbc/product2]  
> [2015-01-04 18:13:56,342][INFO][node] [Bucky III]  
> stopped  
> [2015-01-04 18:13:56,342][INFO][node] [Bucky III]  
> closing ...  
> [2015-01-04 18:13:56,355][INFO][node] [Bucky III]  
> closed
> 
> Windows Server 2008R2
> 
> Elasticsearch 1.4.2  
> Plugins Elasticsearch Head, jdbc river 1.4.0.6
> 
> Microsoft jdbc driver.
> 
> Thanks,
> 
> Garrett
> 
> On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:
> 
> > Do you see anything in the logs? Can you try removing and reinstalling  
> > the service? What's your OS/configuration?
> > 
> > On 1/2/15 10:32 PM, Garrett Johnson wrote:
> > 
> > > By own it's own I mean service stop or using services.msc and clicking  
> > > restart on the service. Both attempts get the  
> > > same error.
> > > 
> > > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> > > 
> > > ```
> > > I'm getting this error every time I try to start and stop the
> > > 
> > > ```
> > 
> > Elasticsearch windows service.
> > 
> > > ```
> > > Takes a couple of minutes then fails. I can kill the task in task
> > > 
> > > ```
> > 
> > manager and then restart but cannot get it to
> > 
> > > ```
> > > stop on its own.
> > > 
> > > ```
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google  
> > > Groups "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send  
> > > an email to  
> > > [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<mailto:elasticsearch+  
> > > [unsubscribe@googlegroups.com](mailto:unsubscribe@googlegroups.com)\>.  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/f4efa651-](https://groups.google.com/d/msgid/elasticsearch/f4efa651-)  
> > > 9c60-4abb-b04a-47992f1c3e82%[40googlegroups.com](http://40googlegroups.com)  
> > > \<[https://groups.google.com/d/msgid/elasticsearch/f4efa651-](https://groups.google.com/d/msgid/elasticsearch/f4efa651-)  
> > > 9c60-4abb-b04a-47992f1c3e82%[40GGGROUPS CASINO – Real Slot Casino for 10,000+ Senior Players](http://40googlegroups.com?utm_medium=)  
> > > email&utm\_source=footer\>.  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > Costin
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX\_g%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![costin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/costin/32/44950_2.png) [@costin](https://discuss.elastic.co/u/costin)\
**Post date:** [January 5, 2015, 8:32am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/6 "2015-01-05T08:32:23Z")

</div>

Can you turn on the logging of elasticsearch-service all the way to debug, start and stop the service and see whether  
anything special appears in the logs?  
You can do this by invoking \>service manager and in the logging tab, changing the level from Info to Debug (see the  
screenshot below):

The service wrapper log is elasticsearch-service-x64, in the same service as Elasticsearch log. Try and do some dry runs

- simply starting and stopping the service (I also recommend removing the service and installing it fresh).  
You could also try removing the plugin and simply starting and stopping the fresh install of Elasticsearch to see  
whether it's a configuration problem or whether one of the plugins might affect the shutdown...

Cheers,

On 1/5/15 2:25 AM, Garrett Johnson wrote:

> Log entries:  
> [2015-01-04 18:13:56,185][INFO][node] [Bucky III] stopping ...  
> [2015-01-04 18:13:56,202][INFO][river.jdbc.JDBCRiver] river closed [jdbc/users]  
> [2015-01-04 18:13:56,203][INFO][river.jdbc.JDBCRiver] river closed [jdbc/product2]  
> [2015-01-04 18:13:56,342][INFO][node] [Bucky III] stopped  
> [2015-01-04 18:13:56,342][INFO][node] [Bucky III] closing ...  
> [2015-01-04 18:13:56,355][INFO][node] [Bucky III] closed
> 
> Windows Server 2008R2
> 
> Elasticsearch 1.4.2  
> Plugins Elasticsearch Head, jdbc river 1.4.0.6
> 
> Microsoft jdbc driver.
> 
> Thanks,
> 
> Garrett
> 
> On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:
> 
> ```
> Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?
> 
> On 1/2/15 10:32 PM, Garrett Johnson wrote:
> > By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts
> get the
> > same error.
> >
> > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> >
> > I'm getting this error every time I try to start and stop the elastic search windows service.
> >
> > Takes a couple of minutes then fails. I can kill the task in task manager and then restart but cannot get
> it to
> > stop on its own.
> >
> > --
> > You received this message because you are subscribed to the Google Groups "elasticsearch" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to
> > elasticsearc...@googlegroups.com <javascript:> <mailto:elasticsearch+unsubscribe@googlegroups.com <javascript:>>.
> > To view this discussion on the web visit
> > https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com
> <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com>
> >
> <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer
> <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer>>.
> 
> > For more options, visit https://groups.google.com/d/optout <https://groups.google.com/d/optout>.
> 
> -- 
> Costin
> 
> ```
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/54AA4C17.8090103%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/54AA4C17.8090103%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Garrett\_Johnson](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Garrett\_Johnson](https://discuss.elastic.co/u/Garrett_Johnson)\
**Post date:** [January 6, 2015, 4:35am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/7 "2015-01-06T04:35:31Z")

</div>

It appears that after uninstall of the jdbc river it starts and stops just fine.

Sent from my iPhone

> On Jan 5, 2015, at 1:36 AM, Itamar Syn-Hershko [itamar@code972.com](mailto:itamar@code972.com) wrote:
> 
> Does it also happen when you uninstall the JDBC river?
> 
> Also, I'd highly recommend using Linux servers for Elasticsearch instances and not Windows ones
> 
> --
> 
> Itamar Syn-Hershko  
> [http://code972.com](http://code972.com) | @synhershko  
> Freelance Developer & Consultant  
> Author of RavenDB in Action
> 
> > On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson [garrettcjohnson@gmail.com](mailto:garrettcjohnson@gmail.com) wrote:  
> > Log entries:  
> > [2015-01-04 18:13:56,185][INFO][node] [Bucky III] stopping ...  
> > [2015-01-04 18:13:56,202][INFO][river.jdbc.JDBCRiver] river closed [jdbc/users]  
> > [2015-01-04 18:13:56,203][INFO][river.jdbc.JDBCRiver] river closed [jdbc/product2]  
> > [2015-01-04 18:13:56,342][INFO][node] [Bucky III] stopped  
> > [2015-01-04 18:13:56,342][INFO][node] [Bucky III] closing ...  
> > [2015-01-04 18:13:56,355][INFO][node] [Bucky III] closed
> > 
> > Windows Server 2008R2
> > 
> > Elasticsearch 1.4.2  
> > Plugins Elasticsearch Head, jdbc river 1.4.0.6
> > 
> > Microsoft jdbc driver.
> > 
> > Thanks,
> > 
> > Garrett
> > 
> > > On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:  
> > > Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?
> > > 
> > > On 1/2/15 10:32 PM, Garrett Johnson wrote:
> > > 
> > > > By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts get the  
> > > > same error.
> > > > 
> > > > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> > > > 
> > > > ```
> > > > I'm getting this error every time I try to start and stop the elastic search windows service. 
> > > > 
> > > > Takes a couple of minutes then fails. I can kill the task in task manager and then restart but cannot get it to 
> > > > stop on its own. 
> > > > 
> > > > ```
> > > > 
> > > > --  
> > > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > > > To unsubscribe from this group and stop receiving emails from it, send an email to  
> > > > [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > > > To view this discussion on the web visit  
> > > > [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com)  
> > > > [https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer).  
> > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > > 
> > > --  
> > > Costin
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com).  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.  
> To unsubscribe from this topic, visit [https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe](https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe).  
> To unsubscribe from this group and all its topics, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX\_g%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![costin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/costin/32/44950_2.png) [@costin](https://discuss.elastic.co/u/costin)\
**Post date:** [January 6, 2015, 11:08am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/8 "2015-01-06T11:08:14Z")

</div>

It might be related then to the underlying JDBC driver. Try to change the driver or see if there are any parameters that  
you could set.  
Some drivers are buggy in that they prevent the JVM from shutting down correctly as they keep hanging on to the  
underlying connections.  
You could try using a connection pool in front, like c3p0 or BoneCP and see if it improves things.

On 1/6/15 6:35 AM, Garrett Johnson wrote:

> It appears that after uninstall of the jdbc river it starts and stops just fine.
> 
> Sent from my iPhone
> 
> On Jan 5, 2015, at 1:36 AM, Itamar Syn-Hershko \<[itamar@code972.com](mailto:itamar@code972.com) [mailto:itamar@code972.com](mailto:itamar@code972.com)\> wrote:
> 
> > Does it also happen when you uninstall the JDBC river?
> > 
> > Also, I'd highly recommend using Linux servers for Elasticsearch instances and not Windows ones
> > 
> > --
> > 
> > Itamar Syn-Hershko  
> > [http://code972.com](http://code972.com) [http://code972.com/](http://code972.com/) | @synhershko [https://twitter.com/synhershko](https://twitter.com/synhershko)  
> > Freelance Developer & Consultant  
> > Author of RavenDB in Action [http://manning.com/synhershko/](http://manning.com/synhershko/)
> > 
> > On Mon, Jan 5, 2015 at 2:25 AM, Garrett Johnson \<[garrettcjohnson@gmail.com](mailto:garrettcjohnson@gmail.com) [mailto:garrettcjohnson@gmail.com](mailto:garrettcjohnson@gmail.com)\> wrote:
> > 
> > ```
> > Log entries:
> > [2015-01-04 18:13:56,185][INFO][node] [Bucky III] stopping ...
> > [2015-01-04 18:13:56,202][INFO][river.jdbc.JDBCRiver] river closed [jdbc/users]
> > [2015-01-04 18:13:56,203][INFO][river.jdbc.JDBCRiver] river closed [jdbc/product2]
> > [2015-01-04 18:13:56,342][INFO][node] [Bucky III] stopped
> > [2015-01-04 18:13:56,342][INFO][node] [Bucky III] closing ...
> > [2015-01-04 18:13:56,355][INFO][node] [Bucky III] closed
> > 
> > Windows Server 2008R2
> > 
> > ElasticSearch 1.4.2
> > Plugins ElasticSearch Head, jdbc river 1.4.0.6
> > 
> > Microsoft jdbc driver.
> > 
> > Thanks,
> > 
> > Garrett
> > 
> > On Saturday, January 3, 2015 10:10:42 AM UTC-6, Costin Leau wrote:
> > 
> > Do you see anything in the logs? Can you try removing and reinstalling the service? What's your OS/configuration?
> > 
> > On 1/2/15 10:32 PM, Garrett Johnson wrote:
> > > By own it's own I mean service stop or using services.msc and clicking restart on the service. Both attempts get the
> > > same error.
> > >
> > > On Friday, January 2, 2015 2:31:28 PM UTC-6, Garrett Johnson wrote:
> > >
> > > I'm getting this error every time I try to start and stop the elastic search windows service.
> > >
> > > Takes a couple of minutes then fails. I can kill the task in task manager and then restart but cannot get it to
> > > stop on its own.
> > >
> > > --
> > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.
> > > To unsubscribe from this group and stop receiving emails from it, send an email to
> > >elasticsearc...@ __googlegroups.com <mailto:elasticsearch+__ unsubscribe@googlegroups.com>.
> > > To view this discussion on the web visit
> > >https://groups.google.com/d/ __msgid/elasticsearch/f4efa651-__ 9c60-4abb-b04a-47992f1c3e82%__40googlegroups.com
> > <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com>
> > > <https://groups.google.com/d/ __msgid/elasticsearch/f4efa651-__ 9c60-4abb-b04a-47992f1c3e82% __40googlegroups.com?utm_medium=__ email&utm_source=footer
> > <https://groups.google.com/d/msgid/elasticsearch/f4efa651-9c60-4abb-b04a-47992f1c3e82%40googlegroups.com?utm_medium=email&utm_source=footer>>.
> > 
> > > For more options, visithttps://groups.google.com/d/__optout <https://groups.google.com/d/optout>.
> > 
> > --
> > Costin
> > 
> > --
> > You received this message because you are subscribed to the Google Groups "elasticsearch" group.
> > To unsubscribe from this group and stop receiving emails from it, send an email to
> > elasticsearch+unsubscribe@googlegroups.com <mailto:elasticsearch+unsubscribe@googlegroups.com>.
> > To view this discussion on the web visit
> > https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com
> > <https://groups.google.com/d/msgid/elasticsearch/fed85958-becc-4269-9300-044e22499624%40googlegroups.com?utm_medium=email&utm_source=footer>.
> > For more options, visit https://groups.google.com/d/optout.
> > 
> > ```
> > 
> > --  
> > You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.  
> > To unsubscribe from this topic, visit [https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe](https://groups.google.com/d/topic/elasticsearch/nzf4sUcf7n0/unsubscribe).  
> > To unsubscribe from this group and all its topics, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com)  
> > [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX\_g%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX\_g%40mail.gmail.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zvr0bkpiNCwJpGWhPRV0POVn1eJQxcs%2Bb19MmtaiB%2BX_g%40mail.gmail.com?utm_medium=email&utm_source=footer).  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com)  
> [https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/DD3CE8D9-D882-4557-B9F9-04DCB56B242C%40gmail.com?utm_medium=email&utm_source=footer).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/54ABC21E.1010107%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/54ABC21E.1010107%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Garrett\_Johnson](https://avatars.discourse-cdn.com/v4/letter/g/41988e/32.png) [@Garrett\_Johnson](https://discuss.elastic.co/u/Garrett_Johnson)\
**Post date:** [January 7, 2015, 3:43am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/9 "2015-01-07T03:43:24Z")

</div>

I tried increasing the logging but it didn't give me anymore info.

I'm sure it is the jdbc driver as I have had to uninstall / reinstall  
everything several times and without that jdbc river driver it's fine.

Since the search is working fine is there any issue with me having to kill  
it to restart?

That said it is unwise for that to be the case in a production environment  
regardless so can you give me and pointers to info about c3P0 and / or Bone  
PC that directly relate to elasticsearch?

Thanks for your help

On Tuesday, January 6, 2015 5:08:37 AM UTC-6, Costin Leau wrote:

> It might be related then to the underlying JDBC driver. Try to change the  
> driver or see if there are any parameters that  
> you could set.  
> Some drivers are buggy in that they prevent the JVM from shutting down  
> correctly as they keep hanging on to the  
> underlying connections.  
> You could try using a connection pool in front, like c3p0 or BoneCP and  
> see if it improves things.
> 
> Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![costin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/costin/32/44950_2.png) [@costin](https://discuss.elastic.co/u/costin)\
**Post date:** [January 7, 2015, 10:23am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/10 "2015-01-07T10:23:52Z")

</div>

c3p0 / boneCP are basically connection pools around JDBC drivers. You can simply point your JDBC client (in this case  
the jdbc river)  
to c3p0 or bonecp which in turn, use the microsoft jdbc driver. Each connection pool has its own documentation on how to  
configure it -  
it's pretty similar to your jdbc configuration.

By the way, I forgot to mention the jTDS driver [1], an open-source implementation for SQL server and Sybase.  
Try first with that and see whether it alleviates your issue if not, I would pick BoneCP first followed by C3P0.

You could also try to see whether the MS driver has any options (such as timeout) and enable tracing to figure out why  
it's hanging [4]  
[5]

Hope this helps,

[1] [jTDS JDBC Driver](http://jtds.sourceforge.net/index.html)  
[2] [http://jolbox.com/](http://jolbox.com/)  
[3] [c3p0:JDBC DataSources/Resource Pools download | SourceForge.net](http://sourceforge.net/projects/c3p0/)  
[4] [Tracing driver operation (logging) - JDBC Driver for SQL Server | Microsoft Learn](http://msdn.microsoft.com/en-us/library/ms378517.aspx)  
[5] [Diagnosing problems with the JDBC driver - JDBC Driver for SQL Server | Microsoft Learn](http://msdn.microsoft.com/en-us/library/ms378522.aspx)

On 1/7/15 5:43 AM, Garrett Johnson wrote:

> I tried increasing the logging but it didn't give me anymore info.
> 
> I'm sure it is the jdbc driver as I have had to uninstall / reinstall everything several times and without that jdbc  
> river driver it's fine.
> 
> Since the search is working fine is there any issue with me having to kill it to restart?
> 
> That said it is unwise for that to be the case in a production environment regardless so can you give me and pointers to  
> info about c3P0 and / or Bone PC that directly relate to elasticsearch?
> 
> Thanks for your help
> 
> On Tuesday, January 6, 2015 5:08:37 AM UTC-6, Costin Leau wrote:
> 
> ```
> It might be related then to the underlying JDBC driver. Try to change the driver or see if there are any parameters
> that
> you could set.
> Some drivers are buggy in that they prevent the JVM from shutting down correctly as they keep hanging on to the
> underlying connections.
> You could try using a connection pool in front, like c3p0 or BoneCP and see if it improves things.
> 
> Costin
> 
> ```
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com) [mailto:elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/701e0c3e-d71c-487e-80e3-bc966c8d3f36%40googlegroups.com?utm_medium=email&utm_source=footer).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
Costin

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/54AD0938.2000606%40gmail.com](https://groups.google.com/d/msgid/elasticsearch/54AD0938.2000606%40gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:40am UTC](https://discuss.elastic.co/t/failed-stopping-elasticsearch-service-x64-service/21460/11 "2017-07-06T00:40:20Z")

</div>


