# Failed to add 2nd ECE VM to cluster

**URL:** <https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [June 13, 2017, 1:33pm UTC](https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198 "2017-06-13T13:33:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matthew\_Bailey](https://avatars.discourse-cdn.com/v4/letter/m/838e76/32.png) [@Matthew\_Bailey](https://discuss.elastic.co/u/Matthew_Bailey)\
**Post date:** [June 13, 2017, 1:33pm UTC](https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198/1 "2017-06-13T13:33:29Z")

</div>

I ran int the following issue adding a 2nd server to my ECE Cluster (v 1.01)

Error: Can't connect COORDINATOR\_HOST [AH-ECE-POC01:2112]: Connection refused

bash: ./elastic-cloud-enterprise.sh --availability-zone "Auburn\_Hills-02" --coordinator-host AH-ECE-POC01 --roles-token 'eyJ0e...truncated for post....7x3xrE-\_w' --debug

There is no firewall between servers, both are on the same subnet, and can ping each other.  
I verifed server 1 is running and I can access the ECE site.

Any suggestions would be helpful.

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [June 13, 2017, 2:40pm UTC](https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198/2 "2017-06-13T14:40:33Z")

</div>

Hi @Matthew_Bailey

Sorry that you're running into problems

It looks like one of two things is happening:

- The co-ordinator host isn't working properly (this would be bad)
- Port 2112 is firewalled off by port

If the 1 host install appears to be working then the first is unlikely, that would be a catastrophic failure.

To confirm you could login to `AH-ECE-POC01` and `telnet AH-ECE-POC01 2112` to check it's accessible locally. If it works you'll get `Escape character is '^]'.`

Here's a couple of other commands you can run on the co-ordinator host:

```auto
[elastic@ip-192-168-44-10 ~]$ docker ps | grep 2112
4e7aa29e6f69 docker.elastic.co/cloud-ci/elastic-cloud-enterprise:1.0.0 "/sbin/my_init" 13 days ago Up 13 days 0.0.0.0:2112->2112/tcp frc-directors-director
[elastic@ip-192-168-44-10 ~]$ netstat -nap | grep 2112
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp6 0 0 :::2112 :::* LISTEN -                   

```

Assuming it is, you can then confirm there is a connectivity issue by logging onto the 2nd server and trying the same `telnet` command. If that fails (but `ping` works) then it must be firewall/`iptables` problem

Alex

---

<div class="post-metadata">

**Author:** ![Matthew\_Bailey](https://avatars.discourse-cdn.com/v4/letter/m/838e76/32.png) [@Matthew\_Bailey](https://discuss.elastic.co/u/Matthew_Bailey)\
**Post date:** [June 13, 2017, 6:44pm UTC](https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198/3 "2017-06-13T18:44:12Z")

</div>

It turns out the cordinator host wasn't working correctly. The solution was to uninstall ECE on both servers (cordinator host and new host) and reinstall.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 27, 2017, 6:44pm UTC](https://discuss.elastic.co/t/failed-to-add-2nd-ece-vm-to-cluster/89198/4 "2017-06-27T18:44:13Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
