# Failed to add match 'elasticsearch': Invalid argument

**URL:** <https://discuss.elastic.co/t/failed-to-add-match-elasticsearch-invalid-argument/294388>\
**Category:** Elasticsearch\
**Created:** [January 14, 2022, 9:15am UTC](https://discuss.elastic.co/t/failed-to-add-match-elasticsearch-invalid-argument/294388 "2022-01-14T09:15:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 14, 2022, 9:15am UTC](https://discuss.elastic.co/t/failed-to-add-match-elasticsearch-invalid-argument/294388/1 "2022-01-14T09:15:17Z")

</div>

Hi,

I have the following issue after upgrading ELasticsearch from 6.8.22 to 7.14.2.

When trying to start the service:  
Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

# journalctl -xe elasticsearch

Failed to add match 'elasticsearch': Invalid argument  
Failed to add filters: Invalid argument

# journalctl -fu elasticsearch

-- Logs begin at Tue 2021-11-16 16:44:59 EST. --  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: Error: A fatal exception has occurred. Program will exit.  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: at org.elasticsearch.tools.launchers.JvmOption.flagsFinal(JvmOption.java:119)  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: at org.elasticsearch.tools.launchers.JvmOption.findFinalOptions(JvmOption.java:81)  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:38)  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:135)  
Jan 14 03:44:28 my-server systemd-entrypoint[4161]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86)  
Jan 14 03:44:28 my-server systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Jan 14 03:44:28 my-server systemd[1]: Failed to start Elasticsearch.  
Jan 14 03:44:28 my-server systemd[1]: Unit elasticsearch.service entered failed state.  
Jan 14 03:44:28 my-server systemd[1]: elasticsearch.service failed.

I run my ELK Stack on RedHat Linux and used rpm package for the upgrade.

I added the following lines to my elasticsearch.yml as I know this is required configuration for all versions after 7.0.  
discovery.seed\_hosts:

- master\_node\_name\_or\_ip\_address

cluster.initial\_master\_nodes:

- master\_node\_name\_or\_ip\_address

I checked my yml and it is a valid file.

Do you have any clues what might be the problem here?

Thank you!  
PP

---

<div class="post-metadata">

**Author:** ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)\
**Post date:** [January 14, 2022, 3:17pm UTC](https://discuss.elastic.co/t/failed-to-add-match-elasticsearch-invalid-argument/294388/2 "2022-01-14T15:17:20Z")

</div>

The issue were fixed by commeting these three lines in jvm.options:  
#-XX:+UseConcMarkSweepGC  
#-XX:CMSInitiatingOccupancyFraction=75  
#-XX:+UseCMSInitiatingOccupancyOnly

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 11, 2022, 3:17pm UTC](https://discuss.elastic.co/t/failed-to-add-match-elasticsearch-invalid-argument/294388/3 "2022-02-11T15:17:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
