# Failed to Authenticate User after Installing X-Pack

**URL:** <https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861>\
**Category:** Elasticsearch\
**Created:** [March 7, 2018, 10:38am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861 "2018-03-07T10:38:55Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ong/32/40766_2.png) [@Ong](https://discuss.elastic.co/u/Ong)\
**Post date:** [March 7, 2018, 10:38am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861/1 "2018-03-07T10:38:55Z")

</div>

I installed elasticsearch, kibana and x-pack all with version 6.2.2. I followed the steps described in the official documentation at [Install X-pack on Elasticsearch](https://www.elastic.co/guide/en/elasticsearch/reference/6.2/installing-xpack-es.html)

There were no errors along the way.

The problem came when I tried to set up passwords for the built in users like elastic and kibana. When I ran the "setup-passwords interactive" command, there was a message:

> Connection failure to: [http://10.1.2.3:9200/\_xpack/security/user/kibana/\_password?pretty](http://10.1.2.3:9200/_xpack/security/user/kibana/_password?pretty)  
> failed: Read timed out ERROR: Failed to set password for user kibana

The same error message appeared when I ran the "setup-passwords auto" command.

I am not sure if there is even the elastic and kibana users created because when I ran the command:

> curl -u my\_admin -XGET [http://10.1.2.3:9200/\_xpack/security/users](http://10.1.2.3:9200/_xpack/security/users)

the output was an empty json. (my\_admin is a user which was created using the users batch file in the bin\x-pack folder. This user has a superuser role)

Currently, I am not able to log into Kibana as well. The login page is disabled with the message "Login is currently disabled. Administrators should consult the Kibana logs for more details".

What should I do to correct this users problem?

---

<div class="post-metadata">

**Author:** ![jspeer](https://avatars.discourse-cdn.com/v4/letter/j/5f8ce5/32.png) [@jspeer](https://discuss.elastic.co/u/jspeer)\
**Post date:** [March 7, 2018, 3:38pm UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861/2 "2018-03-07T15:38:54Z")

</div>

I have no help for you, but I'm having the same issue with 6.2.1 at the moment. If/when I get an answer.

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [March 8, 2018, 1:07am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861/3 "2018-03-08T01:07:35Z")

</div>

> [@Ong](#):
>
> The problem came when I tried to set up passwords for the built in users like elastic and kibana. When I ran the "setup-passwords interactive" command, there was a message:
> 
> ```
> Connection failure to: http://10.1.2.3:9200/_xpack/security/user/kibana/_password?pretty
> failed: Read timed out ERROR: Failed to set password for user kibana
> 
> ```

It is likely that this is caused by some sort of underlying cluster problem and has nothing specific to do with the `setup-passwords` process.

Since you have security enabled, and haven't yet set a password for the builtin users, it can be tricky to diagnose the cluster health issues (but there a couple of options for that if you need).

The easiest first step is to check the elasticsearch logs. The [location of the logs directory](https://www.elastic.co/guide/en/elasticsearch/reference/6.2/path-settings.html) can vary depending on how you installed Elasticsearch (OS package, vs zip/tgz) and any configuration changes you've made. Locate the `elasticsearch.log` file within your logs directory, and check for any error messages.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 5, 2018, 1:07am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-after-installing-x-pack/122861/4 "2018-04-05T01:07:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
