# Failed to authenticate user \[elastic\] on Kibana v.6.4.0

**URL:** <https://discuss.elastic.co/t/failed-to-authenticate-user-elastic-on-kibana-v-6-4-0/156195>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [November 11, 2018, 11:45am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-elastic-on-kibana-v-6-4-0/156195 "2018-11-11T11:45:34Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Okay\_SK](https://avatars.discourse-cdn.com/v4/letter/o/c2a13f/32.png) [@Okay\_SK](https://discuss.elastic.co/u/Okay_SK)\
**Post date:** [November 11, 2018, 11:45am UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-elastic-on-kibana-v-6-4-0/156195/1 "2018-11-11T11:45:35Z")

</div>

$ curl -XPUT -u elastic 'localhost:9200/\_xpack/security/user/elastic/\_password' -H "Content-Type: application/json" -d '{  
"password" : “1234”  
}'  
Enter host password for user 'elastic':  
{"error":{"root\_cause":[{"type":"security\_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security\_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}},"status":401}%

My license is basic but i have used 'trial type'. So i want to give different access to users by using x-pack that is installed by default elastic v6.4.0  
I think [elastic]'s default passwd is 'changeme'. but above error appeared.

1. How can I solve this issue?

2. How can I initialize x-pack on Elastic,Kibana v6.4.0?

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [November 11, 2018, 12:14pm UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-elastic-on-kibana-v-6-4-0/156195/2 "2018-11-11T12:14:09Z")

</div>

Hi there

There's no default password for the elastic user . You can set the password of the internal users using [the setup-passwords](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-passwords.html) utility.

You can read more [in our documentation](https://www.elastic.co/guide/en/elastic-stack-overview/current/setting-up-authentication.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 9, 2018, 12:14pm UTC](https://discuss.elastic.co/t/failed-to-authenticate-user-elastic-on-kibana-v-6-4-0/156195/3 "2018-12-09T12:14:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
