# Failed to bind to \[9300-9400\]

**URL:** <https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294>\
**Category:** Elasticsearch\
**Created:** [October 21, 2018, 5:52pm UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294 "2018-10-21T17:52:01Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikygee](https://avatars.discourse-cdn.com/v4/letter/m/57b2e6/32.png) [@mikygee](https://discuss.elastic.co/u/mikygee)\
**Post date:** [October 21, 2018, 5:52pm UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294/1 "2018-10-21T17:52:01Z")

</div>

Hello,

I reinstalled elastic search and I'm not able to start it

```auto
[2018-10-21T19:41:44,265][INFO][o.e.n.Node] [] initializing ...
[2018-10-21T19:41:44,383][INFO][o.e.e.NodeEnvironment] [-6v8xhD] using [1] data paths, mounts [[/var (/dev/sd0e)]], net usable_space [3.2gb], net total_space [4.4gb], types [ffs]
[2018-10-21T19:41:44,383][INFO][o.e.e.NodeEnvironment] [-6v8xhD] heap size [1.9gb], compressed ordinary object pointers [true]
[2018-10-21T19:41:44,384][INFO][o.e.n.Node] [-6v8xhD] node name derived from node ID [-6v8xhDLQO2bwLoP8UeHYQ]; set [node.name] to override
[2018-10-21T19:41:44,385][INFO][o.e.n.Node] [-6v8xhD] version[6.4.1], pid[93193], build[oss/tar/e36acdb/2018-09-13T22:18:07.696808Z], OS[OpenBSD/6.4/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_172/25.172-b11]
[2018-10-21T19:41:44,385][INFO][o.e.n.Node] [-6v8xhD] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.io.tmpdir=/tmp/elasticsearch.ykodwIAb, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -XX:+PrintGCDetails, -XX:+PrintGCDateStamps, -XX:+PrintTenuringDistribution, -XX:+PrintGCApplicationStoppedTime, -Xloggc:/var/log/elasticsearch/gc.log, -XX:+UseGCLogFileRotation, -XX:NumberOfGCLogFiles=32, -XX:GCLogFileSize=64m, -Des.path.home=/usr/local/elasticsearch, -Des.path.conf=/etc/elasticsearch, -Des.distribution.flavor=oss, -Des.distribution.type=tar]
[2018-10-21T19:41:46,625][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [aggs-matrix-stats]
[2018-10-21T19:41:46,626][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [analysis-common]
[2018-10-21T19:41:46,626][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [ingest-common]
[2018-10-21T19:41:46,626][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [lang-expression]
[2018-10-21T19:41:46,626][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [lang-mustache]
[2018-10-21T19:41:46,626][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [lang-painless]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [mapper-extras]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [parent-join]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [percolator]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [rank-eval]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [reindex]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [repository-url]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [transport-netty4]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] loaded module [tribe]
[2018-10-21T19:41:46,627][INFO][o.e.p.PluginsService] [-6v8xhD] no plugins loaded
[2018-10-21T19:41:55,126][INFO][o.e.d.DiscoveryModule] [-6v8xhD] using discovery type [zen]
[2018-10-21T19:41:56,471][INFO][o.e.n.Node] [-6v8xhD] initialized
[2018-10-21T19:41:56,472][INFO][o.e.n.Node] [-6v8xhD] starting ...
[2018-10-21T19:41:56,612][ERROR][o.e.b.Bootstrap] [-6v8xhD] Exception
org.elasticsearch.transport.BindTransportException: Failed to bind to [9300-9400]
        at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:821) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:786) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:134) ~[?:?]
        at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:66) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.transport.TransportService.doStart(TransportService.java:217) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:66) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.node.Node.start(Node.java:667) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:265) ~[elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:335) [elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) [elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) [elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.4.1.jar:6.4.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.4.1.jar:6.4.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) [elasticsearch-6.4.1.jar:6.4.1]
Caused by: io.netty.channel.ChannelException: Unable to create Channel from class class io.netty.channel.socket.nio.NioServerSocketChannel
        at io.netty.channel.ReflectiveChannelFactory.newChannel(ReflectiveChannelFactory.java:40) ~[?:?]
        at io.netty.bootstrap.AbstractBootstrap.initAndRegister(AbstractBootstrap.java:321) ~[?:?]
        at io.netty.bootstrap.AbstractBootstrap.doBind(AbstractBootstrap.java:283) ~[?:?]
        at io.netty.bootstrap.AbstractBootstrap.bind(AbstractBootstrap.java:279) ~[?:?]
        ... 15 more

```

I took the same configuration as before

```auto
# grep -v '#' /etc/elasticsearch/elasticsearch.yml
path.data: /var/elasticsearch/
path.logs: /var/log/elasticsearch/

```

I ever tried to add

```auto
network.host: 0.0.0.0

```

No luck

My previous elastic was 5.2.2 and now 6.4.1

This is a single machine

Someone as an idea ?

Because I saw other people's problem

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [October 22, 2018, 8:37am UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294/2 "2018-10-22T08:37:54Z")

</div>

what operating system/JVM is this?

Can you put the whole log file output in a gist somewhere and link to it?

Thanks!

--Alex

---

<div class="post-metadata">

**Author:** ![mikygee](https://avatars.discourse-cdn.com/v4/letter/m/57b2e6/32.png) [@mikygee](https://discuss.elastic.co/u/mikygee)\
**Post date:** [October 22, 2018, 2:44pm UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294/3 "2018-10-22T14:44:38Z")

</div>

Hello,

Thank you for your answer. I use Openbsd 6.4

The complete log file is here  
[https://pastebin.com/vvLxBBs7](https://pastebin.com/vvLxBBs7)

grep -v '#' /etc/elasticsearch/elasticsearch.yml  
path.data: /var/elasticsearch/  
path.logs: /var/log/elasticsearch/  
network.host: 0.0.0.0

ls -la /var/elasticsearch/  
total 12  
drwxrwx--- 3 \_elasticsearch \_elasticsearch 512 Oct 21 15:24 .  
drwxr-xr-x 30 root wheel 1024 Oct 22 08:36 ..  
drwxr-xr-x 3 \_elasticsearch \_elasticsearch 512 Oct 21 15:24 nodes

Thank you

---

<div class="post-metadata">

**Author:** ![mikygee](https://avatars.discourse-cdn.com/v4/letter/m/57b2e6/32.png) [@mikygee](https://discuss.elastic.co/u/mikygee)\
**Post date:** [October 31, 2018, 12:05am UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294/4 "2018-10-31T00:05:19Z")

</div>

I tried to make many other tests but no success, I'm still stucked.  
I don't understand how it's possible to debug such logs...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 28, 2018, 12:05am UTC](https://discuss.elastic.co/t/failed-to-bind-to-9300-9400/153294/5 "2018-11-28T00:05:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
